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CHAPTER 1

Welcome to Parallels Desktop

Congratulations on purchasing Parallels Desktop 12 for Mac. You no longer have to choose
between the Mac and the PC. Parallels Desktop lets you use Windows side-by-side with OS X on
your Mac.

Use this guide to quickly set up and start using Parallels Desktop.

In This Chapter

WHat YOU CAN DO ..ottt e e 10
Set Up Your Mac to Use WINdOWS ProgramsS ........cceeeeeeiiiinniiiiiiiniinniinniinininnnnnninn. 10
Other Operating SYSTEIMS ....coiiiiiiiiiiiice e 10



Welcome to Parallels Desktop

What You Can Do

With Parallels Desktop, you can:

= Open Windows applications side-by-side with your Mac OS X applications, without having to
restart

« Copy and paste text and drag and drop objects between Mac and Windows applications
= Run Windows games and other 3D programs

= Transfer all your data from a PC and use it on your Mac

= FEasily share files, devices, and other resources between Windows and the Mac

= |Install other operating systems, such as trial versions of Windows, Linux, another copy of OS X,
and free virtual appliances; and use them together

e And much more

Set Up Your Mac to Use Windows Programs

After just a few steps, you can begin using Windows programs on your Mac. Setting up your Mac
to run Windows programs involves the following steps:

Step 1: Install Parallels Desktop (p. 12).
Step 2: Install Windows on your Mac (p. 18).
Step 3: Install your Windows programs (p. 36).

You only need to follow these steps once. Then you can open and use your Windows programs on
your Mac anytime you like, just as you do with your Mac applications.

Other Operating Systems

Important: This guide is focused on using Parallels Desktop with Windows.

Using Parallels Desktop 12 for Mac you can run several other kinds of operating systems (p. 110)
on your Mac, such as several flavors of Linux and Unix, Mac OS X Server, Windows 8, older
versions of Windows, and more.

10



Welcome to Parallels Desktop

Finding Information On Running Other Operating Systems

You can find much more information and details on using Parallels Desktop to run other operating
systems on your Mac by checking the resources listed in More Resources (p. 211).

Additionally, though not explicitly stated, many of the instructions presented in this guide also apply
to supported operating systems other than Windows. And some important instructions relating to
other operating systems are in the Advanced Topics (p. 110) section.

11



CHAPTER 2

Install or Upgrade Parallels Desktop

Follow the instructions in this chapter to install or upgrade Parallels Desktop.

Note: You can either purchase a boxed version of Parallels Desktop 12 or purchase and download it
from the Parallels website.

In This Chapter

What YOU NEEA .....oooiiiiii 12
INStall Parallels DESKIOD . ...vuuiiiiiii e 13
Activate and Register Parallels DeskiOp .......cuuviiiiiiiiiiiiiii e 13
Purchase Parallels DESKIOD .vvvvuiiiiiiiiciiiiiiii e e 14
Upgrade Parallels DESKIOPD. .. ....uueetiiiiiiiiiiiiiiiiieeieeiieeeeeeeeeeee ettt eeeeeeeeeeeeas 14
SEETNE LANGUAGE - . i e 17

What You Need

To install and set up Parallels Desktop 12 for Mac, you need:

= A Mac computer with:

= AnIntel Core 2 Duo, Core i3, Core i5, Core i7, Intel Core M or Xeon processor (Core Solo
and Core Duo processors are no longer supported).

Note: Parallels Desktop can only be installed on Intel-based Macs running the 64-bit kernel.
Please see http://support.apple.com/kb/HT3770 for more details.

e Atleast 2GB of RAM (4GB recommended)

Note: Your Mac must have enough RAM memory to use Mac OS X and its applications plus the
memory required for each additional operating system (and its programs) that you want to use
simultaneously.

= Atleast 850 MB of space available on the boot volume (the volume that has OS X) for
Parallels Desktop installation

= Enough free disk space for each virtual machine and its applications (at least 15 GB for each
installation of Windows)

e (OS X Yosemite 10.10 or later, OS X Mavericks 10.9.4 or later

To identify your computer's processor, memory, and OS X version, choose Apple menu >
About This Mac.



Install or Upgrade Parallels Desktop

= Internet connection required for product activation, select features, and online updates
= One of the following:

= A Windows installation disc, or other installation media for the operating systems you want
to use alongside OS X

= An Internet connection to download and install freely available operating system such as
Ubuntu or Google Chrome.

= |fyou're using OS X Lion or later, you can set up a second copy of OS X to be used as a
guest operating system alongside your main system, without having to purchase or
download another copy of OS X.

For a list of operating systems that Parallels Desktop supports for use with your Mac, see
Supported Guest Operating Systems (p. 110) or go to
http://www.parallels.com/products/desktop/system-requirements/.

Install Parallels Desktop

You can be up and running with Parallels Desktop in a few easy steps:

1 Make sure you have the latest version of OS X.
2 Do one of the following:

= If you downloaded Parallels Desktop from the Parallels website, double-click the disk image
file, most likely in your Downloads folder (the file has the extension ".dmg" at the end).

= If you purchased a boxed copy of Parallels Desktop with a USB thumb drive, connect the
drive to your Mac, open it and double-click the disk image file.

= |f you purchased a boxed copy with a link to the installation file, open the link in your web
browser, download Parallels Desktop and double-click the disk image file.

= |f you purchased a boxed copy with an installation disc, insert the disc.

Note: If your Mac doesn't have a DVD-ROM, you can use the download link, available in the retail box,
to download Parallels Desktop over the Internet.

3 Double-click the Install icon and follow the onscreen instructions to install Parallels Desktop.

Activate and Register Parallels Desktop

Once Parallels Desktop is installed, you need to activate it and register. Do the following:

1 First you need to sign in to your Parallels account:

= [f you have an account, enter your email address, select | have a password, enter the
password and click Sign In.

13



Install or Upgrade Parallels Desktop

= If you don't have a Parallels account, enter an email address that will be used to create the
account, select I'm a new user, click Sign In and follow the onscreen instructions.

2 Inthe next step, you must enter your Product Activation Key to activate Parallels Desktop.

Note: If you purchased Parallels Desktop from the Parallels Online Store, a key was sent to the email
address you provided. If you bought a boxed copy, you can find your key printed on the installation disc
sleeve.

If you already have a license available and associated with your account, just select the license
and click Activate.

If You Don't Have A Product Activation Key

If you don't have a key already, you can get a free trial Product Activation Key so you can try out
Parallels Desktop for a limited time, click Try Free for 14 days. Or to purchase a key that lets you
use Parallels Desktop permanently, click Buy.

Purchase Parallels Desktop

If you're using a trial version of Parallels Desktop 12, you can easily purchase the full version right
from the application interface. To do so:

1 Click Buy in the About Parallels Desktop window or when you see the promo.
2 Choose one of the following:

= Upgrade: Select this option to upgrade your current version of Parallels Desktop. Please
keep in mind that you will need the activation key for your previous version. If the Upgrade
option is selected by default, Parallels Desktop has already automatically detected the key
for the previous version. If not, please make sure you have it.

Note: Only Parallels Desktop 10 and 11 can be upgraded to Parallels Desktop 12.

= Buy Full Version: Select this option to purchase Parallels Desktop if you have never used it
before or your version cannot be upgraded.

3 Follow the onscreen instructions.You may need to scroll down to see all the information.

Upgrade Parallels Desktop

If you already have Parallels Desktop 10 or 11 follow these steps to upgrade to Parallels Desktop
12.

1 If you haven't already done so, purchase and download a "Parallels Desktop 12 for Mac
Upgrade," available from the Parallels Online Store at www.parallels.com/buyonline.

A Product Activation Key is sent to the email address you provide.

14



Install or Upgrade Parallels Desktop

2 If Parallels Desktop is open, quit Parallels Desktop.
3 Follow the instructions to install Parallels Desktop 12. See Install Parallels Desktop (p. 13).

During installation, the previous version of Parallels Desktop is automatically removed from your
computer.

4 Open Parallels Desktop and enter your upgrade Product Activation Key.

If you were using a trial version of Parallels Desktop or you purchased a previous version but
haven't installed it on your computer, you will also be prompted to enter a full or upgrade key
for that version.

Note: To upgrade from Parallels Desktop 2, 3, 4, 5, 6, 7, 8 or 9 you must purchase Parallels Desktop 12
at full retail price.

Troubleshooting
If you have any problems upgrading Parallels Desktop, you can find troubleshooting information at
http://www.parallels.com/products/desktop/support/.

Install Software Updates

Periodically, Parallels provides free software updates to improve Parallels Desktop.

By default, Parallels Desktop is configured to automatically check for and download available
software updates once a week. When an update is available, Parallels Desktop prompts you to
install it. Simply follow the onscreen instructions.

Adjust Software Update Settings

1 Do one of the following:

= Click the Parallels icon Il in the menu bar and choose Preferences. Then click General.

15



Install or Upgrade Parallels Desktop

= Right-click the Parallels Desktop icon in the Dock and choose Preferences. Then click

General.
& w General

0 =, P @ L = S
General Shortcuts Devices Security Network Advanced Toolbox Access

Parallels menu: Show Parallels icon in menu bar

Virtual Machines Folder: Parallels H
Virtual Machine Dock lcons: Live Screenshot ﬁ
Check for Updates: Once a week ﬂ

Download updates automatically
Check Now

0S X Resume: Disable for Parallels Desktop

Virtual machines shut down according
to their startup and shutdown settings.

i:{“ Click the lock to prevent further changes.

2 Do one of the following:

= To adjust the frequency that Parallels checks for software updates, choose Never, Once a
Day, Once a Week, or Once a Month from the Check for Updates menu.

= To choose whether you want Parallels Desktop to download updates automatically, select
or deselect Download updates automatically.

If you choose not to download updates automatically, Parallels Desktop notifies you when
an update is available and asks whether you want to download it.

Check for an Update Manually

= Follow the instructions in step 1 above and then click Check Now. You can also choose
Check for Updates from the Parallels Desktop application menu.

Note: To check for updates and download them, your Mac must be connected to the Internet.

16



Install or Upgrade Parallels Desktop

Set the Language

You can set which language the Parallels Desktop interface uses by doing the following:

1 Quit Parallels Desktop.

2 Choose Apple menu > System Preferences > Language & Region.

3 Drag the language you want to the top of the list. If you don't see the language you want to use
in the list, click the Add button | * |,

4 Open Parallels Desktop.

If the primary language you chose is supported by Parallels Desktop, the menus and interface
text appear in that language. If the primary language you selected isn't supported, menus
appear in the first language listed that Parallels Desktop supports.

17



CHAPTER 3

Install or Import Windows

There are a few ways to get Windows up and running on your Mac:

= Install Windows (p. 18)

e Import your data from a Windows PC (p. 20)

« Use Windows that you already have installed from a Boot Camp partition (p. 29)

= Import Windows from a previous version of Parallels Desktop or other virtualization software (p.
30)

In This Chapter

INSTAI VWINAOWS ...ttt e e e e eeees 18
IMmport Your Data from @ PO .......eeeiiiiiiiieiiiiie et eee e 20
Use Boot Camp with Parallels Desktop ......oooovieiiioiiiis e 29
Import from an Earlier Parallels Desktop or Other Virtualization Application................ 30

Install Windows

If you have a Windows installation source (a DVD disc, an image file, or a USB storage) and a valid
Windows product key, you can install Windows on your Mac and use it with Parallels Desktop.

To install Windows:

1 Open Parallels Desktop (in the Applications folder) and choose File > New.

2 If you have a Windows installation disc, insert it into the DVD drive. If you have a USB storage
with Windows, connect the storage to the Mac.

Click Install Windows or another OS from a DVD or image file.

Parallels Desktop scans for and lists installable operating systems. If you see the version of
Windows you want to install, select it, click Continue and go to step 6.

5 If the Windows installation source didn't show up automatically in Step 4, click Locate
manually to browse for it manually. You can browse from the following sources:

= DVD: If you have a Windows DVD, insert it into the DVD drive. Once Windows is detected,
click Continue. If your Mac doesn't have a DVD drive, you can use an Apple SuperDrive,
another Mac's DVD drive via Remote Disc, or make an image from the disc.



Install or Import Windows

= Image File: If you have a Windows image file, click Image File and drag the image to the
Parallels Wizard window. Once Windows is detected, click Continue.

« USB Drive: If you have a bootable USB installer with Windows, click USB Drive and
connect the drive to the Mac. Once Windows is detected, click Continue.

Note: Parallels Desktop may fail to detect some operating systems (for example, the latest Linux
distributions). If this happens but you're sure that the operating system can be installed, click Continue,
specify the OS type manually (if it's not listed, choose Other), and follow the onscreen instructions.

6 Be sure to leave Express installation selected.

Note: If you deselect Express installation, you'll need to install Parallels Tools (p. 199) after the
installation to allow the most seamless operation between Windows and Mac OS X.

7 Choose what for you're going to primarily use Windows. Its settings will be tuned to best fit
your needs.

8 Choose where you want to store Windows from the Location menu.

By default, Parallels Desktop stores Windows in your Documents > Parallels folder. To
allow all users of your computer to have access to this installation of Windows, select Share
with other users of this Mac.

9 If you want to pre-set things like how much memory Windows uses or whether it starts
automatically when you open Parallels Desktop, select Customize settings before
installation. You can also adjust these settings after the operating system is installed.

10 Click Continue.

The assistant installs Windows.

Once Windows is installed, you can start it up by opening a Windows program (p. 32) or by clicking
the power button in Control Center.

B

0o
LAl

@ & Control Center

Ubuntu Linux 1

Windows

Windows

Windows XP
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Important: The first time you start Windows, Parallels Tools are installed to allow seamless operation
between Windows and Mac OS X. Once Parallels Tools are installed, you're prompted to restart
Windows.

If you didn't select Express installation in step 6 above, you must install Parallels Tools manually (p.
199).

When you install Windows, Parallels Desktop creates an administrator account with a blank
password. Once the installation is complete, it is recommended that you change this password.

Note: You can also install Windows from a disk image file (p. 172) of an installation disc. Simply choose
the disk image file in step 4 above. Parallels Desktop supports ISO, DMG, CUE, and CCD disk images.

Import Your Data from a PC

You can import all your data from a Windows PC to Parallels Desktop on your Mac. Then you can
continue to work with all your Windows programs, files, and data, side-by-side with Mac OS X.

Overview of Methods for Importing

You can import your data using one of the following:

= Network (p. 21): If both the Windows PC and your Mac are connected to a network, you can
import your data over the network.

= External storage device (p. 24): You can transfer the data from a Windows PC to an external
storage device, such as an external hard drive. Then, you can connect the device to your Mac
and import your data into Parallels Desktop.

Requirements for Importing Your Data

To import your data to your Mac, you need a Windows computer with:

Windows 10, Windows 8, Windows 7, Windows Vista, or Windows XP with Service Pack 2 or
later.

Note: You can also use a computer running Windows Server 2008 R2 (64-bit only), Windows Server
2008, or Windows 2000 Professional (32-bit only).

= AnIntel or AMD (700 MHz or higher) x86 or x64 processor

e Atleast 256 MB of RAM

= Atleast 70 MB of hard disk space for installing Parallels Transporter Agent
« One of the following:

= An Ethernet port for transferring your data over network
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= An external storage device, such as a USB hard disk

Note: Parallels Desktop does not support migrating Windows dynamic volumes. These are volumes
which size is not fixed as in basic volumes. They are migrated as data disks only. You can later add them
(p. 170) to an already existing virtual machine.

Step 1: Install Parallels Transporter Agent on Your Windows PC

To import your data you must first install the Parallels Transporter Agent software on the Windows
PC.

To install Parallels Transporter Agent:

11 Do one of the following:

= |[f you purchased a physical copy of Parallels Desktop, insert the Parallels Desktop
installation DVD into your Windows PC. If the installation doesn't start automatically, locate
and double-click the Parallels Transporter Agent.exe file on the disc.

= Download Parallels Transporter Agent for Windows from the Parallels website at
http://www.parallels.com/download/desktop/ and double-click the installation file.

If your computer is connected to the Internet, Parallels Transporter Agent checks for available
updates. If an update is available, click Download and Install New Version.

12 Follow the onscreen instructions to install Parallels Transporter Agent.

Step 2: Import Your Data
Follow one of the methods below to import your data from your PC to your Mac.
Over a Network

Important: After importing your data, you may need to reactivate some of your Windows programs
using the activation keys you received when you purchased the programs.

To import your data from a PC over a network:

1 Turn on your Mac and your Windows PC and log in.

2 Make sure that Windows Firewall (p. 28) is turned off. You can turn it on again after the import is
finished.
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3 On the Windows PC, open Parallels Transporter Agent by clicking the Start menu and choosing
All Programs > Parallels > Parallels Transporter Agent.

#| Parallels Transporter Agent - O

Continue

In Parallels Transporter Agent, select Network and click Continue.
On your Mac, open Parallels Desktop and choose File > New.
Select Transfer Windows from a PC and click Continue.

Select Network and click Continue.

N O o »

Find the passcode displayed in Parallels Wizard on your Mac and enter it in Parallels
Transporter Agent on your Windows PC.
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If the remote PC and Mac are not connected to the same network, you can transfer the remote
PC using its name or IP address. To do so, click Connect using IP address, select the
Windows PC name from the list or type the IP address, and click Continue.

[-NsNg] Parallels Wizard

NEE IP address

astarovoitov 10.30.16.152

8 If you have chosen to use the computer name or IP address, provide the Windows
administrator credentials. Parallels Desktop connects to Parallels Transporter Agent and starts
collecting information about the source computer.

9 If you want to log in to Windows automatically whenever you start up Windows, select Enable
Automatic Logon. When ready, click Continue.

10 Choose what you want to transfer;

= System only: this option allows you to transfer the operating system and applications only.
If you choose it, go to step 12.

= System and documents: this option allows you to transfer the operating system,
applications, and user's files like pictures, documents, downloads, music, videos, etc.

11 If you chose to transfer system and documents in the previous step, choose how you want to
transfer the user's files:

= Transfer to Windows: If you choose this option, the user's files will be transferred to the
resulting virtual machine and will not be accessible from OS X. You can make them
accessible from OS X later by sharing Windows with OS X (p. 52).

= Transfer to Mac: If you choose this option, the user's files will be transferred to the
corresponding folders in OS X. The resulting virtual machine will have access to these files
as well because it will be configured to share folders with OS X.

This way of transferring the user's files requires additional steps with Apple Migration
Assistant. Follow the link in the screen for more information.
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12 Choose where you want to install your data.

@ Parallels Wizard

Windows 10

M Farallels

Required: 53.6 GB

Available: B17.2 GB

When ready, click Continue.

13 In the next step there's a warning about Windows activation that might be required when you
start using it. To proceed, read this message, select | want to continue and click Continue.

14 Once the transfer is complete, click Done.
15 Start Windows (p. 31).

16 When Windows boots up, choose Actions > Install Parallels Tools and follow the onscreen
instructions.

Note: To be able to install Parallels Tools, you must be logged in to Windows as an administrator.

Using an External Storage Device

Important: After importing your data, you may need to reactivate some of your Windows programs
using the activation keys you received when you purchased the programs.

To import your data from a PC using an external storage device:

1 Connect an external storage device to your Windows PC.
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On the Windows PC, open Parallels Transporter Agent by clicking the Start menu and choosing
All Programs > Parallels > Parallels Transporter Agent.

Select External storage and click Continue. Parallels Transporter Agent collects information
about the Windows PC.

If you want to log in to Windows automatically whenever you start up Windows, select Enable
Automatic Logon and specify the Administrator's password. When ready, click Continue.

Choose what you want to transfer;

= System only: this option allows you to transfer the operating system and applications only.
If you choose it, go to step 7.

= System and documents: this option allows you to transfer the operating system,
applications, and user's files like pictures, documents, downloads, music, videos, etc.

If you chose to transfer system and documents in the previous step, choose how you want to
transfer the user's files:

< Transfer to Windows: If you choose this option, the user's files will be transferred to the
resulting virtual machine and will not be accessible from OS X. You can make them
accessible from OS X later by sharing Windows with OS X (p. 52).

= Transfer to Mac: If you choose this option, the user's files will be transferred to the
corresponding folders in OS X. The resulting virtual machine will have access to these files
as well because it will be configured to share folders with OS X.

This way of transferring the user's files requires additional steps with Apple Migration
Assistant. Follow the link in the screen for more information.
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7 Choose where you want to store your data. You can also click Customize and select which
Windows volumes to migrate.

#| Parallels Transporter Agent - O *

Windows 10

= Ef

Required: 53.6 GB

Available: 315.7 GB

Refresh

Continue

When ready, click Continue.

8 In the next step there's a warning about Windows activation that might be required when you
start using it. To proceed, read this message, select | want to continue and click Continue.

9 Once the migration is complete, click Done to quit Parallels Transporter Agent.
10 Disconnect the storage device from the Windows PC and connect it to your Mac.
11 On your Mac, open Parallels Desktop and choose File > New.

12 Select Transfer Windows from a PC and click Continue.

13 Select External storage and click Continue.

14 Parallels Desktop scans the connected storages for the newly created virtual machine. If
Parallels Desktop cannot find it, select the virtual machine manually. Then click Continue.

15 Choose where you want to install Windows and your data, and then click Continue.
16 Once the transfer is complete, click Done.
17 Start Windows (p. 31).

18 When Windows boots up, choose Actions > Install Parallels Tools and follow the onscreen
instructions.
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Note: To be able to install Parallels Tools, you must be logged in to Windows as an administrator.

Solving Problems

Read this section if you have problems importing your data from a Windows PC.

General Tips

This section provides solutions to some errors that may occur during the import process.

Parallels Transporter Agent Doesn't Work Correctly

If you experience any problems while importing, make sure that the snapman . sys driver is
installed in C:\WINDOWS\system32\drivers\.

If the snapman . sys driver is not installed, follow these steps:

Uninstall Parallels Transporter Agent.
Restart your Windows PC.
Reinstall Parallels Transporter Agent.

Restart your Windows PC again.

a Hh ON =

Try to import Windows and your data again.

Import is Interrupted by an Error

If the import process is interrupted by an error, do the following:

From the Start menu, choose My Computer.

2 In the Hard Disk Drives pane, right-click the volume you want to import, and choose
Properties.

3 Inthe Properties pane, click the Tools tab, and in the Error Checking section, click the
Check Now button.

4 In the Check Disk window, select Automatically fix file system errors and Scan for and
attempt recovery of bad sectors, and then click Start.

5 Wait till the disk is scanned and errors are fixed.

Dynamic Volumes are not Imported

Only basic volumes can be imported. You can't import dynamic volumes using Parallels Desktop.

The only way to import the data stored on a dynamic disk is to copy the data to a basic disk on
your Mac and then import the basic disk.
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If Your Mac Fails to Connect with Parallels Transporter Agent

Firewall applications may block connections between your Mac and Parallels Transporter Agent on
the Windows PC.

Firewall problems in Mac OS X

If your Mac fails to connect with Parallels Transporter Agent on your Windows PC, the reason may
be that the built-in Mac firewall blocks the connection to Parallels Transporter Agent.

To enable connections between your Mac and Parallels Transporter Agent and prevent further
blocking, you can configure the firewall settings in Mac OS X by doing the following:

1 From the Apple menu, choose System Preferences, and then click Security.
2 C(Click the Firewall tab.

3 Configure the necessary settings.

If you try to search for Parallels Transporter Agent by typing the Windows PC IP address manually,
you may receive a message saying that Parallels Transporter Agent is blocked. Click the Unblock
button.

Firewall problems in Windows

Microsoft Windows operating system has a built-in firewall that blocks connections to and from
other computers. When starting Parallels Transporter Agent for the fist time, you may see a
message saying that Windows Firewall has blocked some features of the program.

To enable the connection between your Mac and Parallels Transporter Agent, click Unblock.

To prevent this problem from happening again, add Parallels Desktop and/or Parallels Transporter
Agent to the firewall exceptions (the list of applications allowed to communicate through the
firewall):

1 From the Start menu, choose Control Panel > Network Connections.

2 In the Network Tasks pane, click Change Windows Firewall Settings.

3 Add Parallels Desktop and/or Transporter Agent to the firewall exceptions list.

If Parallels Doesn't Detect Windows Correctly

If Parallels Desktop detects the source operating system (Microsoft Windows XP or Windows Vista
computer) incorrectly, make sure that neither of your Windows programs are running in
compatibility mode - a special mode of Windows allowing you to run applications that are
incompatible with your version of Windows.

See Windows Help for more information.
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Problems Using a Program After an Import
Programs that depend on specific hardware may not work in Parallels Desktop.

If you import from several source volumes, the disk drive letters are changed. Make sure that the
program paths are set correctly. See Windows Help for more information.

Use Boot Camp with Parallels Desktop

Boot Camp is a feature of Mac OS X that lets you start up your Mac in Windows. If you have
already installed Windows 8, Windows 7, Windows Vista, or Windows XP on your Mac using Boot
Camp, you can set Parallels Desktop to work with Boot Camp using either of these two options:

= Set Parallels Desktop to run Windows from the Boot Camp partition: Changes you make in
Windows programs either while working in Mac OS X or when you start up your Mac in
Windows using Boot Camp will be reflected in both places.

Windows running from Boot Camp has the following limitations:
* [t can't be paused

e |t can't be saved as a snapshot (p. 121)

e [t can't run in Rollback Mode (p. 93)

e [t can't be compressed

= Import Windows and your data from Boot Camp into Parallels Desktop: Windows running
from Parallels Desktop doesn't have the above listed limitations. Boot Camp and Parallels
Desktop are separate. Changes you make in Windows programs while working in Mac OS X
are not reflected when you start up your Mac in Windows using Boot Camp.

Set Parallels Desktop to run Windows from the Boot Camp Partition

1 Open Parallels Desktop (in the Applications folder) and choose File > New.

2 Click Boot Camp, and then follow the onscreen instructions.

Note: If you plan to start up in Windows using Boot Camp, it is recommended that you shut down
Windows in Parallels Desktop rather than suspending Windows.

Import Windows and Your Data from Boot Camp into Parallels Desktop

1 Set Parallels Desktop to use Boot Camp, as described in the steps above.

2 Right-click (Control-click) the Boot Camp version of Windows in Control Center and choose
Import Boot Camp.

Note: Windows must be shut down.

3 Click Import.
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4 | ocate where you want to store Windows and your data, and then click Choose.

Windows and all your data are imported from Boot Camp. You can still use the original Boot
Camp Windows installation, separately from Parallels Desktop.

Important: The first time you start Windows after setting Parallels Desktop to work with Boot Camp,
Parallels Tools are installed to allow seamless operation between Windows and Mac OS X. Once Parallels
Tools are installed, you're prompted to restart Windows.

Import from an Earlier Parallels Desktop or Other
Virtualization Application

With Parallels Desktop 12 for Mac you can use Windows that you set up using earlier versions of
Parallels Desktop, as well as VMware Fusion, Microsoft Virtual PC, and VirtualBox:

1 Open Parallels Desktop (in the Applications folder) and choose File > Open.

2 Select the Windows data file you want to import, then click Open and follow the onscreen
instructions.

= Parallels Desktop data files end with . pvm.

= VMware files end with .vmx.

= Virtual PC files end with .vmc.

= VirtualBox files end with .xml or .vbox.

You can also simply drag a Parallels . pvm file to Control Center to add it to Parallels Desktop.

3 Start Windows (p. 31).
4 Choose Actions > Install Parallels Tools and follow the onscreen instructions.
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CHAPTER 4

Use Windows on Your Mac

Read this chapter to find out all about using Windows programs on your Mac. Learn how to get
started using Windows programs, set how Windows programs work with Mac OS X, share
applications, files, and folders between Mac OS X and Windows, connect devices, print, customize
your keyboard, and more.

In This Chapter
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Get Started

In this section, learn how to start Windows, open a Windows program, install more Windows
programs, and shut down or suspend Windows.

Start Windows

To use Windows programs on your Mac, Windows must be running.

The simplest way to start Windows is to open a Windows program (p. 32). If Windows isn't already
running when you open a Windows program, it starts automatically in Coherence mode (p. 41).
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Important: If Windows was previously shut down, you may need to enter your Windows password.

You can also start Windows by doing the following:

1 Open Parallels Desktop.

2 In Control Center, click the Power Button below Windows.

®00 Parallels Desktop Control Center  [EEll = | [ +

Windows 8.1
O | |

Windows XP

Windows 7 1

3 Click anywhere in the Windows window that appears.

Windows starts and you can begin using Windows programs alongside Mac OS X.

Open a Windows Program

Opening a Windows program is as easy as opening a Mac application. Here are several ways to
open Windows programs:

 From the Windows Applications folder in the Dock

= From the Windows Start menu

= From the Mac OS X Finder

= From the Dock

= Using Spotlight searching

= Using Launchpad (if you are using Mac OS X Lion or later)

Note: All Windows program icons can be easily identified by the Parallels Desktop symbol 1lin the
lower-right corner of the icon.
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Windows Applications Folder

This folder is available in the OS X Dock and contains all your Windows programs. As you install
more programs, they are automatically added.

@ Default Programs

™ Desktop Gadget Gallery
& Internet Explorer

@ Safari

@ Windows DVD Maker

of Windows Fax and Scan
& Windows Media Center
B Windows Media Player
8 Windows Update

“ XPS Viewer

Options
Open in Finder

To open a Windows program using the Windows Applications folder:
= (lick the folder, and then choose a program.
To add the Windows applications folder to the Dock:

1 Do one of the following:
= Click the Parallels icon I in the menu bar and choose Configure.

= |If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.

Click Options and then click Applications.

Be sure Share Windows applications with Mac is selected, and then select Show Windows
applications folder in Dock.

Windows Start Menu

To open a Windows program from the Start menu:

1 Do one of the following:
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= Click the Parallels icon !l in the menu bar and choose Windows Start Menu.

ﬁ Author-it

wj Microteft Woed 2010

Documents

Mn:.r] Notepad

=, Pretures
'| Getting Started

Murac
Q-

:J Compuler
K Microsoft Excel 2000
 S— ]

Condrol Panel
! Connect to & Progectiorn

Dewwces and Printers

OF Microsoft Outiook 2010
o’ Default Programs

Sicky Notes
Help and Support

{ Rermote Desktop Connection

« |f Windows is in Full Screen or Window mode, open the Start Menu as you normally would.

Note: You can also Command-click or Right-click the Parallels icon.

2 C(Click the program you want.

Mac OS X Finder
You can also open a program by double-clicking its icon in the Finder.

To find Windows programs in the Finder:

= Double-click the Windows volume on the desktop, and then open the Program Files folder.
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Note: To show the Windows volume on the desktop, the Mac OS X Finder must be enabled to show
connected servers. Click anywhere on the desktop and choose Finder > Preferences, and then select
Connected servers.

You can make an alias for a Windows program on the Mac OS X desktop, then double-click it
anytime to open the program.

To make an alias for a Windows program on the Mac OS X desktop:

e Select the program in the Finder and choose File > Make Alias. Then drag the alias icon to the
desktop.

Program Icon in the Dock

When you open a Windows program, its icon appears in the Mac OS X Dock at the bottom of the
screen. By default when you close the program, the icon disappears from the Dock. Keeping a
program's icon in the Dock provides a quick way to open the program anytime.

To keep a Windows program's icon in the Dock, do one of the following:

= Right-click or Control-click the Windows program icon in the Dock and choose Keep in Dock
from the shortcut menu.

= Drag the program's icon from the Finder to the Dock.

Now you can open the program again anytime by clicking the icon in the Dock.

Spotlight
You can search for and open Windows programs using Spotlight:

= (lick the Spotlight icon in the upper-right corner of your screen, or press Command-Space bar
on your keyboard. Then type the name of the program and select it from the list.

Launchpad

If you're using Mac OS X Lion or later, you can see a full screen display of all your Windows
programs and Mac applications using Launchpad. Just click the Launchpad icon (looks like a
rocket) in the Dock. You can then click any Mac OS X application to open it. To open a Windows
program, click the Windows folder and then click the program you want.

Note: The Windows folder is available in Launchpad only if sharing Windows programs (p. 58) is
enabled.

To move a Windows program from the Windows folder to a main Launchpad page, do one of the
following:

= From Launchpad, click the folder containing your Windows programs and drag a program to
the Launchpad icon in the Dock.
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= Start the Windows program you want, right-click its icon in the Dock, and choose Add to
Launchpad.

To remove a Windows program from Launchpad, start the program, right-click its icon in the Dock,
and choose Remove from Launchpad.

Install Windows Programs

You install Windows programs on your Mac just as you would on a Windows PC. The two most
common ways of installing programs are:

= Using a CD or DVD installation disc

= Downloading the program or installation file from the Internet or a network

Install a Program from a CD or DVD Installation Disc

1 Start Windows (p. 31).
2 Insert the installation disc.

3 In most cases, an AutoPlay dialog opens. Click the option to run a setup or install file, then
follow the onscreen instructions.

For more information about using CD and DVD discs with Parallels Desktop, see CD/DVD-ROM (p.
183).

Install a Program from the Internet or a Network
= Download the program or installation file and follow the instructions from the program's source.

In most cases, you can either run the installation file and follow the onscreen instructions, or simply
open the downloaded program.

For more information about connecting to the Internet and networks, see Connect to the Internet or
a Network (p. 95).

Shut Down or Suspend Windows

When you're finished using Windows programs, you can leave Windows running in the background
as you work with your Mac applications. Or you may want to stop Windows from running so more
of your computer's resources are available for your Mac applications. There are a few ways to stop
Windows. You can:

e Suspend Windows
= Pause Windows
e Shut down Windows

e Stop Windows
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Suspend Windows

Suspending Windows conveniently freezes all running Windows programs and settings in their
current state.

Do one of the following:

= Quit Parallels Desktop.
= Click the Parallels icon Il in the menu bar and choose Actions > Suspend.

= |f the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Suspend.

The next time you start Windows or open a Windows program, you resume your progress from
exactly where you left off.

When Windows is suspended, you can safely quit Parallels Desktop and resume your progress
later.

Note: If you are using Mac OS X Lion or later and you shut down or restart your computer, or quit
Parallels Desktop, Windows is automatically suspended. The next time you start up Parallels Desktop,
you can resume working with Windows from where you left off. If your Windows is encrypted (p. 94), you
will have to resume it manually.

Pause Windows

You can temporarily pause from using Windows and free your computer's resources, such as RAM
and processor cycles, to be used by your Mac applications by doing one of the following:

« Click the Parallels icon Il in the menu bar and choose Actions > Pause.

= |f the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Pause.
To resume using Windows after pausing it, do one of the following:

« Click the Parallels icon Il in the menu bar and choose Actions > Resume.

= |f the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Resume.

If you quit Parallels Desktop while Windows is paused, you're prompted to either Suspend or Stop
Windows first.

Shut Down Windows

Shutting down Windows in Parallels Desktop is just like shutting down Windows on a PC. Al
Windows programs close, giving you the opportunity to save your progress if necessary, and
Windows stops running.

To shut down Windows, do one of the following.
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« Click the Parallels icon Il in the menu bar and choose Actions > Shut Down.

= |f the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Shut
Down.

Stop Windows

To stop Windows and all open Windows programs immediately, do one of the following:

= Click the Parallels icon Il in the menu bar and choose Actions > Stop.

= |f the Parallels Desktop menu bar is visible at the top of the screen, choose Actions > Stop.

Important: When you stop Windows this way, none of your data or progress is saved.

Window Menu

If Windows is set to appear in a separate window, you can also choose any of the above options
from the menu at the bottom of the window:

\ Suspend

Il Pause
@® Shut Down
M Stop

Startup and Shutdown Settings

Using Startup and Shutdown settings, you can choose how to start and shut down the virtual
machine.

To access Startup and Shutdown settings:

1 Do one of the following:

= Click the Parallels icon Il in the menu bar and choose Configure.

= |f the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.

2 Click Options and select Startup and Shutdown.
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Set to Start and Shut Down the Virtual Machine Manually

If you want to always start and shut down the virtual machine manually, select Start up and shut
down manually.

Configure the Virtual Machine to Start Automatically

If you want to make the virtual machine start automatically when the Mac starts, select Always
ready in background.

Specify More Details How to Start and Shut Down the Virtual Machine Automatically

If you want to specify not only how the virtual machine starts or shuts down but also the view mode
and what happens on closing the virtual machine window, select Custom and do the following:

Set Whether Windows Starts Automatically

Choose one of the following from the Start Automatically menu:
Note: Windows starts when you open a Windows program (p. 32) regardless of this setting.

< Never: Windows never starts automatically.
< When window opens: Windows starts automatically when you open it from Control Center.

< When Parallels Desktop starts: Windows starts automatically when you start Parallels
Desktop.

< When Mac starts: Windows starts automatically when you start the Mac. If you select this
option, you can also configure the virtual machine to delay the startup.

Note: This feature is available in Parallels Desktop for Mac Pro Edition only.

< When user logs in: Windows starts automatically when the OS X user logs in to OS X on the
Mac startup.

Set the Startup View

This setting affects in which view mode Windows starts when you start the virtual machine or guest
OS application.

= From the Startup View menu, choose Coherence, Window, Full Screen, Modality,
Headless or Same as last time.

Note: Headless mode is available in Parallels Desktop for Mac Pro Edition only.
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Set What Happens When You Shut Down Windows

Choose one of the following from the On VM Shutdown menu:

= Keep window open: If Windows is set to appear in a separate window, the window stays open
when you stop or shut down Windows.

= Close window: If Windows is set to appear in a separate window, the window closes when
you stop or shut down Windows.

e Quit Parallels Desktop: Parallels Desktop quits when you stop or shut down Windows.

Set What Happens When You Shut Down Your Mac
These settings affect what happens when you shut down the Mac.

From the On Mac Shutdown menu, choose Stop, Shut Down, or Suspend.

Set What Happens When You Close the Parallels Desktop Window
These settings affect what happens only when Windows is set to appear in a separate window.

From the On Window Close menu, choose Suspend, Shut Down, Force to stop, Keep running
in background or Ask me what to do.

Set How Windows Works with Mac OS X

Parallels Desktop 12 for Mac allows you to work seamlessly between Windows and Mac OS X. For
example, you can cut and paste text, and share files, between the two.

There are a number of ways that you can set the level of integration between Windows and Mac
OS X. For example, you may want your Windows programs to behave just like Mac applications,
appearing side-by-side with them on the Mac desktop. Or you may wish to keep the Windows
desktop and programs in a separate window.

Read on to learn more about setting how Windows works together with Mac OS X.
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Merge Windows and Mac OS X

You can set Windows and Mac OS X to work seamlessly together, as if they were part of a single
operating system. In this mode, called Coherence mode, Windows programs appear on the Mac
desktop next to your Mac applications, and documents from Windows programs and Mac
applications are stored in the same folders.
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Switch to Coherence Mode
To switch from Window mode to Coherence mode, do one of the following:

= C(Click the Coherence icon . in the top left corner of the virtual machine window.

e (Choose View > Enter Coherence.

« Press Control-Command-C.
To switch from Full Screen mode to Coherence mode, do one of the following:

e Press Control-Command-F to exit Full Screen. Then click View > Enter Coherence.
41



Use Windows on Your Mac

Move the pointer to the top of the screen until the OS X menu bar appears and click View >
Exit Full Screen. Then open the View menu once again and click Enter Coherence. If you're
using Mac OS X Snow Leopard or working in Parallels Full Screen mode (p. 45), press Control-
Option (Alt) to display the Mac menu bar.

If the Parallels hot corners (p. 45) are active, move the pointer to the upper-left corner of the
screen until the corner peels back and click Exit Full Screen.

Exit Full Screen

Then choose View > Enter Coherence.

Note: To enable the Coherence view mode, Parallels Tools must be installed (p. 199). In most cases,
Parallels Tools are installed by default.

Parallels Menu

When in Coherence mode, the Parallels menu I appears in the menu bar at the top of the screen.

Windows Start Menu
Devices »
Exit Coherence

Request Support
Parallels Desktop Help

Quit

Use the menu for these common functions:
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Click the Parallels icon Il to open a basic menu that provides the following items:

= Windows Start Menu: Access the Windows Start menu.

= Devices: Manage hardware devices like printers and DVD drives.

= Exit Coherence: Switch to Window mode

= Request Support: Fill out a problem report and request support from Parallels Desktop.
= Parallels Desktop Help: Access onscreen help.

* Quit: Quit Parallels Desktop.

Right-click the icon to open the Windows start menu.
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Important: When in Coherence mode, to quit Parallels Desktop, click the Parallels icon I'in the menu
bar and choose Quit Parallels Desktop.

Windows System Tray

When Parallels Desktop is in Coherence mode, the Windows system tray icons are in the Mac OS
X menu bar at the top of the screen.

|ﬁ ﬁ ﬁ 2 !H

You can use the system tray icons just as you would from the Windows Desktop.

Move Windows Programs Between Desktops (Spaces)

When Windows is working in Coherence, you can easily move windows of guest OS programs
between Mac OS X desktops (spaces).

= (lick the title bar of the window you want to move and while holding down the mouse button,
press Control-# (# is the number of the desktop (space) you want to move the window to).

Set Windows to Appear in a Single Window

You can set the Windows and programs to appear together in their own window.

D 4f = @k 16:55 Parallels QL

To switch to Window mode from Coherence mode, do one of the following:

= Click the Parallels icon !l in the menu bar, then choose View > Exit Coherence.
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= |[f the Parallels Desktop menus are available in the Mac menu bar, click View > Exit
Coherence.

To switch to Window mode from Full Screen mode, do one of the following:

e Press Command-Control-F.

= Move the pointer to the top of the screen until the OS X menu bar appears and click View >
Exit Full Screen. If you're using Mac OS X Snow Leopard or working in Parallels Full Screen
mode (p. 45), press Control-Option (Alt) to display the Mac menu bar.

Adjust Window Mode Settings

You can customize how Parallels Desktop appears and behaves when in Window mode.

Set Whether Windows Programs Show in the Dock:

You can choose whether or not to show icons for Windows programs in the Mac OS X Dock when
in Window mode. If you prefer to work with programs by manipulating them on the Windows
desktop, you may not want to be distracted by seeing them in the Dock alongside your Mac OS X
application icons.

3 Do one of the following:
= Click the Parallels icon Il in the menu bar and choose Configure.

= |f the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.

4 Click Options and then click Applications.

5 To show Windows program icons in the Dock when in Window mode, deselect Show Dock
icons in Coherence only.

Monitoring Windows in a Scalable Window
You can set Windows to appear in a window that can be resized to any size so that the content
scales in size with the window. This is called Modality mode. Modality mode can be useful if you

want to monitor programs and other tasks running in Windows as you work in Mac OS X.

To switch to Modality mode:
= From Window mode, choose View > Enter Modality.

For more information on Modality mode, see the Modality mode settings topic (p. 157).

Set Windows to Take Up the Whole Screen

You can set Windows to occupy your entire screen, so it looks just like it would if you were using a
Windows PC. In Full Screen mode, Mac OS X and all of the Parallels Desktop controls are hidden.
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To switch to Full Screen mode, do one of the following:

e From Coherence mode, click the Parallels icon Il'in the menu bar, then choose View > Exit
Coherence. Then click the View menu and select Enter Full Screen.

e From Window mode, choose View > Enter Full Screen or click the Full Screen icon . in the
top left corner of the virtual machine window.

®-0@®

To exit Full Screen mode, do one of the following:

e Press Command-Control-F.

= Move the pointer to the top of the screen until the OS X menu bar appears and click View >
Exit Full Screen. If you're using Mac OS X Snow Leopard or working in Parallels Full Screen
mode (p. 45), press Control-Option (Alt) to display the Mac menu bar.

= |f the Parallels hot corners (p. 45) are active, move the pointer to the upper-left corner of the
screen until the corner peels back and click Exit Full Screen.

Exit Full Screen

If you are using Mac OS X Lion and one of the screen corners is set to show the menu bar (p. 45),
move the pointer to that corner and then click the Full Screen button in the top-right corner of the
menu.

Adjust Full Screen Settings
You can customize how Windows appears and behaves when in Full Screen mode.

To access Full Screen settings:

1 Do one of the following:

= Click the Parallels icon Il in the menu bar and choose Configure > Options.

= |f the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure, and then click Options.
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2 Click Full Screen.
o0 ® Windows 10 - bptions
R

I General Options Hardware Security Backup Dev Settings Business

@ Startup and Shutdown Use all displays in full screen
Optimize full screen for games
@ Optimization Hides 05 X Dock, menu bar and notifications.
Sharing Allow Windows 10 to set display gamma
l Scale to fit screen:  Auto
""'g Applications ﬁ

i Modality

% Web & Email

‘ @ Maintenance

[ |
‘ 15 | Travel Mode

Lo spoennotione
Restore Defaults

JJ Click the lock to prevent further changes.

3 Inthis Full Screen pane, you can adjust any of the settings listed below.

Set What Shows on Displays Connected to Your Mac

If you have a second display connected to your Mac, by default when you switch to Full Screen
mode, Windows is displayed on the primary display and Mac OS X on the secondary.
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You can choose which display Windows is shown on by dragging its window to that display and
then clicking the Full Screen icon .

To extend Windows across all your displays, select Use all displays in full screen.

Optimize Full Screen for Games
If you use a virtual machine to play video games in Full Screen view mode, select Optimize full

screen for games. With this option selected, OS X Dock, menu bar and notifications will not be
displayed when you move the mouse pointer to the top and bottom of the screen.

Allow Windows to set display gamma
If you're using Windows to play video games, Windows may need to temporarily change your

Mac's display gamma setting to properly display different visual effects. To allow Windows to
change gamma settings, select Allow Windows to set display gamma.

Scale to fit screen

Using the Scale to fit screen menu, you can configure how Windows is displayed when working in

Full Screen:

= Off. If Parallels Tools (p. 140) are installed, Windows resolution matches that of the Mac. If
Parallels Tools (p. 140) aren't installed, Windows resolution remains unchanged. If it is lower
than that of the Mac, Windows is displayed on the black background. If higher, Windows has
scroll bars.

e Auto. If Parallels Tools (p. 140) are installed, Windows resolution matches that of the Mac. If
Parallels Tools (p. 140) aren't installed, Windows resolution remains unchanged. If it is lower
than that of the Mac, Windows is displayed on the black background. If higher, Windows is
entirely displayed on the screen without any scroll bars.

= Keep ratio: No matter whether Parallels Tools (p. 140) are installed or not, Windows resolution
remains unchanged. If it is lower than that of the Mac, Windows is displayed on the black
background. If higher, Windows is entirely displayed on the screen without any scroll bars.

e Stretch: No matter whether Parallels Tools (p. 140) are installed or not, Windows resolution
remains unchanged but Windows is stretched to occupy the whole screen.
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i
Note: To prevent unauthorized changes to Full Screen settings, click the Lock icon d at the bottom
of the window. Once locked, an administrator's password is required to make further changes.

About Using Windows 8 with Parallels Desktop

As you probably know, Windows 8 features two environments; the new Metro interface; and the
classic Windows desktop interface, accessible by clicking Windows Explorer on the Start screen
or clicking Start in the Charm Bar.

Metro Applications Run in Full Screen

On a Windows PC, Metro-style applications and the Start screen take up the full screen, rather
than running in a separate window. So even when you're using Windows 8 in Coherence mode (p.
41), Metro applications still use most of the screen.
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When Windows 8 is in Window mode (p. 43), the Metro interface takes up the full window.

Using the Edges and Corners of the Screen
In Windows 8, you must click in the edges and corners of the screen to access various features.

For example, to access the Charm Bar, which contains icons for accessing settings, searching, and
more, you must move the pointer to the upper- or lower-right corner of the screen.

=]

Y

A
-

A

Finance

49



Use Windows on Your Mac

And to see thumbnails of all your open Metro-style applications, you move the mouse pointer to the
upper- or lower-left corner until you see a thumbnail, then slide up or down. Click an application to
make it active.
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When you're using Windows 8 in Window mode, it can be tricky to find the exact corner or edge of
the screen with the mouse pointer. So Parallels Desktop 12 allows you to set the mouse pointer to
"stick" to the edges of the screen (p. 168) when you move it slowly. To move past the edge, just
move the mouse quickly. This feature, enabled by default, makes it easy to use Windows 8.

Set Windows 8 to Work Like Windows 7

As you might know, Windows 8 differs considerable from its previous versions: Windows 8 boots to
a tiled "Start screen" rather than the traditional Windows desktop, modern Windows 8 apps are all
full screen only, and the Windows 8 desktop has no Start menu.

If you prefer the classic Windows environment where Windows boots to the desktop, Windows
applications run in resizable windows, and a fully functional Start menu is available from the
desktop, you can easily apply this Windows classic style to Windows 8. To do so:

In Parallels Desktop, start Windows (p. 31).

2 |f Windows is running in Coherence, click the Parallels icon Il in the menu bar and click View >
Exit Coherence.

3 Choose View > Use Windows 7 Look.
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To revert to Windows 8 experience, repeat the steps above and deselect Use Windows 7 Look.

Set a Program to Open When You Insert a CD or DVD

You can set the Windows program of your choice to open when you insert a music CD, picture CD,
video DVD, or a blank CD or DVD.

From the Mac OS X Finder, choose Apple menu > System Preferences.
Click CDs & DVDs.

From the disc type menu of your choice, choose Open other application.

A WO N =

Choose a Windows program from Zusername/Applications (Parallels)/Windows
Applications.

When you insert a disc of the type you selected, the Windows program you chose automatically
opens.

Note: 1.If you're unable to set a Windows program to open when you insert a CD or DVD, be sure that
sharing Mac OS X applications (p. 58) is enabled and that Mac OS X CD/DVD-ROM is not selected in
CD/DVD Preferences (p. 183).

2. To enable a Windows program to open when you insert a CD or DVD, Parallels Tools must be installed
(p. 199). In most cases, Parallels Tools are installed by default.

Share ltems Between Mac OS X and Windows

Parallels Desktop allows you to easily access your Mac OS X files using Windows programs, and
also to access Windows files using Mac OS X applications.

Read on to learn about all the ways you can share folders, files, and applications between Mac OS
X and Windows.

Copy and Paste Between Mac OS X and Windows

Parallels Desktop allows you to copy and paste images and formatted text (italic, bold, underlined,
and of various colors, fonts, and sizes) between Mac OS X and Windows applications.

To enable copying and pasting between Mac OS X and Windows:
1 Do one of the following:

- Click the Parallels icon Il in the menu bar and choose Configure.

= |[f the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.

2 (Click Options > Advanced.
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3 Select Share Mac clipboard.

4 To preserve text formatting when copying and pasting text, select Preserve text formatting.

Note: To enable copying and pasting between Mac OS X and Windows, Parallels Tools (p. 199) must be
installed. In most cases, Parallels Tools are installed by default. Copying and pasting between Mac OS X
and Windows is unavailable if you isolate Mac OS X from Windows.

Copy and Paste Files

You can easily copy and paste files between Windows and Mac OS X by doing the following:

1 Select afile (or multiple files) and press Command+C on your keyboard to copy it.

2 Open a folder or click the desktop in the other operating system and press Command-V to
paste the file.

Notes:

1. To enable copying and pasting files between Mac OS X and Windows, in Sharing settings (p. 52) All
disks or Home folder only must be chosen from the Share Folders menu, and Access Windows
folders from Mac must be selected. In most cases all of these options selected by default.

2. If Home folder only is selected in the Share Folders menu (p. 52), you will be able to copy and paste
files from the Mac to Windows only from the Mac home folder.

Share Files and Folders

Parallels Desktop allows you to share folders between the Mac OS X and Windows file systems, so
you can easily open Mac OS X files from Windows applications and Windows files from Mac OS X
applications.

Note: These instructions apply to sharing folders between OS X and Linux as well.

Access a Mac OS X Folder or File from a Windows Program

With folder sharing enabled, you can navigate to any shared Mac OS X folder from within a
Windows program. When you open a file (for example, by choosing File > Open in many
programs), your shared Mac OS X folders appear as network shared directories labeled "psf."

To enable Mac OS X folders for sharing with Windows programs:
1 Start Windows. (p. 31)
2 Do one of the following:

= Click the Parallels icon Il in the menu bar and choose Configure.

= |If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.
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3 Click Options and select Sharing > Share Mac.
o0 ® Windows 10 - ;lfjpt'ions
= S B

i
|
| General Options Hardware Security Backup Dev Settings Business

@ Startup and Shutdown Lo b Share Windows

@ Optimization Share Folders: None ﬁ

"

Shared Profile: Share Mac user folders with Windows

rg Applications Configure...

@ Fuisoreen Shared Cloud:  Share cloud folders with Windows
i Modality SmartMount:  Map Mac volumes to Windows
% Web & Email ¥ Advanced Settings

Assign a drive letter to shared folders
Allow creating executables

@ Maintenance
7]
m T {2 Enable DOS 8.3 filenames

n Kl Timblmemn
Restore Defaults

JJ Click the lock to prevent further changes. ¥

4 Do one of the following:

« To share just the folders in your Home folder, choose Home folder only from the Shared
Folders menu.

e To share all your Mac OS X folders, choose All disks from the Shared Folders menu.
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= To share any folder you want, click Custom Folders and click the add (+) button, then
choose the folder you want to share. You can add more folders by clicking the add (+)
button again.

User-defined OS X folders:

On Name Path Permissions

Cancel OK_

Once you share a Mac OS X folder with Windows you can:
= Disable the folder sharing by deselecting On.

= (Change the folder name that will be displayed in Windows by double-clicking the folder
name in the Name column and typing another name.

= Restrict writing to this folder by clicking Read & Write in the Permissions folder and
choosing Read only. You will not be able to add items to the folder.

Note: 1. To enable folder sharing, the Isolate Windows from Mac option must be disabled on the
Security tab of the Configuration dialog.

2. If you're running Linux, shared folders are mounted to the /media/psT or /mnt/psT directory.

Set Mac OS X and Windows to Use the Same Folders

You can set Mac OS X and Windows to use the same folders for things like music, documents,
pictures, your desktop, and deleted files. So for example, if you save a file to the Documents folder,
it will be in the Documents folder whether you're using a Mac OS X application or a Windows
program.

5 Start Windows. (p. 31)
6 Do one of the following:

= Click the Parallels icon Il in the menu bar and choose Configure.

= |If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.

7 Click Options and select Sharing.
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8 Click the Share Mac tab and select Share Mac user folders with Windows.

Your Mac OS X Desktop, Documents, Pictures, Music, Movies, and Downloads
folders are merged with the corresponding Windows folders, and the Mac OS X Trash is
merged with the Windows Recycle Bin.

9 |If you only want to map some of the folders, click Configure and select the folders you want.
To map the Mac OS Trash to the Windows Recycle Bin, select Merge Recycle Bin with
Trash.

Show an Item from Windows in the Finder

If Windows is set to appear in a separate window or in full screen mode (p. 43), you can show an
item from Windows in the Mac OS X Finder.

= In Windows, right-click (or Control-click) a file or folder and choose Show in Finder from the
shortcut menu.

From the Finder you could, for example, apply a color label to an item, or easily drag it to another
location in the Finder.

Note: You can only perform these actions with files stored in shared folders (p. 52).

Access a Windows Folder or File from a Mac OS X Application

By default, you can navigate to all your Windows folders and files from Mac OS X. Windows disks
are mounted to /Volumes. At the same time, Windows appears as a hard disk mounted on the
Mac OS X desktop.

= Double-click the icon to access Windows folders and files. You can also navigate to this disk
from within Mac OS X applications.

Note: If the Windows disk icon doesn't appear on the Mac OS X desktop, from the Finder choose Apple
menu > Preferences and click General, and then make sure that Connected servers is selected.

To unmount Windows from the desktop:

1 Start Windows. (p. 31)
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2

3

Click the Parallels icon Il in the menu bar and choose Configure. Then click Options and
select Sharing > Share Windows.

Note: If Windows is running in Window mode (p. 43), choose Configure from the Actions menu.

Deselect Shortcuts to virtual disks on Mac desktop.

Note: The Windows disk disappears from the desktop and the Finder, but you can still access all of the
Windows files and folders via the Windows PVM file and Terminal (/Volumes). By default, the PVM file
is either in /Users/<Username>/Documents/Parallels/ or /Users/Shared. You can also find
the PVM file by right-clicking Windows in Control Center (or in the virtual machine window when
Windows is shut down) and selecting Show in Finder. To access Windows files and folders, right-click
the PVM file, select Show Package Contents from the context menu, and open the Windows Disks
folder. To disable the ability to navigate to Windows files and folders, deselect Access Windows
folders from Mac in step 3 above.

Share iCloud, Dropbox, or Google Drive Folders with Windows

If you're using iCloud, Dropbox, or Google Drive cloud storage in OS X, you can easily share their
OS X folders with Windows. Once sharing is enabled, you can upload, download, and sync files
from any of these services from within Windows without duplicating any of their files on your hard
disk.

Notes:

1. This functionality is also available for Linux virtual machines.
2. To be able to use this functionality, Parallels Tools (p. 140) must be installed.

To share OS X iCloud, Dropbox, or Google Drive folders with Windows, do the following:

Note: In Parallels Desktop for Mac Pro Edition, you can also share your Dropbox for Business, Box and
OneDrive for Business folders with Windows.
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If you haven't already, set up iCloud, Dropbox, or Google Drive in OS X.
Start Windows (p. 31).

Do one of the following:

= Click the Parallels icon Il in the menu bar and choose Configure.

= |f the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.

Click Options and select Sharing > Share Mac.

Select Share cloud folders with Windows.
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6 Log in to Windows and open Computer. Folders for iCloud, Dropbox, or Google Drive are

available in the Favorites section. You can use them to upload and download files to and from

the cloud.
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I Desktop
Downloads
~» Recent places
< iCloud (Mac)
- Photo Stream (Mac)
< Google Drive (Mac)
& SkyDrive

Share Windows OneDrive Folders with Mac OS X

If you're using Microsoft OneDrive to store files in the cloud, you can easily share your OneDrive
folders with Mac OS X. Then you can upload or download OneDrive files in Mac OS X without
duplicating any of the files on your hard disk.

Notes:

1. To share OneDrive folders with Mac OS X, the OneDrive desktop app must be installed in Windows. If
you're using the preinstalled Windows 8 OneDrive app, OneDrive folders are not shared because this app
doesn't create any local folders and works directly with the cloud storage.

2. This feature is available only when Parallels Tools are installed (p. 142) in Windows.

To share your Windows OneDirive folders with OS X, do the following:

1 If OneDrive isn't already set up in Windows, set it up. For more information, go to
http://windows.microsoft.com/en-us/skydrive/download.

2 Do one of the following:
« Click the Parallels icon Il in the menu bar and choose Configure.

= |[f the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.

Click Options and select Sharing > Share Windows.

Select Access Windows folders from Mac and Share OneDrive with Mac.
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5 Inthe Mac OS X Finder, choose Finder > Preferences and select Connected servers.

Once selected, Microsoft OneDrive folders appear as hard disks on the OS X desktop. You can use
them to upload and download files to and from OneDrive.

Note: These shared folders are visible on the OS X desktop and you can use them to upload files from
OS X only when Windows is running.

Share Applications and Programs

You can access Mac OS X applications from within Windows and you can access Windows
programs from Mac OS X. For example, if you locate a file using the Open menu in a Windows
program and decide you would rather open the file using a Mac OS X application, you can.

Note: Provided that Parallels Tools are installed in Linux (p. 143), you can also open Mac OS X files using
Linux applications.

Enable Sharing Mac OS X Applications

When sharing Mac OS X applications is enabled, you can open Mac OS X Applications from within
Windows or Windows programs.

If not, you can enable it at any time by doing the following:

1 Do one of the following:
= Click the Parallels icon Il in the menu bar and choose Configure.

= |If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.

2 Click Options and click Applications.

3 Select Share Mac applications with Windows.

Once sharing Mac OS X applications is enabled, you can do the tasks below.

Open a File from Windows in a Mac OS X Application

You can open a file in a Mac OS X application from Windows Explorer, from the Open dialog in
most Windows programs, or from Windows Desktop if Windows is set to appear in a separate
Window or at full screen (p. 43). You may want to do this if you don't have a Windows program that
can open the file.

< In Windows, right-click (or Control-click) a file and do one of the following:

= Choose Open on Mac from the shortcut menu. The file opens in the default Mac OS X
application for that file type.

= (Choose Open With from the shortcut menu, and then choose an application.
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Note: You can only perform these actions with files stored in shared folders (p. 52).

Open a Mac Application from the Windows Start Menu

From the Windows Start menu, do one of the following:

= Choose All Programs > Parallels Shared Applications, and then choose an application.

= Type the name of the application you're looking for in the search field, then choose the
application from the list.

Enable Sharing Windows Programs

When sharing Windows programs is enabled, you can open Windows programs from the Mac OS
X Finder. You can also choose to add a folder to the Dock containing all your Windows programs
for easy access.

4 Do one of the following:
= Click the Parallels icon Il in the menu bar and choose Configure.

= |f the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.

5 Click Options and click Applications.

6 Select Share Windows applications with Mac.

Add a Windows Applications Folder to the Dock

1 Do one of the following:
= Click the Parallels icon Il in the menu bar and choose Configure.

= |If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.

2 Click Options and then click Applications.

3 Be sure Share Windows applications with Mac is selected, and then select Show Windows
applications folder in Dock.

Configure Whether Dock Icons Bounce to Alert

When a Windows application icon in the taskbar would normally flash to alert you to something,
such as a new message in Skype or a notification in Microsoft Outlook, by default its icon also
bounces repeatedly in the OS X Dock.

To enable or disable Windows application icons bouncing to alert:

1 Do one of the following:
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Click the Parallels icon Il in the menu bar and choose Configure.

If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.

2 Click Options and click Applications.

3 Select or deselect Dock icons bounce to alert.

Note: Icon bouncing is available for Windows with Parallels Tools installed (p. 199) provided that Share
Windows applications with Mac is selected in the Applications pane.

Force Quit Windows Programs

If your running Windows guest OS program doesn't respond and freezes, you can easily force quit
it as you can do with any Mac OS X application. To force quit a Windows program, do one of the
following:

= Right-click the icon of the Windows program available in the Dock, press Option (Alt), and
choose Force Quit.

= Press Option + Command + Esc (Alt + Command + Esc), select the name of the Windows
program you want to quit, and click Force Quit.

Note: To be able to force quit Windows guest OS programs, Parallels Tools must be installed (p. 199).

Add Applications to Launchpad

When you install any applications in Windows (except temporary apps), you can choose to
automatically add their icons to Launchpad.

1 Do one of the following:

= Click the Parallels icon Il in the menu bar and choose Configure.

= |If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.

2 Click Options and click Applications.

3 Select Add new applications to Launchpad.
Set Files to Open in the Application or Program of Your Choice

You can set files of a particular type that you open from the Mac OS X Finder to open in the
Windows program of your choice. For example, you could set files ending in . txt to always open
in Windows Notepad.

You can also set files opened from Windows to always open in the Mac OS X application of your
choice.
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Set Mac OS X Files of a Particular Type to Open in a Windows Program

To open a Mac OS X file once with a Windows program:

1 Right-click (or Control-click) the file in the Finder and choose Open With from the shortcut
menu.

2 Select a Windows program.

If you don't see the program you want, click Other and choose a Windows program from
/username/Applications (Parallels)/Windows Applications.

You can also open a Mac OS X file in a Windows program by dragging it to the program's icon in
the Dock.

To set files of a particular type to always open in a Windows program:

Right-click (or Control-click) a file and choose Get Info from the shortcut menu.
2 (Click the triangle next to "Open with" to expand the section.
3 Choose a Windows program from the pop-up menu.

If you don't see the program you want, choose Other and choose a Windows program from
/username/Applications (Parallels)/Windows Applications.

4 Click Change All.

From this point on, double-clicking a file of this type (. txt in the example above) in the Mac OS X
Finder opens the file in the Windows program. If Windows is shut down, suspended, or paused,
double-clicking the file starts or resumes Windows in Coherence mode. When Windows starts up,
the file opens in the Windows program.

Set Windows Files of a Particular Type to Open in a Mac OS X Application

To open a Windows file with a Mac OS X application only this time:

= Right-click (or Control-click) the file in Windows, choose Open With from the shortcut menu,
and choose an application.

To set all files of a particular file type to open in a Mac OS X application:

1. Right-click (or Control-click) a file in Windows, choose Open With from the shortcut menu,
and click Choose default program.

2. Select an application, choose Always use the selected program to open this kind of file,
and click OK.

Note: To set files to open in the application or program of your choice, Parallels Tools must be installed
(p. 199). In most cases, Parallels Tools are installed by default. Also, the Isolate Mac from Windows (p.
93) option must be disabled, and Windows application sharing (p. 58) must be enabled.
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Set Internet Links to Always Open in Mac OS X or Windows

By default, clicking a link (such as a web page URL) in Windows opens the default Windows
program for that link type, and clicking a link in Mac OS X opens the default Mac OS X application.

You can set links of a particular type to always open in Mac OS X or in Windows. For example, you
could set web pages to always open in Windows Internet Explorer, even if the link is clicked in a
Mac OS X application.

Note: To set Internet links to open in Mac OS X or Windows, Parallels Tools must be installed (p. 199). In
most cases, Parallels Tools are installed by default.

To set Internet links to open in Mac OS X or Windows:

1 Do one of the following:
= Click the Parallels icon Il in the menu bar and choose Configure.

= |If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.

2 Click Options and select Web & Email.

3 Click the menu for the type of link you want to set. If you don't see the link type you want, click
More Applications. The following types of links can be set:

= Web Pages: Web pages accessible through the HTTP and HTTPS protocols.

= Email: Links in the mai I'to format that open a pre-addressed email.

= Newsgroups: Links in the news . format that typically open a newsreader program.
= FTP: File upload and download locations accessible through the FTP protocol.

= RSS: Episodic content, such as blogs and podcasts.

< Remote Access: Locations accessible through the Telnet and Secure Shell (SSH)
protocols.

4 Choose one of the following:

= Default: The link opens in the application or program set as default in the operating system
(Mac OS X or Windows) where you click the link.

e Open in Windows: Links clicked in Mac OS X or Windows open in the default Windows
program for that link type.

e Open in Mac: Links clicked in Mac OS X or Windows open in the default Mac OS X
application for that link type.

Open the Current Safari Page in Internet Explorer

Some webpages work best when viewed in Windows Internet Explorer. If you are browsing in Mac
OS X using Safari, you can quickly open the current page in Internet Explorer by doing the
following:
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5 First you need to install the "Open in Internet Explorer" plugin. Do one of the following:
- Click the Parallels icon Il in the menu bar and choose Configure.

= |[f the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.

Click Options and select Web & Email.
Click Install Plugin.
&)

8 Once the plugin is installed, click the Open in IE button =1 in the toolbar.

If Windows isn't already open, it starts up and the page opens in Internet Explorer.

Share External Storage Devices and Volumes

When you connect an external storage device, such as a USB drive, to your Mac, you can access
the contents from Mac OS X applications.

Using SmartMount, you can set Parallels Desktop to automatically mount storage devices and
volumes to Windows. That way, you can access the contents from both Mac OS X and Windows.

With SmartMount enabled, these items are automatically mounted to Windows:

< Removable drives: External storage devices, such as USB hard disks and USB flash drives.

< CD/DVD drives: CD and DVD drives or CD/DVD images (files most commonly ending in .dmg,
-iso, and .img.).

= Network folders: Folders shared over the network.
To enable SmartMount:

Start Windows. (p. 31)
2 Do one of the following:
= Click the Parallels icon Il in the menu bar and choose Configure.

= |f the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.

3 Click Options and select Sharing > Share Mac.

4 Select Map Mac volumes to Windows.

When you connect a storage device or volume, it is mounted as a network drive. For example, a
USB flash drive plugged in to your Mac will be accessible from both the /Volumes folder in Mac
OS Xand My Computer in Windows.
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Note: Permissions for accessing the mounted device from Windows are the same as permission settings
for the device in Mac OS X. For example, if you can read from and write to a USB flash drive in Mac OS
X, you can also read from and write to it in Windows. One exception: Mac OS X can't write to NTFS
volumes, regardless of permissions.

Use a Disk Image with the Virtual DVD Drive

While working in Windows, you can select a disk image file to be used with the virtual Windows
DVD drive, as if it was a DVD inside a real drive. To do so:

1 In Windows Explorer, open Computer or This PC, right-click the DVD drive icon, and choose
Select disk image.

2 | ocate the disk image you want to use and click Open.

Note: This functionality is available only for Windows with Parallels Tools installed (p. 199).

Save Internet Passwords in Mac Keychain

Nowadays, users don't have to remember numerous passwords to various social media accounts
and websites. Your Mac can store and automatically fill them in when necessary.

If you browse the Internet in Windows using Internet Explorer or Microsoft Edge, you can set to
store your passwords in Mac keychain. If you do so, the passwords you enter in Internet Explorer
or Microsoft Edge will be saved to Mac keychain and you will be able to auto fill them from these
browsers. These passwords won't be accessible to any other applications and won't be lost if
Windows gets corrupted or reinstalled.

To store Internet passwords in Mac keychain:

1 Do one of the following:

- Click the Parallels icon Il in the menu bar and choose Configure.

= (lick Actions in the Parallels Desktop menu bar at the top of the screen and choose
Configure.

2 Click Options and select Web & Email.

3 Select Store Internet passwords in Mac keychain.

Apply Mac OS X Parental Controls to Windows

If you have administrator rights in Mac OS X, you can use parental controls to prevent others with
accounts on your Mac from using certain Windows programs or accessing certain web sites.

To apply parental control settings:

1 InMac OS X, choose Apple menu > System Preferences and click Parental Controls.

2 Click the lock if it's not unlocked, and then enter an administrator name and password.
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3 Select the account that you want to restrict, click Enable Parental Controls, and set up the
controls. If you want the user to be able to use some Windows programs, be sure to select
Parallels Desktop in the list of allowed applications.

For more information on using parental controls, see Mac Help.

Set Media Files to Open in Windows 8 Apps

When you install Windows 8, Parallels Desktop sets most types of media files (photos, pictures,
music, and video) to open in classic Windows desktop applications.

To set media files to open in Windows 8 apps by default, do the following:

Start Windows 8.

From the Start screen, right-click or Control-click anywhere on the screen and click All Apps.
Open Control Panel.

Choose Programs > Default Programs > Associate a file type or protocol with a program.

a A ON =

In the list of file extensions, select the file extension for which you want to change the default
program, then select Change program and select the program you want to use with that type
of file.

Mouse, Trackpad, and Keyboard

Parallels Desktop lets you configure your mouse or trackpad and your keyboard to work just the
way you want them to.

You can also use trackpad gestures or the optional Apple Remote to control Windows programs
just as you can with Mac OS X applications.

Read on to learn how to customize how your mouse, trackpad, and keyboard work with Windows
programs.

Set Your Mouse or Trackpad to Right-Click and Middle-Click

Many tasks in Windows, such as bringing up shortcut menus, are accomplished by right-clicking.

By default, Parallels Desktop is set to mimic a right-click when you press Shift+Control and click
the mouse. You can change which key combination triggers a right-click.

You can also set your trackpad to allow right-clicking, and if you have an Apple Mighty Mouse

(included with Apple desktop computers from 2005-2009) or Magic Mouse (included with current
Apple desktop computers), you can set the mouse to allow right-clicking.
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Most other mice are pre-configured for right-clicking.

Set the Trackpad for Right-Clicking.

1 Choose Apple menu > System Preferences and click Trackpad.

2 Select Secondary Tap.

Now you can tap the trackpad with two fingers to imitate a right-click.

Set an Apple Mighty Mouse for Right-Clicking

1 Choose Apple menu > System Preferences and click Mouse or Keyboard & Mouse.

2 Choose Secondary Button from the menu to the right of the mouse.

Now you can press the right side of the mouse to right-click.

Set an Apple Magic Mouse for Right-Clicking

1 Choose Apple menu > System Preferences and click Mouse or Keyboard & Mouse.

2 Select Secondary click.

Now you can press the right side of the mouse to right-click.

Set Which Key Combination Triggers a Right-Click or a Middle-Click

1 Do one of the following:

- Click the Parallels icon Il in the menu bar and choose Preferences.

= Right-click the Parallels Desktop icon in the Dock and choose Preferences.
2 Click Shortcuts.

3 If necessary, click the lock icon and enter an administrator password.
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4 Select Mouse Shortcuts in the sidebar.

@& Shortcuts
e . 0, o e —
"B . P Q@ = &
General Shortcuts Devices Security Network Advanced Toolbox Access
o Choose keyboard shortcuts for secondary click and
m Application Shortcuts middle click in the virtual machine.
Secondary click: ik 3 + click
05 X System Shortcuts
Middle click: S + click
0 Mouse Shortcuts
== Keyboard Menu
VIRTUAL MACHIMES
s ..
- Windows 8.1
f U .
173 Windows XP
@ Ubuntu Linux 1
L@ Click the lock to prevent further changes. Restore Defaults ’

5 Select Secondary click (for right-click) or Middle click.

6 Click in the corresponding text field and press the key or combination of keys that you want to
use with a mouse click to trigger a right-click or middle-click.

You can use any combination of the Control, Option (Alt), Shift, and Command keys.

Control Programs with Trackpad Gestures or the Apple Remote

You can use the Apple Remote to control some Windows programs. If you have an Apple portable
computer, such as a Macbook, or if you have an Apple Magic Trackpad, you can use gestures,
such as swiping left or right across the trackpad, to control some Windows programs.

Note: You can control some Windows programs using three-finger swipes only if you're using Parallels
Desktop with Mac OS X Snow Leopard. In OS X Lion and later, three-finger swipes are used by default to
move between full-screen apps and spaces.
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To use the Apple Remote, you must first enable it by doing the following:
Start Windows (p. 31).
2 Do one of the following:

= Click the Parallels icon Il in the menu bar and choose Configure.

= |f the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.

3 Click Options, and then click Advanced.
4 Select Enable next to Apple Remote.

The following table provides commands to control some of the more popular Windows programs.

Action Keybo_ard_and Mouse Apple Touchpad Gesture
Combination Remote
General
. Swipe up, down, left, or
Scroll Up, down, left, or right arrow n/a right with two fingers
Microsoft Power Point
Start slide show F5 [ 1] n/a
End slide show Esc MENU n/a
Perform the next animation | N, Enter, Page Down, Right Swine right with three
or advance to the next Arrow, Down Arrow, Space (or (o >WIpe 19
. . | fingers
slide click the mouse)
Perform the previous
animation or return to the P, Page Up, Left Arow, Up e Swipe left with three fingers

orevious slide Arrow, Backspace

Zoom in/zoom out Ctrl+wheel up /Ctrl+wheel down | n/a Pinch open/pinch close

Microsoft Word/Excel
Zoom in/zoom out

Ctrl+wheel up /Ctrl+wheel down | n/a Pinch open/pinch close

Windows Media Player

Start/pause playback Space el n/a
Skip to the next song Ctrl+F L ](SWIpe right with three
| ingers

Play the previous song Ctrl+B (53] Swipe left with three fingers
Volume up F8, Up Arrow, wheel up + n/a
Volume down F9, Down Arrow, wheel down — n/a

i
Media Player Classic (k-lite)
Start playback/pause Space 1l n/a
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Volume up F8, Up Arrow, wheel up -+ n/a
B
Volume down F9, Down Arrow, wheel down - n/a
R—
Winamp
Start playback/pause X to start, C to pause 1l n/a
Volume up Up Arrow, wheel up -+ n/a
i
Volume down Down Arrow, wheel down — n/a
[E———
Microsoft Internet Explorer
i n/a or ine fi i
Page back Backspace, Option+Left Arrow SW|pe right with three
(Alt+Left Arrow) g fingers
Option+Right Arrow (Alt+Right | n/a or . . .
Page forward Arrow) e Swipe left with three fingers
Zoom in/zoom out Ctrl+wheel up/Ctrl+wheel down | n/a Pinch open/pinch close
Mozilla Firefox
; n/a or ne I i
Page back Backspace, Option+Left Arrow SWlpe right with three
(Alt+Left Arow) (o fingers

Option+Right Arrow (Alt+Right | n/aor

Page forward Arrow) e

Swipe left with three fingers

Ctrl-wheel up/Ctrl-wheel down or

Zoom in/zoom out Ctrl-"+"/Ctrl-"-" n/a Pinch open/pinch close
Windows Picture and Fax Viewer
Next image Right Arrow g SW'pe right with three
| fingers
Previous image Left Arrow 4 Swipe left with three fingers
x or
Zoom in/zoom out RRRVAR E— Pinch open/pinch close
(Whwes
Rotate clockwise Ctrl+K n/a Rotate right with two fingers
Rotate counterclockwise Ctrl+L n/a Rotate left with two fingers
Use Keyboard Shortcuts

Both Mac OS X and Windows provide extensive keyboard shortcuts. For example, in Mac OS X
you can hold down the Command key and press Q (Command-Q) to quit the current application.

To enter a keyboard shortcut, simply press a key combination on your keyboard.
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You can also enter keyboard shortcuts by doing one of the following:

= Click the Parallels icon Il in the menu bar, then choose Devices > Keyboard and choose a
key combination.

e Choose Devices > Keyboard and choose a key combination.

These methods are most useful for using keyboard shortcuts that include keys not included on a
Mac keyboard, such as Alt + PrintScreen.

Note: To use the F1-F12 keys on a MacBook, press and hold the Fn key and then press an F key.

Customize Keyboard Shortcuts

By default, Parallels Desktop maps common Mac OS X keyboard shortcut key combinations to the
equivalent Windows key combinations. That way if you're used to, for example, pressing
Command-C to copy text in Mac OS X, you don't have to switch to the Windows equivalent,
Control-C.

You can also use and customize keyboard shortcuts for switching between Coherence, Full
Screen, and Window view modes, and for showing and hiding Parallels Desktop.

Customize Keyboard Shortcuts

1 Do one of the following:

- Click the Parallels icon Il in the menu bar and choose Preferences.

= Right-click the Parallels Desktop icon in the Dock and choose Preferences.
2 C(Click Shortcuts

3 Select Windows from the Virtual Machines list in the sidebar.
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Or if you're using another operating system with Parallels Desktop and you want to customize
keyboard shortcuts for it, select it in the sidebar.

& Shortcuts
= P @ = &
General Shortcuts Devices Security MNetwork Advanced Toolbox Access
q Application Shortcuts Profile: Windows &
On FromOS X To Windows
OS X System Shortcuts v N3 Space Switch Language
i v 3 Space Switch Language
J Mouse Shortcuts e Ctrl+X
#C Ctrl+C
== Keyboard Menu apy Ctrl+V
BA Ctri+A
VIRTUAL MACHIMES
E Ctrl+Z
%P Ctrl+P
gg Windows XP ®F Ctrl+F
#B Ctrl+B
@ Ubuntu Linux 1 I Ctri+l
|+ ]~ |- |
E‘Z{“ Click the lock to prevent further changes. Restore Defaults ?

When you're using a Windows application, pressing a key combination in the From column
above triggers the key combination in the To column.

4 |If the lock icon is locked, click it and enter an administrator password.

5 Do one of the following:
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= To edit an existing key combination, double-click the key combination or select it and click

the Edit button | ¥, Click modifier keys to select or deselect them. If you wish, change the
character in the text field.

From: {88

-—i shlf[vn_-l A Ctri Al |-_ R 3 Gmd“"‘l

To: Ctrl+Z
o shift | & Ctrl & Win x Alt z v
Clear Cancel oK

= To delete a key combination, select it and click the Remove button
= To add a new key combination, click the Add button L% |,

If you're using multiple operating systems with Parallels Desktop, you can create keyboard profiles
for each OS (p. 135).

Note: 1. Some key combinations can't be edited or deleted.

2. There are Mac shortcuts that do not have similar shortcuts in Windows For example, you can use the
F11 key or Fn+F11 combination to see your Mac OS desktop with Expose, but in Windows there are no
keys or key combinations that enable you to perform the same action, because there is no Expose in
Windows.

Enable or Disable Mac OS X System Shortcuts

In Mac OS X the function keys on your keyboard (F1, F2, F3 and so on) control functions like
activating Dashboard and Mission Control, adjusting screen brightness, and controlling the volume.
By default, when a Windows application is active the function keys and other Mac system shortcut
key combinations (such as pressing Cmd + Tab to switch between open applications) continue to
activate Mac OS X functions.

To set whether function keys and OS X system shortcut key combinations activate functions in OS
X or Windows:

6 Click OS X system shortcuts in the sidebar.
7 Select one of the following from the Send OS X system shortcuts menu:

= Always: When Windows or Windows applications are active, function keys and other
system shortcuts always trigger functions in Windows.

= Never: Function keys and other system shortcuts always trigger functions in OS X.

= Auto: If you're working with Windows, system shortcuts that don't function in Windows (for
example, Control-Up Arrow button to display Mission Control) trigger functions in OS X. If
you're using OS X as a guest OS and a guest OS or its application is active, system
shortcuts that are typical only to OS X trigger functions in the guest version of OS X.
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Customize Keyboard Menu

In Window mode you can enter key combinations by choosing Devices > Keyboard and then
choosing a key combination. To customize available key combinations, do the following:

8 Do one of the following:
= Click the Parallels icon Il in the menu bar and choose Preferences.

= If the Parallels Desktop menu bar is visible at the top of the screen, choose Parallels
Desktop > Preferences.

9 Click Shortcuts > Keyboard Menu.
10 If the lock icon is locked, click it and enter an administrator password.

11 Do one of the following:

= To add a new key combination, click the Add button | * |,

= To remove a key combination from the Keyboard menu, select it and click the Remove

button
= To edit an existing key combination, double-click the key combination or select it and click

the Edit button ¥, Click modifier keys to select or deselect them. If you wish, change the
character in the text field.

To:

BEESHIRS ~ Curl | IR - Al ¥

Clear Cancel oK

Create New Keyboard Shortcuts

You can press certain key combinations, called keyboard shortcuts, to quickly trigger various
actions in Parallels Desktop. For example, you can press Command-Control-F to switch Windows
to Full Screen mode. You can use existing keyboard shortcuts (you can see them in the Parallels
Desktop > Preferences > Shortcuts > Application Shortcuts pane), and you can also create
your own.

To create a new keyboard shortcut:
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1 Make a note of the name for the command you want a shortcut for as it appears in a menu in
Parallels Desktop. For example, if you want to create a new shortcut for switching to Full
Screen mode, you can see by opening the View menu in Parallels Desktop that the name of the
menu item is Enter Full Screen:

VIEUH Virtual Machine  Devices  Wind

Enter Coherence ~3+
Enter Full Screen
Enter Modality AN BS

Parallels Desktop File

+ Use All Displays in Full Screen
Use MaclLook

Make Screenshot

Hide Status Bar

In Mac OS X, choose Apple Menu > System Preferences.
In System Preferences, click Keyboard and click Shortcuts.
Select App Shortcuts in the sidebar and click the Add button =

If you want a new shortcut to work only for Parallels Desktop, choose Parallels Desktop from
the Application menu. If you leave All Applications selected, the shortcut will work for any
application that has the same command name and is currently active.

a h ODN

6 Enter the menu item name from Step 1.

Important: You must enter the command name exactly as it appears in the Parallels Desktop menu or
your new shortcut won't work.

7 Inthe Keyboard Shortcut field, press the key combination that you want to trigger the action.

Note: You must create separate shortcuts for commands that change in the menu depending on the
state of Parallels Desktop, such as Enter Full Screen and Exit Full Screen.

See and Change Windows Input Language In OS X

While you're working with Windows or any Windows applications, Parallels Desktop shows the
input language set in Windows in OS X menu bar. You may find it useful while working with
Windows in Coherence (p. 41) when the guest OS desktop is hidden.

4) E (= 19:23 Parallels Q
As soon as you switch to Mac, the input language in OS X menu bar changes back to the language
that was set before you started working with Windows.

To make this feature work properly, Parallels Tools (p. 142) must be installed and the same input
languages must be available in Windows and OS X. To learn how to add input languages, please
refer to the help resources for these operating systems.
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Change Windows Input Language From OS X Menu Bar

To change the Windows input language from the OS X menu bar:

1 Click Windows or your Windows application to make it active.

2 Choose the language you need from the Input menu available in the OS X menu bar.

(= 19:12 Parallels Q

v E US.
B German
= Spanish
L1 French

Show Input Source Name

Open Language & Text Preferences...

Note: The language you're selecting from the Input menu must be also available in Windows. To learn
how to add a language to the list of input sources in Windows, please refer to the Windows help
resources.

If the Input menu isn't available in OS X menu bar, you can set it to show by doing the following:

1 In Mac OS X, choose Apple menu > System Preferences and click Language & Text.
2 Click Input Sources.

3 Select the language or languages you want to use from the sidebar.

4

Select Show input menu in menu bar.

Mouse & Keyboard Settings

Use Mouse & Keyboard settings, you can:

= Set whether the mouse pointer behavior is optimized for games.

= Set whether the mouse pointer sticks at the edges of the window in Window mode (p. 43).
= Set whether modifier keys are optimized for games.

To access Mouse & Keyboard settings:

1 Do one of the following:

- Click the Parallels icon Il in the menu bar and choose Configure.

= |[f the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.
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2 C(Click Hardware and select Mouse & Keyboard in the sidebar.

. & (<] Windows 10 - Hardware

c = O B

General Options Hardware Security Backup Dev Settings Business

ﬂ CPU & Memory Mouse: Auto-detect for games K
45 Change this option if you have problems with moving a mouse
% Boot Order pointer in some applications.

m Graphics Mouse pointer sticks at window edges

Smooth scrolling
-‘ Mouse & Keyboard
Keyboard: Don't optimize for games ﬁ

H Shared Printers When the keyboard is optimized for games, modifier
keys become more responsive.

@ Network 1
Shortcuts can be configured in Parallels Desktop Preferences:
i Brinter 1 Open Shorteuts Preferences..,

m USB & Blustooth

+ | = Restore Defaults

LE“ Click the lock to prevent further changes.

Mouse

If you play games in a virtual machine, the Mouse menu allows you to set how to use a mouse:

= Auto-detect for games. This is a recommended default setting. If you're working with a guest
OS application, the mouse moves freely between the guest operating system and Mac OS X.
However, when you start a game, SmartMouse automatically captures the mouse input in the
virtual machine so that you couldn't move the mouse to Mac OS X by mistake and
automatically releases the mouse when you quit the game.

= Optimize for games. If your mouse accidentally moves to Mac OS X when you're playing a
game, select this option to make the mouse work in the virtual machine only.

< Don't optimize for games. In some rare cases, SmartMouse may detect an application as a
game and the mouse starts working incorrectly with the application. If you have this problem,
choose Don't optimize for games.
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Mouse Pointer Sticks at Edges

When working with a virtual machine in Window view mode (p. 43), you may often need to move

the mouse pointer to the edges of the virtual machine window to display various guest OS items:

for example, to display the Start menu in Windows 8, hidden taskbar in Windows XP, or OS X
menu bar when any of the guest OS X applications is running in full screen.

The Mouse pointer sticks at window edges option makes the mouse pointer pause for a while at

the edges of the virtual machine window and you won't move the mouse outside of the virtual
machine window by mistake. To move past the edge, just move the mouse quickly.

Modifier Keys Optimization

Choose Optimize for games from the Keyboard menu if you actively use the modifier keys Option

(Alt), Ctrl, and Shift in action games. If you choose this option, signals from these keys will be
processed faster.

Note: You're not recommended to optimize keyboard for games when not playing games.

Connect External Devices

Parallels Desktop allows you to use USB, Thunderbolt, and FireWire devices with Windows.

Many external devices, such as mice and printers, are available by default to both Windows and
Mac OS X when you connect them to your Mac.

Some external devices, such as an Apple iPhone, can only be used with either Mac OS X
applications or Windows programs, but not both at the same time. When you connect such a
device, you can choose whether you want to use it with Mac OS X or Windows.

To connect an external device:

1 Connect the device to your Mac.
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2 If Windows is running and the device can't be used with both Windows and Mac OS X at the
same time, you're prompted to choose which one you want to use it with. To use the device
with Mac OS X applications, click the Mac icon. To use it with Windows programs, click the
Windows screen.

New external device detected

T r
Windows #

e

! External HDD

ali
Haolel to remember the choice
i

You can connect up to 12 USB 3.0 (p. 196), 15 USB 2.0 and 32 USB 1.1 devices to your Mac and
use them with Windows. You can connect and use up to 30 USB printers.

Important: To be able to use a USB device with Windows programs, you may need to install Windows
drivers for the device. Typically you can download drivers from the manufacturer's website.

You can also set what happens when any new external device is connected and set particular
external devices to always be used with either Mac OS X or Windows (p. 79).
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Connect a Common Access Card reader

A Common Access Card (CAC) reader can work simultaneously in Mac OS X and Windows.

1 Connect the CAC reader to your Mac.

2 When you're prompted to choose Windows or the Mac, click the Windows screen. The CAC
reader becomes available to both Windows and Mac OS X.

Adjust Devices Settings

In the Devices pane of Parallels Desktop Preferences, you can:

= Set what happens when you connect any new USB, Thunderbolt, or FireWire device to your
Mac.

e Set a particular external device to always be used with either Mac OS X or Windows.
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e (Choose to mount Windows-connected external NTFS drives to Mac.

@ Devices
o @=Ll L@ O =Na
| General Shortcuts Devices Security Network Advanced Toolbox Access

When a new external device is detected:

Connect it to my Mac
Connect it to the active virtual machine
) Ask me what to do

Mirror Windows-connected drives on Mac

Permanent Assignments:
Devices Connect To

Apple Internal Keyboard / Trackpad Your Mac

gl Click the lock to prevent further changes.

To access Devices Settings:
1 Do one of the following:

= Click the Parallels icon Il in the menu bar and choose Preferences.
= Right-click the Parallels Desktop icon in the Dock and choose Preferences.

2 Click Devices.

Set What Happens When You Connect a New External Device to Your Mac

Choose one of the following:

= Connect it to my Mac. New external devices are automatically available for use with Mac OS X
applications.
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= Connect it to the active virtual machine. New external devices are automatically available for
use with Windows programs. If Windows isn't running, the external device is connected to Mac
OS X.

= Ask me what to do. Each time you connect an external device, you're prompted to choose
whether you want to connect the device to Windows or the Mac.

Set a Particular External Device to Always Be Used With Mac OS X or Windows

If you know you always want a particular external device to be available to either Mac OS X or
Windows, you can set it to do so by following the instructions below. The device must already have
been connected to your Mac at least once.

Click the Add (+) button towards the bottom of the window.
2 Select the device from the list.

3 Double-click the word (either Computer or some form of Windows) in the Connect To
column. The word becomes a pop-up menu.

4 Do one of the following:

= To set the device to always be available to Mac OS X applications, choose Computer from
the menu.

« To set the device to always be available to Windows programs, choose Windows from the
menu.

To remove an existing assignment, so that the device no longer automatically connects to Mac OS
X or Windows, select the device in the External Device column and click the Remove (-) button.

Important: To be able to use an external device with Windows programs, you may need to install
Windows drivers for the device. Typically you can download drivers from the manufacturer's website.

Mount Windows-connected external NTFS drives to Mac

If you connect an external NTFS drive to Windows, you can make it available in OS X as well. To do
s0, choose Mirror Windows-connected drives on Mac.

Connect Bluetooth Devices

Parallels Desktop lets you connect Bluetooth devices directly to Windows.
Before connecting a Bluetooth device, Bluetooth must be enabled.

To enable Bluetooth:

5 If Bluetooth is turned off in Mac OS X, turn it on. Choose Apple menu > System Preferences
and click Bluetooth. Then select On.
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In Parallels Desktop, start Windows (p. 31) if it isn't already started.
7 Do one of the following:
= Click the Parallels icon Il in the menu bar and choose Configure.

= |f the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.

8 Click Hardware and click USB & Bluetooth in the sidebar.

9 Select Bluetooth devices.

Once you've enabled Bluetooth, you can pair Bluetooth devices with your computer and they'll
work with both Windows and Mac OS X. For instructions on pairing a Bluetooth device with your
computer, see the documentation that came with the device.

In Windows 7, you can send a file to a paired Bluetooth device that's capable of receiving files by
right-clicking the file and choosing Send to > Bluetooth.

Besides Windows, you can connect Bluetooth devices to any guest operating systems (Linux or
Mac OS X) that support USB Bluetooth adapters.

Print from Windows

By default, Windows is set to use the same printer that you use with Mac OS X. Simply print from a
Windows program the way you normally would.

You can also set Windows to use a different printer. There are a few ways to set up printing in
Windows:

= Share any of the printers connected to your Mac.

= (Connect to a network printer.

e Connect a USB printer directly to Windows.
Share a Printer Connected to Your Mac

You can use any printer connected to your Mac with Windows programs.

Note: This functionality is also available for Linux with Parallels Tools installed (p. 143).

To print a document from a Windows program:

= Open the document and simply print it the way you normally would (for example, choose File >
Print).

In the print window, you can choose any printer that's connected to your Mac.
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Share Printers Connected to Your Mac

1 Do one of the following:

= Click the Parallels icon Il in the menu bar and choose Configure.

= |f the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.

2 Click Hardware and select Shared Printers.

Note: The Shared Printers pane is available for Windows 2000 and newer versions of Windows.

3 Select Share Mac printers with Windows.

Set a New Default Printer

By default, Windows is set to use the same default printer as your Mac. To use a different default
printer for Windows.

1 Do one of the following:

= Click the Parallels icon Il in the menu bar and choose Configure.

= [f the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.

2 Click Hardware and select Shared Printers.

3 Deselect Synchronize default printer.

Now you can set a new default printer in Windows the way you normally would.
Show Page Setup Before Printing

When you choose to print a document from Windows, first you need to set how the document will
be printed. You usually have to specify various printing settings, such as orientation, page size,
whether to print the document on one or both sides, etc. Once everything is ready and you click
Print in Windows, the OS X window with printing settings appears as well. It's done by default for
you just to ensure that the document will be printed exactly the way you want.

To make the documents print without showing this OS X page setup window:

1 Do one of the following:
« Click the Parallels icon Il in the menu bar and choose Configure.

= |If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.

2 Click Hardware and select Shared Printers.

3 Deselect Show page setup options before printing.
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Add a Printer in Linux

The procedure of adding a printer in a Linux guest operating system depends on the Linux
distribution. In this example, we describe how to add a printer to a virtual machine running RHEL
5.4 Server. However, you can use these guidelines as general instructions on how to add a printer
to a Linux virtual machine:

1 Start the Linux virtual machine and log in when the guest operating system boots up.

Note: You must log in as root or acquire root privileges after successful login. If you don't do that, you
will be required to enter the root password when starting the system-config-printer
administration tool in the next step.

2 Start the system-config-printer administration tool by doing one of the following:
= C(Click System > Administration > Printing; or

= Start the Terminal and enter the following command:
system-config-printer

3 In the displayed window, click New Printer.

4 In the next window, you must type a printer name. Under this name the printer will be displayed
in your Linux guest operating system. You can also enter the printer description and location.
When ready, click Forward.

5 Now you have to specify how your Mac printer will be shared with the virtual machine. As the
printer is connected to the virtual machine printer port, select LPT #1 (or another port to which
the printer is connected) and click Forward.

6 Then specify the printer manufacturer and model. No matter what printer you have, choose
either HP Color Laserdet 8500 PS or Apple Color LW 12/660 PS. When ready, click Forward.

7 Click Apply to finish setting up the printer.

Now the printer is properly configured and you can use it to print documents from your Linux
virtual machine.

Set Up a Printer Using Bonjour

If you have more than one Mac connected to your home network, you can use Apple Bonjour for
Windows to share any printer connected to any of them.

To see the list of all Windows operating systems supported by Bonjour, please refer to
http://support.apple.com/kb/dI999.

Important: To share a Mac printer with Windows via Apple Bonjour, Windows must be configured to
work in the Bridged networking mode.

To set up a printer via Bonjour:
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Be sure the printer you want to use is set to be shared on your Mac. To share a printer, in Mac
OS X choose Apple menu > System Preferences and click Print & Fax. Then select the
printer and select Share this printer.

Open Parallels Desktop and start Windows.

When Windows starts, go to http://support.apple.com/kb/dI999 and download the Bonjour for
Windows installation package.

In Windows, start the Bonjour installation by launching the Bon jourPSSetup - exe file from
the folder in which it was downloaded.

Follow the onscreen instructions to install Bonjour for Windows.

Start the Bonjour Printer wizard either by double-clicking its icon on the desktop or by selecting
Start -> All Programs -> Bonjour Print Services -> Bonjour Printer Wizard.

In the Browse for Bonjour Printers window, select the printer that you want to use and click
Next.

If the next window you see is Completing the Bonjour Printer Wizard, then the driver required
by this printer is available in the Windows driver library and the printer has been successfully
configured. Click Finish and you can start using the newly added printer to print documents
from Windows programs.

However, if the next window you see is Install Bonjour Printer, you must choose the printer
manufacturer and model.

Bonjour Printer Wizard E
Install Bonjour Printer s
The manufacturer and model determine which printer software to usa. b
g
ﬁ- HP Deskjet D2300 series

The Bonjour Printer Wizard has auto-selected the following printer settings.
Click ‘Mext’ to continwe instaling this printer,

Manufacturer = || Model o

Fuji Xerox HP 2500C Series Prirber

Fugitsu | hp business inkjet 1000

Generic . hp business inijet 1200

Gestetner | HP Business Inijet 22002250

e | | HP Business Inkjet 2200/2250 (HPA)

TR T L HP A inaee Taldiat 39003380 55 i
" |Use this printer as the default printer Have Disk...

et ] (o

If the required printer model is not listed, you can do one of the following:
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= Install the printer drivers in Windows. Then click Have Disk button in the Install Bonjour
Printer window and specify the path to the . InfT file located in the folder where you
installed the printer drivers.

< In the Install Bonjour Printer window, select Generic in the Manufacturer list and
Generic/Postscript in the Model list.

Click Next.

9 In the Completing the Bonjour Printer Wizard window, click Finish. You can start using the
newly added printer to print documents from Windows programs.

Set Up a Network Printer

You can install a network printer directly into Windows.

Before installing a network printer in Windows, make sure that:

e Your Mac can access the Internet.

< Windows is configured to work in either the Shared networking mode (p. 95) or Bridged
networking mode and can access the Internet too.

= The user account in Windows has permission to access the network printer.

= You know the printer IP address.

After that, you can log in to Windows and install a hetwork printer.

In Windows

Before adding a network printer in Windows, download and install an appropriate printer driver. For
detailed information on installing the printer driver, refer to the printer manufacturer documentation.

To add a network printer in Windows 7 or Windows Vista:

Open the Windows Start menu and select Control Panel.

2 In the Control Panel window, select Hardware and Sound and click Add a printer in the
Devices and Printers section (Printers in Windows Vista). The Add Printer wizard opens.

In the first window, click Add a network, wireless or Bluetooth printer.
In the next window, click The printer that | want isn't listed.

In the Find a printer by name or TCP/IP address window, select Add a printer using a
TCP/IP address or hostname and click Next.

6 Inthe Type a printer hostname or IP address window, do the following:
1. Select TCP/IP Device from the Device type menu.
2. Specify the printer IP address in the Hostname or IP address field.
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3. Clear the Query the printer and automatically select the driver to use option if it is
selected.

4. When ready, click Next.

7 If prompted to specify additional port information, choose Standard, select Generic Network
Card from the list, and click Next.

8 Inthe Install Printer Software window, specify the manufacturer and model of the network
printer.

If the required printer model is not listed, click Have Disk button and specify the path to the
- inT file located in the folder where you installed the printer driver.

When ready, click Next.

9 Continue with the printer configuration procedure. When the printer is added to Windows, you
can use it to print documents from Windows XP.

To add a network printer in Windows XP:
Open the Windows Start menu and select Control Panel.
In the Control Panel window, double-click the Printers and Faxes item.

Click the Add a printer link to open the Add Printer wizard.

In the Welcome to the Add Printer Wizard window, click Next.

a A ON =

In the Local or Network Printer window, select Local printer attached to this computer and
clear the Automatically detect and install my Plug and Play printer option if it is also
selected. When ready, click Next.

6 In the Select a Printer Port window, select Create a new port and specify Standard TCP/IP
Port as the port type. When ready, click Next.

7 Inthe Welcome to the Add Standard TCP/IP Printer Port Wizard window, click Next.
In the Add Port window, specify the network printer IP address and click Next.

If prompted to specify additional port information, choose Standard, select Generic Network
Card from the list, and click Next.

10 In the Completing the Add Standard TCP/IP Printer Port Wizard window, click Finish.

11 In the Install Printer Software window, specify the manufacturer and model of the network
printer.

If the required printer model is not listed, click Have Disk button and specify the path to the
- inT file located in the folder where you installed the printer driver.

When ready, click Next.

12 Continue with the printer configuration procedure. When the printer is added to Windows, you
can use it to print documents from Windows XP.
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In Linux

The procedure of setting up a network printer in a Linux or FreeBSD guest operating system
depends on the Linux or FreeBSD distribution and printer. In this example, we describe how to set
up a network printer in a virtual machine running RHEL 5.4 Server. However, you can use these
guidelines as general instructions on how to set up a network printer in a Linux or FreeBSD virtual
machine.

Note: For more detailed information, refer to the CUPS documentation.

To set up a network printer:

1 Start the virtual machine.

2 Make sure the following components are installed in the guest operating system:
e Common UNIX Printing System (CUPS). Installation instructions can be found at CUPS site;
= Samba service. Installation instructions can be found at Samba site; and

< A Web browser, since we consider controlling CUPS via web interface.

Note: To set up a network printer, you should have root privileges.
3 Download and install an appropriate printer driver. For detailed information on installing the
printer driver, refer to the printer manufacturer's documentation.

4 Start Common UNIX Printing System. In the Terminal, type the command:
/etc/init.d/cups start

5 Start a web browser and type either the IP address of your virtual machine or
http://127.0.0.1:631.

Click the Add Printer button.

In the Add New Printer window, specify a printer name. Under this name the printer will be
displayed in the guest operating system. You can also enter the printer description and location.
When ready, click Forward.

8 In the Device for <Printer Name> window, select AppSocket/HP JetDirect and click
Continue.

9 In the Device URI for <Printer Name> window, specify the printer IP address in the following
format:

socket://<printer IP address>
When ready, click Continue.

10 In the Make/Manufacturer for <Printer Name> window, select the manufacturer of your
printer and click Continue.

11 In the Model/Driver for <Printer Name> window, select the model of your printer and click
Add Printer.

12 Enter the root password when prompted.
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CUPS performs the installation. If the installation is successful, the "Printer <name> has been
configured successftully" message is displayed. Now you can use this printer to print
documents from the virtual machine.

Set Up a USB Printer

You can connect a USB printer directly to Windows. In this case, the printer isn't available to Mac
OS X. If you want to use the printer to print both from Mac OS X and from Windows, see Share a
Mac Printer (p. 82).

To connect a USB printer directly to Windows:

—t

In Parallels Desktop, start Windows.

2 When Windows starts, install the printer driver. For detailed information on how to do that, refer
to the printer manufacturer's documentation. Typically you can find drivers on the
manufacture's website.

3 Do one of the following:
= If the USB printer is already connected to your Mac:

« |f Windows is in Coherence, click the Parallels icon Il'in the menu bar, choose Devices >
USB and select this printer from the list.

= [f Windows is working in a separate window, in the Mac menu bar click Devices > Printer >
Printer and select this printer from the list.

= |f the USB printer is not connected to your Mac, connect it. In the New USB device detected
window, connect the printer to Windows.

4 In Windows, follow the Add New Hardware wizard instructions.

Create a PDF File

When working with a text document, web page, or other file, you may wish to create a Portable
Document Format (PDF) file out of it. A PDF file preserves the format and layout of a document, so
others can see it as if it were printed on the page.

To create a PDF file, select Print to PDF (Mac Desktop) when choosing a printer. A PDF file is
saved on the Mac desktop.

Note: This functionality is available for Windows guest operating systems provided that Parallels Tools
are installed (p. 140) and all Mac printers are shared (p. 82) with Windows.
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Use the Built-in iSight Camera or Another
Webcam

If your Mac or display has a built-in iSight camera, or if you connect a compatible external webcam,
by default you can use it with Windows.

To use a built-in iSight or external camera with Windows:

= Simply open a Windows program that uses a camera, you should be able to select the iSight or
external camera for use with the program.

Note: If you are running a guest OS other than Windows XP Service Pack 2 or later, Windows Vista, or
Windows 7, be sure you have USB video device class (UVC) drivers installed.

Disable Camera Sharing

If you don't want Windows programs to be able use connected webcams or the built-in iSight
camera, you can disable camera sharing by doing the following:

1 Do one of the following:
= Click the Parallels icon Il in the menu bar and choose Configure.

= |If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.

2 Click Hardware and click USB & Bluetooth.

3 Deselect Web cameras.

Show a Presentation on an External Monitor or
Projector

You can easily connect your Mac to an external monitor or projector and show a presentation from
a Windows application, with little configuration needed.

To do so:

1 Start Windows (p. 31) if it isn't already running.
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2 Connect your Mac to the external monitor or projector as you normally would. A message
appears asking if you're going to show a presentation.

Are you going to show a presentation
in Parallels Desktop?

[J Use Mirroring

\[o] Yes

1t
Hold to remember the choice for this display

3 If you want to show the exact contents of your computer's display on the external display or
projector, select Use Mirroring.

If you don't select Use Mirroring, certain applications, such as Microsoft Powerpoint, may
show a presenter view on your computer while showing only the presentation on the external
display or projector.

4 Click Yes. Windows switches to Presentation mode, displayed at full screen on both your
computer's display and external display or projector. After that, you can start showing your
presentation.

Note: To learn how to choose on which display the presentation is shown, please refer to Help of the
application you're using for presentations.

Important! While you're working in Presentation mode, changing display settings in Windows may
cause the presentation to malfunction.

Protect Your Data

You probably have important documents, photos, and more on your Mac. When running Windows
on your Mac, it's especially important to protect your data from viruses and unauthorized use. Read
this section to learn how.
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Protect Your Data from Viruses

Parallels Desktop offers complementary trial subscription to Kaspersky antivirus software for both
Mac OS X and Windows.

To take advantage of this offer, you download and install Kaspersky Internet Security for Windows
and for the Mac. When the trial period expires, you can purchase a permanent activation key.

Download and Install Antivirus Protection for Windows

1 Open Parallels Desktop and start Windows.

2 Click the Parallels icon Il in the menu bar and choose Actions > Install Internet Security and
follow the onscreen instructions.

Note: To install antivirus protection for Windows, Parallels Tools must be installed (p. 199). In most
cases, Parallels Tools are installed by default.

Remove Antivirus Protection from Windows

To remove Kaspersky Internet Security, remove it the same way you'd remove any other Windows
application. See Windows Help and Support for more information.

Download and Install Antivirus Protection for Mac

1 If Parallels Desktop is set to Coherence mode, click the Parallels icon Il'in the menu bar and
choose View > Exit Coherence.

2 Choose Parallels Desktop > Install Antivirus for Mac and follow the onscreen instructions.

Remove Antivirus Protection for Mac

Choose Uninstall Antivirus for Mac from the Parallels Desktop menu and enter your
administrator name and password.
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Isolate Windows from Mac

You can isolate Windows from OS X, so that they no longer share folders, profiles, and
applications, connected external devices are no longer automatically accessible by Windows,
Windows and Mac no longer synchronize volume, and you can no longer copy or move objects
between Windows and OS X. Isolating Windows from OS X may provide a higher level of security
by not allowing compromised items from one OS to come into contact with the other.

To isolate Windows from OS X

1 Do one of the following:

= Click the Parallels icon Il in the menu bar and choose Configure.

= |f the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.

2 C(Click Secuirity.

3 Select Isolate Windows from Mac.

Work in Windows Without Saving Changes

If you don't want Windows to store the changes you make to it during the working session (for
example, when testing some Windows programs that may damage Windows), you can start
Windows in Rollback Mode:

Note: This feature is available in Parallels Desktop for Mac Pro Edition only.

1  Open Parallels Desktop.
2 From Control Center select Windows that you want to start in Rollback Mode and click
Actions > Start in Rollback Mode.

Set Windows to Always Start in Rollback Mode

If you want Windows to always start in Rollback Mode:

1 Open Parallels Desktop.
2 From Control Center select Windows and click Actions > Configure > Security.

3 Choose Ask me what to do from the Rollback Mode menu.

Note: If you have the automatic compression of virtual disks (p. 100) enabled, it will become disabled
after you enable Rollback Mode.
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Set Password Requirements

For added security, you can set Parallels Desktop to require an administrator password to perform
certain functions.

1 Do one of the following:
- Click the Parallels icon Il in the menu bar and choose Configure.

= |If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.

2 (Click Security.

3 Select one or more of the following to require a Mac OS X administrator password to perform
the selected action:

= Exit full screen mode: A password is required to exit full screen mode (p. 43).

« Change virtual machine state: A password is required to start, stop, suspend, pause, or
shut down (p. 36) Windows.

< Manage snapshots: A password is required to create or delete a snapshot (p. 121), or
revert to a snapshot.

Encrypt Windows to Protect It from Unauthorized Use

If you store any important data using Windows programs, it is highly recommended that you
encrypt Windows to protect your data from any unauthorized use.

Encrypt Windows

To encrypt Windows (it must be shut down):

1 Select Windows and click Actions > Configure > Security.

2 On the Security tab, click Turn On, specify a password, and click OK.

Warning: The specified password is very important. You must record it. Without this password,
you can't start Windows.

Change Your Password

To change the password for an encrypted Windows (it must be shut down):

1 Select Windows and click Actions > Configure > Security.

2 On the Security tab, click Change Password, specify a new password, and click OK.
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Remove Encryption from Windows

To remove encryption from Windows (it must be shut down):

1 Select Windows and click Actions > Configure > Security.
2 On the Security tab, click Turn Off.

Connect to the Internet or a Network

Parallels Desktop allows you to use three types of networking with Windows:

= Shared Networking: Windows programs share a network connection with Mac OS X. This is
the default setting.

= Bridged Ethernet: Windows can use one of your Mac's network adapters. This makes
Windows appear as a separate computer on the network.

= Host-only networking: Windows can access only your Mac.

In most cases, you don't need to adjust network settings. If your Mac is set to connect to a

network or to the Internet, Windows programs have access to the same network and the Internet.

The Bridged Ethernet networking mode is more complex and you may need to contact your
system administrator to set it up properly.

Read on for detailed information on these types of networking and how to configure them.

Share Network Settings Between Mac OS X and Windows

By default, Windows is set to share network settings with Mac OS X. Windows programs can
access other computers on your local network and the Internet by using the IP address of your
Mac. Windows does not have its own IP address on the network.
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In most cases, you don't need to adjust network settings. If your Mac is set to connect to a
network or to the Internet, Windows programs have access to the same network and the Internet.
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You may wish to use Shared Network mode in the following cases:

= Your Mac accesses the Internet via a modem or another non-Ethernet device.
< You need to access the Internet from inside Windows but are concerned about security.

= You have problems with working in the Bridged Ethernet mode.
To configure Windows to use Shared Networking:

1 Do one of the following:
« Click the Parallels icon I in the menu bar and choose Configure.

= |f the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.

2 C(Click Hardware and then click Network.
3 Inthe Network pane, make sure that the Shared Network option is selected.

Note: In the MAC address field, you can change the MAC address currently assigned to Windows.
MAC addresses are automatically generated when you first set up Windows on your Mac. However, you
can modify the default MAC address by typing another value in the MAC address field or clicking the
Generate button. When entering a new MAC address, make sure that it is unique within your network.

For the information about troubleshooting networking problems, refer to the Parallels knowledge
base http://kb.parallels.com/ available at the Parallels website.

Apply Separate Network Settings to Windows

When operating in the Bridged Ethernet mode, Windows appears on the network as a stand-alone
computer with its own IP address and network name.
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Note: The Bridged Ethernet networking mode is more complex than the Shared Networking mode and
you may need to contact your system administrator to configure it properly.
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To configure Windows to work in the Bridged Ethernet mode:

1 Do one of the following:

- Click the Parallels icon Il in the menu bar and choose Configure.

= |If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.

2 Click Hardware and then click Network.

3 In the Network pane, select the appropriate network adapter from the list. To connect the
virtual machine's adapter to the active network adapter of your Mac, choose Default Adapter.

Note: In the MAC address field, you can change the MAC address currently assigned to Windows.
MAC addresses are automatically generated when you first set up Windows. However, you can modify
the default MAC address by typing another value in the MAC address field or clicking the Generate
button. When entering a new MAC address, make sure that it is unique within your network.

If you can't configure Windows to function in the Bridged Ethernet mode, consider using Shared
Networking or Host-Only Networking.

For the information about troubleshooting networking problems, refer to the Parallels knowledge
base http://kb.parallels.com/ available at the Parallels website.
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Use Host-Only Network Settings

Parallels Desktop provides a closed network that is accessible only to Mac OS X and Windows.
Mac OS X is connected to this network via the Parallels Host-Only Networking adapter
automatically created on your Mac during the Parallels Desktop installation. The addresses for
Windows are provided by the Parallels DHCP server.
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To configure Windows to use Host-Only Networking:

1 Do one of the following:

= Click the Parallels icon Il in the menu bar and choose Configure.

= |If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.

2 Click Hardware and then click Network.

3 Inthe Network pane, make sure that the Host-Only option is selected.

Note: In the MAC address field, you can change the MAC address currently assigned to Windows.
MAC addresses are automatically generated when you first set up Windows. However, you can modify
the default MAC address by typing another value in the MAC address field or clicking the Generate
button. When entering a new MAC address, make sure that it is unique within your network.

For the information about troubleshooting networking problems, refer to the Parallels knowledge
base http://kb.parallels.com/ available at the Parallels website.

Use Wi-Fi with Windows

If your Mac is already connected to the Internet wirelessly, by default Windows is also set to access

the Internet wirelessly, with no setup required.
If you change your network setup, you can reconfigure a Wi-Fi connection using the Bridged

Ethernet mode, When operating in this mode, Windows appears on the network as a stand-alone
computer with its own IP address and network name.
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To configure Windows to access the Internet through Wi-Fi:

1 Do one of the following:

= Click the Parallels icon Il in the menu bar and choose Configure.

= |[f the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.

2 Click Hardware and then click Network.

3 In the Network pane, choose Wi-Fi from the list.

After you perform these steps, Windows is able to connect to the Internet through the Wi-Fi
adapter of your Mac.

If you can't configure your virtual machine to function in the Bridged Ethernet mode, consider using
Shared Networking or Host-Only Networking.

For the information about troubleshooting networking problems, refer to the Parallels knowledge
base http://kb.parallels.com/ available at the Parallels website.

Connect Windows to a VLAN

If your Mac is a VLAN (virtual local area network) member, Parallels Desktop allows you to bridge
Windows to this VLAN.

To bridge Windows to the VLAN, do one of the following:

= Click the Parallels icon Il in the menu bar and choose Configure.

= |f the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.

4 Click Hardware and then click Network.
5 Select Bridged Network > VLAN from the Source list.

Windows is bridged to the selected VLAN.

Optimize Performance

If Windows isn't working as speedily as you'd like, there are several simple ways you can optimize
its performance. This section contains many helpful instructions for doing just that.

Read this section to find out how you can tune Windows for speed.
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Set How Much Memory is Allocated to Windows

Parallels Desktop is set to allocate a certain amount of your Mac's available RAM memory to
Windows and the rest to Mac OS X. If too much memory is allocated to Windows, Mac OS X may
slow down, which in turn can cause Windows programs to slow down because they're running on
top of Mac OS X. If, on the other hand, too much memory is allocated to Mac OS X, then Mac OS
X applications may run well but Windows programs might slow down.

To optimize the performance of both Windows and Mac OS X, set the memory allocated to
Windows to be somewhere within the recommended range.

To set how much memory is allocated to Windows:

Shut down Windows (p. 36).
Choose Actions > Configure > Hardware > CPU & Memory.

Move the memory slider to somewhere within the recommended range, indicated by the
graphic under the slider (see above).

If you use Windows programs that require lots of memory, like 3D or video production
programs, it's best to set the memory allocation towards the high end of the range (move the
slider to the right). If not, it's usually best to set it closer to the middle.

Note: No matter how much memory (RAM) your Mac has, the maximum amount of memory that can
be assigned to Windows is 8 GB. However, if you're using Parallels Desktop for Mac Pro Edition, the
maximum amount of memory that can be assigned to Windows is 64 GB.

If you change this setting and then you don't like how Windows is performing, then try a different
setting.

Note: If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock
ol

icon ®=" at the bottom of the window. The next time someone wants to change the settings in any

pane of Virtual Machine Configuration, an administrator's password will be required.

Optimization Settings

Using Optimization settings, you can:

= Optimize performance for either Mac OS X applications or Windows programs
= Tune Windows for speedier performance or more graphical features
e Set Windows to pause when no programs are open (p. 103)

= |f you're using a MacBook or other portable computer, optimize your computer for better
battery life or higher performance

= Limit the virtual machine resource usage
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To access Optimization settings:

1 Do one of the following:
« Click the Parallels icon Il in the menu bar and choose Configure.

= |f the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.

2 Click Options and select Optimization.

@ Windows 10 - Dpt'ians

= O @ -

General Options Hardware Security Backup Dev Settings Business

@ Startup and Shutdown Performance: Faster virtual machine H

i Adaptive Hypervisor
Optimization :
Tune Windows for speed

Pause Windows when possible

Sharing

va Applications
ir= Power: Better performance E

“ Eull Screen Show battery in Windows

E Modality Resource usage:

" Web & Email Low Medium No limit
Lirnitt virtual machine disk 1/O speed,
@ Maintenance CPU wsage, and bandwidth when you

want to run tasks in multiple virtual
machines.

@}hu Travel Mode

n LT PN s N P
Restore Defaults

ljj Click the lock to prevent further changes.

Optimize Performance for Mac OS X Applications or Windows Programs

Choose one of the following from the Performance menu:

= Faster virtual machine: More of your computer's resources are given to Windows. The
performance of Windows programs may be increased significantly, but Mac OS X applications
may slow down.
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= Faster Mac: More of your computer's resources are given to Mac OS X. The performance of
Mac OS X applications may be increased significantly, but Windows programs may slow down.

To set Parallels Desktop to automatically optimize performance for Mac OS X or Windows
depending on which application or program you're working with at the moment:

= Select Adaptive Hypervisor. When you're using a Windows program, more resources are
given to Windows, and when you're using a Mac OS X application, more resources are given to
Mac OS X.

Tune Windows for Speedier Performance
= Select Tune Windows for speed.
Some Windows features that tend to slow down performance, such as animations during startup,

are disabled.

Optimize your MacBook for Longer Battery Life or Higher Performance

The Power menu contains the power and performance related options:

= Longer battery life: If you have a portable Mac that you often use unplugged, you can choose
this option to lower power consumption for longer battery life. This may slightly reduce
Windows performance.

= Better performance: This option (selected by default) maximizes Windows performance, but
uses more power.

Note: If you change options in the Power menu when Windows is running, you must shut down
Windows and start it again for the changes to take effect.

To show battery status in Windows:
= Select Show battery in Windows.
When your MacBook or other portable computer is running on battery power, the battery status is

displayed in the menu bar.

Limit the Virtual Machine Resource Usage

If your Mac lacks resources for running two or more virtual machines at a time, you can limit the
virtual machine resource usage for the virtual machine doing more important work to have more
resources. Drag the slider between Low, Medium, and No limit points. If you change this setting
and then don't like how Windows is performing, then try a different setting.

Optimize 3D Graphics Performance on a MacBook Pro

Some new MacBook Pro computers have two video adapters. By default, the slower video adapter
that saves energy is used.
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To use the faster video adapter for better 3D graphics performance:

1 Inthe Mac OS X Finder, select Apple menu > System Preferences and click Energy Saver.

2 C(Click Higher performance.

Setting graphics to higher performance uses battery life faster.

Speed Up Games and Graphics Programs

With Parallels Desktop, you can run games and programs that require video cards with DirectX or
OpenGL support. To do so, you must enable 3D acceleration.

For information on whether a program requires DirectX or OpenGL support, see the materials that
came with the game or program.

To enable 3D acceleration:
1 Shut down the virtual machine. (p. 36)

2 Choose Actions > Configure.

3 In the Video pane, select On or select a version of DirectX from the 3D acceleration menu.

Note: Parallels Tools must be installed (p. 199) before you can enable 3D acceleration. Parallels Tools
are installed by default when you set up Windows.

Pause Windows When No Programs Are Open

You can conserve your computer's resources by setting Windows to pause automatically when no
Windows programs are open. That way, more resources such as RAM and CPU can be used for
Mac OS X applications.

To set Windows to pause when no programs are open:

1 Do one of the following:

= Click the Parallels icon Il in the menu bar and choose Configure.

= |f the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.

2 Click Options and select Optimization.

3 Select Pause Windows when possible.
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Optimize Virtual Machine for Games, Graphics, Productivity, or
Development

When creating a virtual machine, you can optimize it according to your needs. You can choose to
configure the virtual machine for:

= Productivity. Choose this profile if you're using the virtual machine for your everyday work with
text editors, email, web browsers, etc.

= Games only. Choose this profile if you're using the virtual machine to play PC games on your
Mac.

If you're using Parallels Desktop for Mac Pro Edition, you can configure your virtual machine also
for:

= Design. Choose this profile if you're using the virtual machine to work with graphics
applications.

= Software development. Choose this profile if you're using the virtual machine to develop and
test software.

= Software testing. Choose this profile if you're using the virtual machine to test software in an
isolated environment.

You can change this setting after the virtual machine is created:

Start Parallels Desktop.

2 In Control Center, right-click the virtual machine (it must be shut down) and choose
Configure.

3 On the General tab, click Change.
4 Select the profile that best fits your need.

Work with Windows in Travel Mode

If you often travel with your MacBook, you must have come across the situations when you had no
power adapter at hand to charge the Mac's batteries or experienced some problems when
connecting to public networks.

Travel Mode makes Windows use less energy to extend the Mac's battery life and adjusts settings
to connect to public networks.

Enter Travel Mode

To switch Windows to Travel Mode, do the following:

1 Start your virtual machine (p. 31).
2 When Windows boots up, do one of the following:
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« Click the Parallels icon Il in the menu bar and choose Actions > Enter Travel Mode.

e (Click Actions in the Parallels Desktop menu bar at the top of the screen and choose Enter
Travel Mode.

Quit Travel Mode

To quit Travel Mode, do one of the following:

= Click the Parallels icon Il in the menu bar and choose Actions > Quit Travel Mode.

= (lick Actions in the Parallels Desktop menu bar at the top of the screen and choose Quit
Travel Mode.

Enter and Quit Travel Mode Automatically

You can also configure your virtual machine to enter and quit Travel Mode automatically:
3 Do one of the following:

= Click the Parallels icon Il in the menu bar and choose Configure.

= (lick Actions in the Parallels Desktop menu bar at the top of the screen and choose
Configure.

4 Click Options and select Travel Mode.
5 To enter Travel Mode automatically, choose one of the following:

= Always when on battery power: The virtual machine enters Travel Mode when the Mac
starts working on battery power.

= When battery power is: Choose from the menu when you want your virtual machine to
enter Travel Mode.

< Never: The virtual machine never enters Travel Mode automatically.
6 To quit Travel Mode automatically, choose one of the following:

< When connected to power: The virtual machine quits Travel Mode when you connect your
Mac to power.

= Never: The virtual machine never quits Travel Mode automatically.

Schedule Windows Maintenance

From time to time, Windows needs to do various maintenance tasks like installing updates,
cleaning and defragmenting the disk(s), etc. When Windows is doing these tasks, performance may
slow down.

To avoid low performance when you're busy with important tasks, schedule Windows to run
maintenance when you're away or at any time you like:

7 Do one of the following:
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= Click the Parallels icon Il in the menu bar and choose Configure.

= (lick Actions in the Parallels Desktop menu bar at the top of the screen and choose
Configure.

8 Click Options and select Maintenance.

9 Select Start maintenance and choose the day and time from the corresponding menus.

Once ready, Windows will do maintenance at the specified time.

Use Windows on Your iPad, iPhone, or Android
Device

Parallels Access is a product created by Parallels that allows you to work with your Mac or
Windows PC and their applications remotely from your iPad, iPhone or Android device. It also
allows you to work with a remote computer via a web browser.

If you have Parallels Desktop installed on your Mac, you can use the Parallels Access app to
access and control Windows.

Parallels Access lets you:

= Use any of your Windows programs on your mobile device
= Remotely start, stop, and reset Windows

= Connect over Wi-Fi or 3G

= Access Windows from anywhere over the Internet

Get Started

Before you can use Parallels Access, you must do the following:

1 On your iPad, iPhone or Android device, download and install Parallels Access from the App
Store or Google play.

Be sure you have installed Windows on your Mac (p. 18).

In Parallels Desktop, do one of the following:

- Click the Parallels icon Il in the menu bar and choose Preferences.

= Right-click the Parallels Desktop icon in the Dock and choose Preferences.
4 Click Access.

5 Install the Parallels Access agent on your Mac by clicking Install.

You only have to do these steps once.
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Access Windows from your iPad, iPhone or Android device

1 Turn on your Mac.
Your Mac must be on for Parallels Access to access and use Windows.

2 Open Parallels Access on your iPad, iPhone or Android device and log in to your account using
the same email and password you used to register Parallels Desktop.

3 Tap your Mac in the list of available Macs.

When you access Windows for the first time, you see tips about gestures you can use to control
Windows. Tap Close to go to the Windows desktop.

For more information about using Parallels Access, see Parallels Access User's Guide, available
online.

Save Time With Parallels Toolbox

Parallels Toolbox is a set of handy tools that may help you to save time during your daily routine.
With Parallels Toolbox, you can:

= take screenshots;

e record audio;

= archive and unarchive files;

= block the Mac's camera and mute the microphone to prevent them from unauthorized access;
= set a countdown to count down days to a specific event;

= lock the Mac's screen to ensure that other users cannot access your desktop while you're
away;

= prevent your Mac from going to sleep;

= and much more.

Please refer to the Parallels Toolbox User's Guide available online for the detailed information on
what and how you can do with Parallels Toolbox.

Install Parallels Toolbox on your Mac

To install Parallels Toolbox:

1 Do one of the following:

« Click the Parallels icon Il in the menu bar and choose Preferences. Then click Toolbox.

= Right-click the Parallels Desktop icon in the Dock and choose Preferences. Then click
Toolbox.
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2 Click Install and follow the onscreen instructions.

Save a Picture of the Screen

To save a picture of Windows in Window Mode:
e (Choose View > Make Screenshot.

A file named Parallels Picture.png is saved on the Mac OS X desktop.

You can also take a picture of the entire screen at any time by pressing Command-Shift-3. By
default, pictures are saved to the Mac OS X desktop.

Set the Appearance of Virtual Machine Dock
lcons

You can choose which type of icon appears in the Mac OS X Dock when your virtual machine is
open or running.

1 Do one of the following:
« Click the Parallels icon Il in the menu bar and choose Preferences. Then click General.

= Right-click the Parallels Desktop icon in the Dock and choose Preferences. Then click
General.

2 From the Virtual Machine Dock Icons menu, choose one of the following:

= OS Icon: The Dock icon shows the icon of the operating system installed in the virtual
machine.

= Live Screenshot: The Dock icon shows a miniature image of what you see in Windows.

< None: Virtual machines running in Window, Full Screen or Modality modes don't have
separate icons in the Dock.

Allow Windows Updates While Your Mac is
Sleeping

Parallels Desktop supports OS X Power nap, which lets you keep aspects of Windows up-to-date
even while your Mac is sleeping. When Power Nap is enabled, services that usually update
information after Windows wakes from sleep (for example, new emails in email applications and
new event updates in Calendar) will update while your Mac is in sleep.

To use Power Nap, your computer must be compatible. See Apple.com for more information.
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To enable Power Nap:

1  On your Mac, choose Apple menu > System Preferences and click Energy Saver.

2 Depending on whether your Mac is working on batteries or is plugged, make sure Enable
Power Nap while on battery power or Enable Power Nap while plugged into a power
adapter is selected.

Note: To learn more about Power Nap, please refer to the OS X help resources.

Translate Words in Windows

If you're working with Windows and come across a word you don't know, you can easily look it up
in Mac OS X Dictionary. Just hover the mouse cursor over the word and either press Control-
Command-D or tap (don't click) the touchpad with three fingers.

Notes:

1. Parallels Tools (p. 142) must be installed in Windows.

2. When you hover the mouse over a word, the mouse cursor should change from arrow X to text
selection I You cannot look for words depicted on pictures.
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Advanced Topics

This chapter is intended to give you additional information on how to work with Parallels Desktop
and virtual machines.

In This Chapter
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Work with Virtual Machines

Read this section for basic information about working with virtual machines.

Supported Guest Operating Systems

Any of the following guest operating systems can be installed in Parallels Desktop virtual machines.

Express
32-bit | 64-bit | Installatio
n
Windows
Windows 10 ¥ | |
Windows 8.1 ¥ | |
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Windows 8

Windows Server 2012 SPO, R2

Windows 7 SPO, SP1

Windows Server® 2008 SPO, SP1, SP2, R2

Windows Vista® Home, Business, Ultimate, Enterprise SPO, SP1, SP2

Windows Server® 2003 SPO, SP1, SP2, R2

e | €€ e

Windows XP Home SPO, SP1, SP2, SP3

Windows XP Professional SPO, SP1, SP2, SP3

LWL L LY vy %

Windows XP Professional SP2

LCeEE|e Q€€ €|c

Windows 2000 Professional SP4

Windows 2000 Server SP4

Windows NT 4.0 Server SP6, Workstation SP6

Windows ME

Windows 98 SE

Windows 95

Windows 3.11

MS-DOS 6.22

Ubuntu® Linux 10.04 LTS, 12.04 LTS, 12.04, 13.04, 13.10, 14.04, 14.10,

LWL QD Qv v v s

15.10, 16.04 LTS v
Red Hat® Enterprise Linux 5.x, 6., 7.x !
CentOS Linux 5.x, 6.x, 7.0

Fedora™ Linux 19, 20, 21, 22, 23, 24 !

SUSE® Linux Enterprise Server 11 SP2, SP3

OpenSUSE Linux 12.3, 13.1, 13.2, 42.1

Linux Mint 13, 16, 17, 17.2, 17.3

Mageia 3, 4.1, 5

Debian® Linux 7.x, 8.x

OS X Yosemite 10.10.x

AN NN NN A NANANSEN

@E €€ e e e e w

w©

OS X Mavericks 10.9.x

«
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OS X Mountain Lion 10.8.x e
OS X Lion 10.7.x !
OS X Lion Server 10.7.x !
Mac OS X Snow Leopard Server 10.6.x :ﬁ L;.ij
Mac OS X Leopard Server 10.5.x :ﬂ L‘.ij
Chrome

Chrome OS* g
Solaris

Solaris® 10, 11 ¥

BSD

FreeBSD® 8.x, 9.x, 10, 10.1 Y
0s/2

0S/2® Warp 4.5, 4 ¥
eComStation™ 1.2, 2.x gl
Android

Android OS* "y

*Chrome and Android OSs - we currently support these operating systems as guest operating
systems only if you downloaded them as virtual appliances (p. 125) using New Virtual Machine
Wizard.

Please note that Parallels Desktop does not include operating system installation discs or their
images. You should purchase them separately.

About Virtual Machines

To add Windows or another operating system to your Mac, Parallels Desktop creates a “virtual
machine," or a virtual copy of a computer, inside your Mac. You can then install Windows in the
virtual machine, just as you would install an operating system on a regular computer.

Many use Parallels Desktop to create one virtual machine and install Windows in it. But you can
install as many virtual machines as you like, and install a different operating system in each of them.
That way you can use multiple operating systems together at the same time on your Mac. And just
like with a regular computer, you can turn virtual machines on and off, configure them, and install
and use programs.
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Default Configurations

A typical virtual machine has the following basic virtual hardware: CPU, memory, hard disk drive,
floppy disk drive, sound device, CD/DVD drive, network adapter, USB controller, serial port, printer
port connected to the printer set as the default in Mac OS.

Note: Apart from the basic hardware, you can add new devices to your virtual machine using the Virtual
Machine Configuration dialog (p. 170).

The amount of memory and the size of hard disks vary for different guest OSs. Refer to the table
below to learn the memory and hard disk values that are allocated to a virtual machine depending
on the guest operating system that will be installed in it. Virtual hard disks for typical virtual
machines are always created in the expanding format (p. 172).

Guest Operating systems m;mory, \I\ll:gﬁ'noory, g;rlg MB Ellfi)‘f’:y gDéE\); i gg::ir:l
MB ’ Adapter
Mac OS X 1024 32 64,000 i ! v
Windows 7 1024 256 64,000 i i ¥ ¥
Windows Server 2008 | 1024 128 64,000 | 1 ) ! &
Windows Vista 1024 256 64,000 v ! ! ¥
Windows XP 1024 256 64,000 v ! ! ¥
Windows 2003 1024 64 64,000 v w i v
Windows 2000 056 256 64,000 iy 7 ! ¥
Windows ME 056 32 8,000 v > 2 ¥
Windows NT 056 32 4,000 v ) i ¥
Windows 98 056 32 8,000 v i/ ! ¥
Windows 95 128 32 2,000 ! > ! v
Windows 3.11 64 32 2,000 i i @ v
Other Windows 1024 128 64,000 v ! ! ¥
Red Hat Enterprise Linux | 1024 32 64,000 e ! ! !
SUSE Linux Enterprise | 1024 32 64,000 (*2 (% ! v
Debian GNU/Linux 1024 32 64,000 1y r:ﬂ @ v
Ubuntu Linux 1024 32 64,000 | 1 ! i g
Fedora Linux 1024 32 64,000 L{j t;d t’ﬂ ';’ﬂ
CentOS Linux 1024 32 64,000 | 1 ) ! &
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OpenSUSE Linux 1024 32 64,000 v ! ! ¥
Mandriva Linux 1024 32 64,000 v i ¥ v
Other Linux kernel 2.6 | 1024 32 64,000 v i @ v
Other Linux kernel 2.4 1024 32 64,000 l;’j l:;ﬂ l.iﬂ ﬁﬂ
Other Linux 1024 32 64,000 | 1 ! ! ¥
FreeBSD 8.x 056 32 64,000 | iy ) i ¥
FreeBSD 7.x 056 32 64,000 | I i/ ¥ ¥
Other FreeBSD 056 32 64,000 | 1 /) ! ¥
0S/2 Warp 4.5 056 32 2,000 i i ! ¥
0S/2 Warp 4 128 32 2,000 i i ¥ v
eComStation 1.2 256 32 2,000 v ! ! ¥
Other 0S/2 128 32 2,000 i ! ! ¥
MS-DOS 6.22 64 32 2,000 g W ¥

Other DOS 32 32 2,000 e/ 7 i

Solaris 10 1024 32 64,000 ) !

OpenSolaris 256 32 64,000 i !

Other Solaris 1024 32 64,000 (%7 !

Other 256 32 8,000 v i @ v

Set Where New Virtual Machines Are Stored

By default, Parallels Desktop stores virtual machines in ~/Documents/Parallels.

To change the default location for new virtual machine installations:

1 Do one of the following:

« Click the Parallels icon Il in the menu bar and choose Preferences. Then click General.

= Right-click the Parallels Desktop icon in the Dock and choose Preferences. Then click
General.

2 Choose a location from the Virtual Machines Folder menu.

All newly created virtual machines are stored in the new location. Any existing virtual machines
remain in their original locations.
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Arrange Virtual Machines

If you have many virtual machines, the Control Center window may get overloaded and
inconvenient to work with.

You can configure Control Center to show the minimum information - only virtual machine names
and icons. To do so, click the Parallels Desktop icon in the Dock and choose View > Compact
View in the OS X menu bar.

Or if you're using Parallels Desktop for Mac Pro Edition, you can change how your virtual machines
are arranged. Click the Parallels Desktop icon in the Dock, click View > Arrange By and choose
how you want to list the virtual machines.

Make Virtual Machines Distinctive
Note: This functionality is available in Parallels Desktop for Mac Pro Edition only.

If you have two or more virtual machines running simultaneously, the icons of all applications
running in the virtual machines are usually present in the Dock. You can easily get confused to
which virtual machine the app icon belongs. To distinguish one virtual machine from others, you
can mark it with some color. Do one of the following:

= Right-click a virtual machine in Control Center and choose the color you want at the bottom of
the context menu.

= Right-click your virtual machine in OS X (virtual machines are usually stored in the
Documents/Parallels folder) and choose the color you want from the context menu.

If you choose, for example, red, the Dock icons of this virtual machine applications will be marked
with a red spot.

n @l

Change the Virtual Machine Icon
Note: This functionality is available in Parallels Desktop for Mac Pro Edition only.

If you have two or more virtual machines with the same guest operating system, their Dock icons
look the same and you may get confused. To change the virtual machine icon, do the following:

1 Copy a new icon you want to use to the clipboard (select the icon and press Command + C).

2 Right-click the virtual machine which icon you want to change (virtual machine are usually
stored in the Documents/Parallels folder) and click Get Info.
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3 Click the virtual machine icon in the top left corner and paste the new icon from the clipboard
by pressing Command + V. The icon will change in Finder and in the Dock.

To return the default icon, repeat step 2, click the virtual machine icon and press Backspace.

Change the Virtual Machine Name

The name of a virtual machine is displayed in Control Center and, at the top of the guest OS
window when you are running in Window mode.

To change the virtual machine name:
1 Do one of the following:

- Click the Parallels icon Il in the menu bar and choose Configure.

= |[f the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.

2 (Click General and type a new name in the Name field.

The length of the name is limited to 50 characters.

Clone a Virtual Machine

Clone a Virtual Machine

If you need an exact copy of a virtual machine, you can clone it. A clone is a separate virtual
machine fully identical to the original one. To make a clone:

Start Parallels Desktop.

2 In Control Center, select the virtual machine you want to clone (it must be shut down) and
choose File > Clone.

3 Choose where you want to store the clone.
By default, Parallels Desktop stores clones in your Documents > Parallels folder.

4 Click Save to start cloning the virtual machine.
Create a Linked Clone of a Virtual Machine
Note: This feature is available in Parallels Desktop for Mac Pro Edition only.

A linked clone is a virtual machine that shares virtual hard disks with the parent virtual machine. This
technology allows multiple virtual machines to use the software installed on the parent virtual
machine hard disk. This way, users can save space on the Mac's hard disk. To create a linked
clone:
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Start Parallels Desktop.

2 In Control Center, select the virtual machine you want to clone (it must be shut down) and
choose File > New Linked Clone.

3 Choose where you want to store the clone.
By default, Parallels Desktop stores clones in your Documents > Parallels folder.

4 C(Click Save to start cloning the virtual machine.

Back Up a Virtual Machine

Most people don't seriously consider regular backups as a necessity until they have experienced a
significant data loss. You should create your own backup strategy to protect yourself from data
loss. Virtual machines are as vulnerable to crashes as physical computers.

You can back up your virtual machine using one or several of the following methods:

= Configure the regular backup settings on the Backup tab of the Virtual Machine
Configuration dialog.

= Use third-party backup utilities like Acronis True Image (p. 128).

= Clone the virtual machine with the help of Clone Virtual Machine Assistant. Give a descriptive
name to the clone and save it in a location specially designated for backups.

= Copy the virtual machine files manually.

Configure Regular Backups

On the Backup tab of the Virtual Machine Configuration dialog, you can choose how to back up
your virtual machine regularly. You can configure how the virtual machine snapshots will be created
or choose to back up the virtual machine with Time Machine.

If you choose to back up your virtual machine with Time Machine, your virtual machine's PVM file
will be automatically backed up together with other files stored in Mac OS. As a consequence, files
stored on your virtual machine's hard disk will be also backed up, since the virtual hard disk file
(HDD) is stored inside the virtual machine bundle file (PVM).

Warning: Time Machine backups can guarantee safety only when your Parallels virtual machines
were stopped or suspended during the backup.

To restore some of your Windows files:

1 From within the Finder (and not within Time Machine), locate the backup copy of your virtual
machine's file (PVM) on your backup disk.

Right-click the file, and choose Show Package Contents.
In the virtual machine contents window, right-click the virtual hard disk file (HDD) that is usually
named <VirtualMachine”sName>_hdd. and choose Open With > Parallels Mounter.

117



Advanced Topics

4 Using Parallels Mounter, browse the contents of your virtual machine's hard disk to find the files
you need to restore.

Use Third-Party Backup Utilities

You can use any third-party backup utilities you like. Registered Parallels Desktop users can use
Acronis True Image (p. 128) to back up their Windows virtual machines.

Note: Acronis doesn't support backing up virtual machines that use Boot Camp as their hard disks.

Clone the Virtual Machine

You can create a complete clone of the virtual machine using Clone Virtual Machine Assistant. For
details, see Clone a Virtual Machine (p. 116).

Copying the Virtual Machine Files

You can locate your virtual machine in Finder and create a backup copy of the virtual machine file
(PVM).

1 In Control Center (or in the virtual machine window if it is shut down), right-click the virtual
machine name and select Show in Finder from the context menu. In Finder, go to the folder
where your virtual machine is stored.

2 Locate the required virtual machine PVM file.

Note: PVM file is a bundle that contains the virtual machine configuration file (PVS), virtual hard disk file
(HDD), and other files. For more information about the virtual machine files, see About Virtual Machines
(p. 112).

3 Copy the virtual machine's PVM file to a safe location.

Browse Virtual Hard Disks in Mac OS X

For easy access to Windows files, you can mount the virtual hard disk (on which Windows is
installed) in Mac OS X.

Mount a Virtual Hard Disk to the Mac OS X Desktop

If you need the virtual hard disk (on which Windows is installed) to be mounted to the Mac OS X
desktop when Windows is running, open Finder, choose Finder > Preferences > General and
select the Connected servers option.

For easy access to your virtual machines files, you can mount their hard disks in Mac OS X Finder
together with other disks and storage devices.
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If you want your virtual hard disks to be mounted to the Mac OS X desktop when the virtual
machine is running, perform the following actions:

1 Open the Sharing pane of the Virtual Machine Configuration dialog and enable the Mount
virtual disks to Mac desktop option.

Note: To be able to edit the settings in the Sharing pane, you must have Parallels Tools (p. 140)
installed in the virtual machine and the Isolate Mac from Windows option disabled in the Security
pane.

2 Open the Finder Preferences, click the General tab and select the Connected servers option
in the list of items displayed on the desktop.

If you want to manage the virtual machine content without starting the virtual machine, you can
mount the virtual hard disks manually using Parallels Mounter:

1 Browse the virtual machine files in Finder. For Parallels virtual machines, right-click the virtual
machine name in Control Center (or in the virtual machine window if it is shut down) and select
Show in Finder from the context menu.

The default paths for storing Parallels virtual machines are
/Users/<UserName>/Documents/Parallels/ and /Users/Shared.

2 To mount the hard disk of a particular virtual machine, right-click this virtual machine's file and
choose Open With > Parallels Mounter or Open With > Other > Library > Parallels >
Parallels Mounter from the shortcut menu. You can mount the following virtual machines and
hard disks:

= Parallels bundle (. pvm) or configuration file (- pvs) or virtual hard disk file (. hdd).
= VMware configuration file (- vmx, .vmwarevm) or virtual hard disk file (. vmdk).

= Virtual PC configuration file (-vme, .vpc7) or virtual hard disk file (. vhd).

= VirtualBox configuration file (.xml) or virtual hard disk file (. vdi).

If you choose the PVM file of a Parallels virtual machine or the configuration file of a third-party
virtual machine that has several virtual hard disks, all its volumes will appear as mounted in
Finder.

If you want to mount a single virtual hard disk, double-click the virtual hard disk file to mount it
with Parallels Mounter. The icon for the selected hard disk appears in the sidebar of the Finder
window, together with other Mac OS X icons.

3 To browse the contents of a volume, click its icon in the sidebar of the Finder window.

You can manage the virtual machine files just as you manage your Mac OS X files in Finder
windows.

Note: If you are browsing the contents of a suspended virtual machine in Finder, you cannot delete,
move, or otherwise modify its files.

4 To unmount the volume, use the Eject button next to the disk icon.
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Note: If a hard disk that has several volumes was mounted and you want to open it or the virtual
machine using it in Parallels Desktop, you should disconnect its volumes one by one by clicking the
Eject button.

Create and Use Virtual Machine Templates

On the basis of your virtual machines you can create templates. Later you can use them to create
multiple identical virtual machines. To create a virtual machine template, you can:

Note: Virtual machine templates are available in Parallels Desktop for Mac Pro Edition only.

e convert a virtual machine to a template; or

= clone a virtual machine to a template.

The difference between these two ways is that when you convert a virtual machine to a template,
you can't run it until you convert the template back to the virtual machine. And when you clone a
virtual machine to a template, the template appears separately from the virtual machine and you
can work with both.

A template, in its turn, can be converted or deployed back to the virtual machine. When you
convert a template, it turns back to the virtual machine. And when you deploy it, the resulting virtual
machine appears separately from the template and you can work with both.

Convert a Virtual Machine to a Template

To convert a virtual machine to a template:

1 Start Parallels Desktop.

2 In Control Center, select the virtual machine you want to convert (it must be shut down) and
choose File > Convert to Template.

Convert a Template to the Virtual Machine

To convert a template back to the virtual machine:

1 Start Parallels Desktop.

2 In Control Center, right-click the template you want to convert and choose Convert to Virtual
Machine.

Clone a Virtual machine to a Template

To clone a virtual machine to a template:

1 Start Parallels Desktop.

2 In Control Center, select the virtual machine you want to clone (it must be shut down) and
choose File > Clone to Template.
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3 Choose where you want to store the resulting template.
By default, Parallels Desktop stores templates in your Documents > Parallels folder.

4 Click Save to start cloning the virtual machine to the template.

Deploy a Template to the Virtual Machine

To deploy a template back to the virtual machine:

Start Parallels Desktop.

2 In Control Center, right-click the template you want to deploy and choose Deploy to Virtual
Machine.

3 Choose where you want to store the resulting virtual machine.
By default, Parallels Desktop stores virtual machines in your Documents > Parallels folder.

4 C(Click Save to start deploying the template to the virtual machine.

Save Snapshots of a Virtual Machine

A snapshot is a saved state of the guest OS. It's useful to create snapshots, for example, before:

= you're going to run some programs that may damage the guest OS; or
= if you're going to configure some guest OS software that requires a lot of settings; or

< if you want to mark milestones in the development process.
Notes: 1. Snapshots cannot be created for Windows virtual machines that use the Boot Camp partition.

2. If your virtual machine has one or more snapshots, you can neither compress nor resize the virtual
hard disk.

3. Creating a snapshot increases the size of the virtual machine .pvm bundle.

If something goes wrong, you can revert the changes back to any of your snapshots and continue
working with the guest OS.

Create a Snapshot

Start Parallels Desktop.
In Control Center, select the virtual machine for which you want to create a snapshot.

Click Actions > Manage Snapshots.
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Click New, specify the snapshot name and click OK.

Automate the Creation of Snapshots

The SmartGuard functionality allows you to automate snapshots creation.
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Note: SmartGuard is available only when the virtual machine is not running in Rollback Mode (p. 93).

To access settings for automating snapshots:

Start Parallels Desktop.

2 In Control Center, right-click the virtual machine for which you want to create a snapshot and
choose Configure.

3 Click Backup.

@ Windows 8.1 - Backup

= S @

General Oplbans Hordwide Security Backug

Time Machime: Do not back up virual maching

SmartGuard: [ Enabled Details...

You need o have at least 25.0 GB of free disk space to
use this featwre.

lj Chick the lock to prevent furthar changes.

To automate snapshots, enable SmartGuard, click Details, and do one of the following:

= Select Optimize for Time Machine. If you select this option, a snapshot will be taken every 48
hours. Time Machine, when backing up your Mac, will not back up the entire virtual machine,
but only its latest snapshot. This allows you to reduce the amount of data that Time Machine
backs up, to reduce the time Time Machine spends backing up the virtual hard disk(s), and to
minimize the risk of data loss or corruption when restoring the virtual machine hard disk(s) from
the Time Machine backup.

< Manually set the snapshots frequency and maximum number of snapshots to keep. If you want
to know when it is time to make the next snapshot and to be able to reject the snapshot
creation, select Notify me before snapshot creation.

To set how often snapshots are made:
= Use the Take a Snapshot Every field. You can set from one to 48 hours.

If the time interval is less than 24 hours, SmartGuard will allow you to restore the latest hourly, daily
and weekly snapshot. If the time interval is more than 24 hours, you will be able to restore the latest
daily, weekly and monthly snapshot.

To limit how many snapshots are stored:

= Use the Snapshots to Keep field to set the maximum number of snapshots that can be stored
on your Mac.

The maximum available value is 100 snapshots. As soon as Snapshots Manager reaches the limit
for snapshots and needs to make a new one over limit, it deletes the oldest snapshot.
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Revert to a Snapshot

To revert to a snapshot:

Start Parallels Desktop.
In Control Center, select the virtual machine that you want to revert.

Click Actions > Manage Snapshots.
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Select the snapshot to which you want to revert and click Go To.

Delete a Snapshot

To delete a snapshot:

Start Parallels Desktop.
In Control Center, select the virtual machine which snapshot you want to delete.

Click Actions > Manage Snapshots.
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Select the snapshot you want to delete and click Delete.

When you delete an intermediate snapshot, the information it contains is merged into the next
snapshot.

Change Virtual Machine Configuration at Runtime

Parallels Desktop allows you to connect or disconnect certain devices at runtime or switch some of
them for using other media.

Generally, the following virtual devices can be connected or disconnected at runtime:

= Floppy disk drive

= (CD/DVD-ROM drives
= Network adapter

= Sound device

= USB device

= Shared folders

If printer and serial ports are present in the virtual machine configuration, you can also manage
them at runtime.

To configure any of these devices, use the necessary command from the Devices menu in the
menu bar. This menu is available only when the virtual machine is running.
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Connecting a CD/DVD-ROM or a Floppy Drive
If you have several CD/DVD-ROM drives connected to your virtual machine, in the Devices menu

they are listed in the same order as they were connected. The first CD/DVD-ROM drive will be
CD/DVD-ROM 1, the second will be CD/DVD-ROM 2, and so on.

Connecting a Network Adapter

You can set up any of the three network modes: Shared Networking, Bridged Networking, or Host-
Only Networking.

Connecting a Sound Device

To connect or disconnect a sound device, choose the Activate or Mute options respectively. You
can also choose the type of output and input devices.

Connecting a USB Device
Parallels Desktop automatically detects all USB devices plugged into your Mac computer. The

devices that are currently connected to the virtual machine appear in the list from the Device menu.
You cannot use a USB device in Mac OS X while it is being used by the virtual machine.

Connecting a Shared Folder

The Shared Folders options available at runtime are similar to the settings in the Virtual Machine
Configuration dialog.

You can

= share all Mac disks or Home Folder only with the virtual machine
= share Windows guest operating system disks with Mac OS X

= add a new shared folder

Connecting a Serial Port

To connect or disconnect a serial port, click the Devices menu, select the corresponding serial
port, and choose the appropriate command in the displayed menu.

Connecting a Printer Port
To connect or disconnect a printer port or to connect a printer or an output file to a printer port,

click the Devices menu, select the corresponding printer port, and choose the appropriate
command in the displayed menu.
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Use Mouse Wheel Horizontal Scrolling

You can use the mouse wheel horizontal scrolling when working with windows of virtual machine
applications. This feature is available only if Parallels Tools (p. 199) are installed in the virtual
machine.

Remove a Virtual Machine

Remove a Virtual Machine from your Mac

If you don't need a virtual machine any more, you can permanently remove it from your Mac:

Warning: Before removing, check that none of the virtual machine files (e.g. virtual hard disk) are
used by other virtual machines. If you remove a Boot Camp virtual machine, the Boot Camp
partition with Windows installed remains available on your Mac.

1 Shut down the virtual machine if it is running, right-click in the virtual machine window and
choose Remove. You can also click File > Remove or right-click this virtual machine in the
Control Center and choose Remove.

2 Click Move to Trash.

Remove a Virtual Machine from Control Center

To temporarily remove a virtual machine from Control Center:

1 Shut down the virtual machine if it is running, right-click in the virtual machine window and
choose Remove. You can also click File > Remove or right-click this virtual machine in the
Control Center and choose Remove.

2 Click Keep Files.

When you need this virtual machine again, you can easily import it in Parallels Desktop (p. 30).

Download Pre-configured Virtual Appliances

If you don't have enough time to create a new virtual machine with the required configuration, you
can download a ready-to-use virtual machine with a predefined configuration.

Downloading Parallels Virtual Appliances

Parallels Virtual Appliances are pre-built Ubuntu, Fedora Linux, CentOS Linux, Debian GNU/Linux,
and Android virtual machines.

To download such an appliance and use it with Parallels Desktop:
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1 Choose File > New.
Select the appliance you need in the Free Systems section and click Continue.

In the next step, click Download. Once the download starts, you can pause it anytime by
clicking Pause. To resume the download, click Resume.

Once the download is complete, you can start working with the virtual appliance in Parallels
Desktop.

Downloading Chromium OS Virtual Appliance

To download the Chromium OS virtual appliance from Parallels Desktop:

1 Choose File > New.
2 Select Download Chromium OS and click Continue.

3 In the next step, click Download. Once the download starts, you can pause it anytime by
clicking Pause. To resume the download, click Resume.

Once the download is complete, you can start working with the Chromium OS virtual appliance in
Parallels Desktop.

Downloading Modern.IE Virtual Appliances

The Modern.|E virtual appliances allow web developers to check how websites are displayed and
functioning in different versions of Internet Explorer on different versions of Windows.

To download such an appliance and use it with Parallels Desktop:

Choose File > New.
2 Select Modern.IE and click Continue.

3 Inthe next step, select the version of Internet Explorer and Windows you'd like to work with and
follow the onscreen instructions.

Once the download is complete, you can start working with the virtual appliance in Parallels
Desktop.

Set the Guest OS Type and Version

You can change which guest OS a virtual machine is configured to work with. You need to change
it in the following cases:

= |f you upgrade the guest operating system (for example, from Windows XP to Windows 7), you
need to change the guest OS type and version correspondingly or Parallels Tools (p. 140) may
start working incorrectly.

= If you create a virtual machine without installing an operating system, and then decide to use it
with a different operating system than the one you initially specified.
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To set the guest OS type and version:

1 Shut down the virtual machine. (p. 36)
2 Open the Actions menu and choose Configure.

3 Click General and select an OS from the menu just above the Name field.

Set How Many Processors are Allocated to a Virtual Machine

You can change the number of virtual CPUs that will be used to handle the processes running in a
virtual machine. Parallels Desktop automatically calculates the maximum allowable number of virtual
CPU. The calculation is based on the number of physical CPUs available to your Mac OS X
computer.

Note: [t is reasonable to use more than one CPU in your guest OS if you are going to use applications
that perform better under multi-core processors.

To set how many processors are allocated to a virtual machine:

1 Shut down the virtual machine. (p. 36)
2 Open the Actions menu and choose Configure.

3 Click Hardware > CPU & Memory and select a number from the Processors menu.

Note: In Parallels Desktop for Mac, you can assign up to 4 CPUs to a virtual machine. In Parallels

Desktop for Mac Pro Edition, you can assign up to 16 CPUs.
Check Your Virtual Machine CPU and Memory Usage
While working with a virtual machine, you may need to check how much memory and CPU time of
your Mac it is currently using. If the virtual machine is consuming too much and your running Mac
applications become slow, you can easily reduce the number of CPUs (p. 127) and amount of

memory (p. 100) assigned to the virtual machine.

To check the current CPU and memory usage, choose Window > Show Resource Usage.

Enable Spoken Commands

You can work with Windows or other guest OSs using the following spoken commands:

Commands Description

Start Starts a virtual machine.
Suspend Suspends a virtual machine.
Shut Down Shuts down a virtual machine.
Pause Pauses a virtual machine.

127



Advanced Topics

Stop
Reset

Snapshot
Make Screenshot

Make Clip

Switch to Coherence
Switch to Full Screen
Switch to Window
Edit Configuration
New

Open
Download

About Parallels
Desktop

Install Parallels Tools
Report a Problem
Open

Open Directory

Stops a virtual machine.
Resets a virtual machine.
Opens the Snapshot Manager window.

Makes a screenshot of the Guest OS window and stores it on the Mac OS X
Desktop.

Makes a clip.

Switches to the Coherence view mode.

Switches to the Full Screen view mode.

Switches to the Window view mode.

Opens the Virtual Machine Configuration dialog.
Creates a new virtual machine.

Opens a virtual machine.

Allows you to download a virtual machine appliance available at
http://www.parallels.com/en/ptn/dir.

Opens the About Parallels Desktop menu.

Launches the installation of Parallels Tools in the running virtual machine.
Opens the Parallels Problem Report window.
Opens an existing virtual machine and registers it in Parallels Desktop.

Opens the Parallels Virtual Machines window.

To enable the spoken commands, choose Parallels Desktop > Preferences > Advanced and
select Enable spoken commands. If necessary, tune the speech settings on the corresponding
tab of Mac OS X System Preferences.

Get Acronis True Image

As an additional benefit, Parallels provides you with Acronis True Image. It is an online backup tool
for Windows and OS X. For Parallels Desktop users, Acronis True Image is free for 30 days.

For instructions on backing up your Mac and virtual machines, please refer to the Acronis True
Image documentation.

Install Acronis True Image

To install Acronis True Image, choose Parallels Desktop > Backup with Acronis True Image...
and follow the onscreen instructions.

Or you can also install Acronis True Image from the virtual machine configuration:

1 Do one of the following:

= Click the Parallels icon Il in the menu bar and choose Configure.
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= |If the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.

2 C(Click Backup > Install Acronis True Image and follow the onscreen instructions.

Start Acronis True Image

To start Acronis True Image:

1 Do one of the following:
= Click the Parallels icon Il in the menu bar and choose Configure.

= |f the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.

2 Click Backup > Start Acronis True Image and follow the onscreen instructions.

Use AppleScript with the Guest OS

You can use AppleScript to open various files and websites in the guest OS applications. You may
need this when creating automated workflows.

To make the explanation more vivid, let's assume that you need to open some .txt file in Windows
Notepad using AppleScript (in AppleScript Editor). The syntax of this command is as follows:

tell application "Notepad"
open "/Users/username/somefile.txt"
end tell

As an example of opening a website in the guest OS application, let's assume that you need to
open "www.parallels.com" in Internet Explorer. The syntax of this command is as follows:

tell application "Internet Explorer”
open "//www.parallels.com"
end tell

Quickly Free Up Disk Space

Using Free Disk Space Wizard, you can compress the virtual machine hard disk(s) and remove
various unnecessary files to free up disk space.

To quickly compress the disk(s), remove unnecessary files, and free up disk space:

Shut down the virtual machine.
2 Choose File > Free Up Disk Space.

Free Disk Space Wizard shows whether you can reclaim any disk space by removing the
virtual machine snapshots, cache files and various unnecessary files such as statistical, memory
dump, and crash dump files, which are generated during the virtual machine life cycle.

You can also conserve disk space by compressing virtual disks manually (p. 185) or clicking
Reclaim on the General tab of virtual machine configuration.
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Archive and Unarchive Virtual Machines

If you have two or more virtual machines, you may notice that there's not enough space on your
Mac. If you seldom use a virtual machine or don't use it at all, archive it to make the virtual machine
occupy significantly less disk space on the Mac's hard disk.

Archive a Virtual Machine

To archive a virtual machine, do the following:
1 Right-click the Parallels Desktop icon in the Dock and choose Control Center.

2 Right-click a virtual machine and select Archive.

Unarchive a Virtual Machine

Archived virtual machines cannot be started. To start an archived virtual machine, first you should
unarchive it. Do the following:

1 Right-click the Parallels Desktop icon in the Dock and choose Control Center.
2 Right-click an archived virtual machine and select Start.

3 In the dialog prompting to unarchive the virtual machine, click Unarchive.

Use Other Operating Systems on Your Mac

Read this section for the information that's specific to certain operating systems other than
Windows XP or later.

Import Linux and Your Data from a PC

You can import Linux and your data from a PC over a network or using an external storage device.
These procedures are identical to the same ways of importing Windows (p. 20).

You can import the following Linux operating systems:

OS Name 32-bit 64-bit Migration Method
Red Hat® Enterprise Linux 5 e 1! Network, External Storage
Ubuntu® Linux 8.04 ;y lij Network, External Storage

Supported File Systems

e [Ext2

e [Ext3
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e [Ext4

Use Linux in Coherence Mode

You can set Linux and Mac OS X to work seamlessly together, as if they were part of a single
operating system. In this mode, called Coherence mode, Linux programs appear on the Mac
desktop next to your Mac applications.
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To enable the Coherence view mode:

« Parallels Tools must be installed (p. 143).

= Disable Linux 3D effects. The way you can do this depends on your Linux distribution. For
example, in Fedora 14 click System > Preferences > Desktop Effects and select Standard.
To learn how to disable Linux 3D effects in other Linux OSs, refer to the operating system
documentation.

Switch to Coherence Mode

To switch from Window mode to Coherence mode, do one of the following:

e (Choose View > Enter Coherence.

e Press Control-Command-Return.

To switch from Full Screen mode to Coherence mode, do one of the following:
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= Press Control-Option (Alt), click the View menu and select Exit Full Screen. Then open the
View menu and select Enter Coherence.

= Move the pointer to the upper-left corner of the screen until the corner peels back and click
Exit Full Screen. Then choose View > Enter Coherence.

Exit Full Screen

Install Windows 98

All Windows 95 and some of Windows 98 installation packages include a bootable floppy (a startup
floppy disk). The floppy is used to perform disk partitioning and formatting by means of MS-DOS.
Since modern Macs have no floppy drives, you will need an external USB floppy drive or an image
of a bootable floppy disk. Such an image can be created using third-party tools.

If you have a bootable CD with Windows 98 installation, you can use it as is or create an ISO image
of it.

Below we describe how to install Windows 98, the case when you have a startup floppy image and
a CD with the installation files. The installation of Windows 95 is similar to that.

Prepare a Virtual Machine for Windows 95/98 Installation

1 Create a Windows 98 virtual machine using New Virtual Machine Assistant. Select the
Customize settings before installation option in the Name and Location window.

2 In the Virtual Machine Configuration dialog, click Hardware > Boot Order, and configure the
floppy disk to be the first boot device.

3 Below the Boot Order item, select Floppy Disk to open the virtual floppy disk drive settings. In
the Floppy Disk pane, do the following:

1. Make sure the Connected option is selected.
2. Specify the floppy disc image in the Source menu.

4 Click OK to save the virtual machine configuration.

Initial Partitioning and Formatting

1 Start the virtual machine. You will see the black screen and messages indicating the process of
booting to MS DOS.

2 When prompted, enter the following command:
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fdisk

Fdisk (MS-DOS utility) is used to partition hard disks and floppy disks.

The Fdisk options will be listed. Choose the operation to perform (the default choice is 1) and
press Return (Enter) to continue.

Fdisk prompts you to create a partition. Select the Create Primary DOS Partition option if
you are going to have only one partition or less than four, and enter:

Other choices are for the case when you want to create more than four partitions.

Then Fdisk prompts you to define the size of the primary partition. Press Return (Enter) if you
wish to create a partition of the maximum size available.

To define other size type N and press Return (Enter). You will be prompted to specify the size.
Fdisk creates the partition and then prompts you to restart the computer (virtual machine).

Reboot the virtual machine using the same image of the boot floppy disk. That is, press
Ctrl+Option (Ctrl+Alt) to release the keyboard input and then click the Shut Down button to
stop the virtual machine. Then click the Start button.

When the booting is complete, you should format the system drive C-:.

Enter the following command:

format c:

Confirm that you want to format the disk C: when prompted. Type y and press Return(Enter).

You may be prompted to choose how exactly to format your disk. Windows 95/98 supports
FAT16 and FAT32 file systems.

FAT16 partition cannot be greater than 2 GB. Larger disks can be formatted with FAT32. But
do not use larger disks if you are going to run legacy applications.

The program starts formatting the disk C:.

Format other disks too (if you created more than one primary partition or if you created a
custom virtual machine with more than one disk). Use E:, F: drive letters.

Enter a label for each disk (11 character string). The label is optional, you can press Return
(Enter) to skip this step.

10 Shut down the virtual machine.

Now you are ready to start the installation of the Windows 98 operating system.

General Steps of Windows 98 Installation

3

Start the virtual machine using the same bootable floppy image.

Insert the Windows 98 installation CD or connect an ISO image of the installation disc choosing
CD/DVD > Connect Image from the Devices menu.

If you created only one primary partition (disk C:), by default, your CD/DVD drive will have the
drive letter D:. Type the command:

D:\setup.exe
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11
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and press Return(Enter). The installation starts and the files are copied from the CD to the virtual
hard disk.

Follow the on-screen instructions of the Setup. Note that you can add or remove some options
later.

Read and accept the License Agreement. Enter the license key.
Confirm the default system directory or specify another one.
In the Setup options dialog choose the type of installation. Typical is recommended.

(only for Windows 98) If you are going to use networking, select the network card when
prompted.

Turn off the virtual machine.
Eject the installation CD or disconnect the ISO image.

Choose Configure from the Virtual Machine menu, go to Hardware > Boot Order, and select
the hard disk to be the first boot device. Click OK to save the configuration.

Restart the virtual machine. This time, it will boot from the hard disk.

Improve Graphics Performance in Windows NT/98/ME

If you have Windows NT, Windows 98, or Windows ME installed on your Mac, you can improve
graphics performance by installing a video driver.

To install a video driver in Windows 98 and Windows ME:

1
2
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10

11

Start Windows 98, or Windows ME.

When the guest OS boots up, in the Mac menu bar click Devices > CD/DVD > Connect
Image.

Click Applications, double-click Parallels Desktop > Contents > Resources > Tools, select
pri-tools-other. iso, and click Open.

In Windows, click Start > Settings > Control Panel > Display.

In the Display Properties dialog, go to the Settings tab and click the Advanced button.
On the Adapter tab, click Change. The wizard opens.

In the wizard, click Next.

Select Search for a better driver than the one your device is using now and click Next.

Select Specify a location option. Click Browse. Locate the \Drivers\Video\Win9x folder
on the CD-ROM drive and click OK.

Click Next in the Update Device Driver Wizard and then, when the driver is found, click Next
again.

Click Finish and then Close to close the Update Device Driver Wizard.
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12 Click Close to exit the Display Properties dialog box.

13 When you are prompted to restart the guest OS in the System Settings Change dialog box,

click Yes.

The new settings are applied once the virtual machine is restarted.

To install a video driver in Windows NT:

0o N o a »H

9

10
11
12

Start Windows NT.

When the guest OS boots up, in the Mac menu bar click Devices > CD/DVD > Connect
Image.

Click Applications, double-click Parallels Desktop > Contents > Resources > Tools, select
pri-tools-other. iso, and click Open.

In Windows, click Start > Settings > Control Panel > Display.

In the Display Properties dialog, go to the Settings tab and click the Display Type button.
In the Adapter Type section, click Change. The Change Display window opens.

In this window, click Have Disk.

Click Browse. Select the \Drivers\Video\Nt4 folder on the CD-ROM drive and click Open
twice.

In the Install From Disk window, click OK.
In the Change Display window, click OK.
Confirm that you want to install the video driver.

When you are prompted to restart the guest OS in the System Settings Change dialog box,
click Yes.

The new settings are applied once the virtual machine is restarted.

Customize the Keyboard for the Guest OS

By default, Parallels Desktop contains four profiles that represent sets of key combinations typical
for the following OSs:

Windows
Linux
Mac OS X

Generic (for other guest OSs)
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When you create or register a virtual machine, one of these profiles, depending on the guest
operating system, is assigned to the machine by default. You can create your own profile and

assign it to your virtual machines.

To create a custom keyboard profile or edit the existing profiles:

1 Do one of the following:

= Click the Parallels icon |l in the menu bar and choose Preferences.

= Right-click the Parallels Desktop icon in the Dock and choose Preferences.

2 Click Shortcuts.

& Shortcuts

0 B L P @

General Shortcuts Devices Security Metwork Advanced

m Application Shortcuts Profile: Windows

On FromOSX
0S X System Shortcuts

/X 3Space
~  $Space
]
J Mouse Shortcuts 38X
#®e
=" Keyboard Menu 4
A
VIRTUAL MACHIMES
%7
ﬂs
%P
&'g Windows XP o
8
@ Ubuntu Linux 1 !
|+ | = [#-

Toolbox Access

To Windows
Switch Language
Switch Language
Ctrl+X

Ctri+C

Ctrl+V

Ctri+A

Ctri+Z

Ctrl+5

Ctrl+P

Ctri+F

Ctrl+B

Ctri+l

E}ﬁ Click the lock to prevent further changes.

Restore Defaults
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3 Select a virtual machine from the sidebar, click the Profile menu, and select Edit profiles list.

Add or remove keyboard and mouse profiles.
— Reafile \icdous
Generic

Linux

Os X

Windows

Cancel OK--4

4 Do one of the following:

= To add a new profile, click the Add button | * | Specify the new profile name and select the
base profile from the list. After the profile is created, you can submit the changes by clicking
OK. Then select this new profile in the Profile list and configure its shortcuts.

= To remove one of the existing custom profiles, select it and click the Remove button

= To duplicate or rename one of the existing profiles, select this profile, click the button ¥,
and select the corresponding action from the menu.

Note: You can rename or remove your custom profiles only.

In the Shortcuts pane of Parallels Desktop Preferences, you can also assign profiles to your virtual
machines.

To change a profile assigned to a virtual machine:

= Select a virtual machine and choose a profile from the Profile menu.

Emulate a Mouse Right-Click or Middle-Click

To emulate a mouse right-click or middle-click:

Select Mouse Shortcuts in the sidebar.
Select Secondary click (for right-click) or Middle click.

Click in the corresponding text field and press the key or combination of keys that you want to
use with a mouse click to trigger a right-click or middle-click.
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You can use any combination of the Control, Option (Alt), Shift, and Command keys to specify the
key combination that will be used to emulate a mouse right-click or middle-click in the virtual
machine.

Use OS X as a Guest OS

If you are using OS X Lion or Mountain Lion, you can install a copy of OS X in a virtual machine and
use it as a guest operating system. This can be useful, for example, if you want to test software in a
fresh version of OS X without having to log in and out of your main account.

By default, an installation of OS X is stored in a recovery partition on your Mac You can easily install
OS X into a virtual machine from that partition without having to purchase or download another
copy of OS X.

To install OS X in a virtual machine:

1 Open Parallels Desktop and choose File > New.

2 Select Install OS X Using the Recovery Partition, click Continue, and follow the onscreen
instructions.

When using Lion or Mountain Lion as a guest OS, you can use it in Coherence mode (p. 41), so
that guest OS application windows appear on the host OS desktop alongside host OS applications.

You can also copy and paste text and drag and drop files between host and guest Mac OS X, just
as you can when using Windows as a guest OS.

You can set whether function keys and other system shortcuts trigger actions in the host or guest
version of OS X (p. 70).
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Use OS X in Coherence Mode

You can set an OS X virtual machine and OS X to work seamlessly together, as if they were part
a single operating system. In this mode, called Coherence mode, guest OS X applications appe
on the host OS X desktop next to your host applications.

@ Finder File FEdit View Go Window Help D 4 = 4) E (= 18:10 Parallels Q
@ TextEdit File Edit Format Window Help D 4 (= Mon6:10PM Q

Untitled
(hohetice = (Boa = ][ [ W) (B o) B === (ioz)==] @

¥ > 13 > > > > >

To T T3 T3 Ta T Te T7

This is the guest OS X app‘xlicatibn.\'

This is the host OS X application. I

To enable the Coherence view mode, Parallels Tools must be installed (p. 148).

Switch to Coherence Mode
To switch from Window mode to Coherence mode, do one of the following:

e (lick the Coherence icon . in the top right corner of the virtual machine window.

e (Choose View > Enter Coherence.

= Press Control-Command-C.
To switch from Full Screen mode to Coherence mode, do one of the following:

= Press Control-Command-F to exit Full Screen. Then open the View menu and select Enter
Coherence.

of
ar

139



Advanced Topics

Install or Update Parallels Tools

Parallels Tools are a suite of behind-the-scenes tools that allow seamless operating between Mac
OS X and Windows or another guest operating system.

This section gives an overview of Parallels Tools, and has information about how to install them for
various guest operating systems.

Parallels Tools Overview

Parallels Tools are a suite of special utilities that help you use your virtual machines in the most
comfortable and efficient way. With Parallels Tools, you can move the mouse seamlessly between
the virtual machine and your Mac, change the virtual machine's screen resolution by simply resizing
its window, synchronize your virtual machine's time and date settings with the time settings of the
host computer, share your Mac's disks and folders with its virtual machines, copy text and drag
and drop objects from Mac OS to a virtual machine and vice versa.

Parallels Tools are available for the most popular Windows, Linux, and Mac OS X operating
systems, and include the utilities listed below. All utilities supported by your guest OS are installed
in your virtual machine as a single package when you install Parallels Tools.

Utility Available for Description

Windows Mouse Synchronization Tool captures the mouse input
in the virtual machine each time the pointer moves over
its window and automatically releases the input when
Mac OS X the pointer moves outside the window.

Mouse Synchronization Tool | Linux

Time Synchronization Tool enables you to customize
your virtual machine time settings. You can:

Windows = Automatically synchronize the time settings of
Time Synchronization Tool Linux your virtual machine with your Mac time
Mac OS X settings.

e Set up and maintain the time difference
between your Mac and your virtual machine.

Drag-and-Drop Tool allows dragging and dropping files

Drag-and-Drop Tool Windows between your virtual machines and Mac OS.
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Clipboard Synchronization
Tool

Dynamic Resolution Tool

Shared Folders Tool

Coherence Tool

Shared Profile Tool

Shared Applications Tool

Shared Internet Applications
Tool

SmartMount

Printing Tool

Tray Integration Tool

Windows

Linux

Windows
Linux
Mac OS X
Windows
Linux
Mac OS X

Windows

Linux

Windows

Windows

Windows

Windows
Linux
Mac OS X

Windows

Windows

Clipboard Synchronization Tool enables you to easily
exchange texts between:

= the virtual machine and your Mac.

= different virtual machines irrespective of the
guest operating systems installed in them.

To copy and paste text, you should use the standard
procedure for the current operating system. For
example, to copy some text in the Windows guest OS,
select the text, and press Ctrl+C. To paste this text in
Mac OS X, press Cmd+V, or select Paste from the
shortcut menu.

Dynamic Resolution Tool enables you to work with
dynamic resolution. When you resize the guest OS
window by dragging its lower right corner, the guest OS
window resolution changes automatically.

Shared Folders Tool enables you to share Mac folders
with the virtual machine and vice versa. With this tool,
you can access your Mac folders from the virtual
machine and virtual machine folders from Mac OS X.

The Coherence tool allows you to work with your
Windows or Linux applications like if they were Mac
applications. It hides the virtual machine's window
leaving only guest OS and Mac applications visible.

Shared Profile Tool enables you to share your Mac
desktop, pictures, documents, downloads, music and
videos with your virtual machine, which allows you to
access them right from Windows.

Shared Applications Tool enables you to specify default
applications for certain types of files, so that you can
open some types of files in Windows applications by
default, and others - in Mac OS.

Shared Internet Applications Tool enables you to specify
default Internet browsers, including those installed in the
virtual machine, for different types of Internet pages. For
example, you may set the Internet pages to open in your
default Mac OS X Internet browser, and FTP pages to
open in your virtual machine Internet browser.

SmartMount automatically detects volumes connected
to your Mac and makes them available to the virtual
machine as well.

Printing Tool allows you to synchronize the host and
guest OS printers.

Tray Integration Tool allows you to use Windows tray
icons in the Mac menu bar.
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Parallels Tools are located on disc images that are installed together with Parallels Desktop. There
is a separate Parallels Tools disc image for each type of the supported guest operating systems.

e pril-tools-win. iso - disc image with Parallels Tools for Windows guest operating systems.
e prl-tools-lin.iso - disc image with Parallels Tools for Linux guest operating systems.

e pril-tools-mac. iso - disc image with Parallels Tools for Mac OS X guest operating
systems.

These disc images can be found in the following location on your Mac:
<username>/Applications/Parallels Desktop/Contents/Resources/Tools.

Parallels Tools for Windows

Important: To take advantage of much of the functionality Parallels Desktop offers, Parallels Tools must
be installed.

Parallels Tools can be installed in the following Windows guest operating systems:
= Windows 8

= Windows 7

= Windows Server 2008

= Windows Vista

= Windows XP

e Windows Server 2003
« Windows 2000

Installing Parallels Tools

If you chose Express Installation when you first installed Windows, Parallels Tools were installed
automatically after the installation.

If you didn't choose Express Installation, do the following to install Parallels Tools:
1 Start Windows (p. 31).
2 When Windows boots up, choose Install Parallels Tools from the Virtual Machine menu.

Note: After you choose Install Parallels Tools in Windows 7 and Windows Vista, User Access Control
(UAC) may ask you whether to allow or deny the Parallels Tools installation. In this case, you need to
allow the installation.

3 Click Continue to connect the ISO image with Parallels Tools for Windows to the virtual
machine's CD/DVD-ROM drive.

4 Click Install Parallels Tools to start the installation.
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Note: After you click Install Parallels Tools in Windows 7 and Windows Vista, User Access Control
(UAC) may ask you whether to allow or deny the Parallels Tools installation. In this case, you need to
allow the installation.

5 When the installation is complete, click Restart to restart the virtual machine or wait for about 2
minutes and it will be restarted automatically.

If the Parallels Tools ISO image doesn't autoplay after you click Continue, the CD/DVD autorun
must be disabled in your virtual machine. In this case, do the following to install Parallels Tools:

Open My Computer, right-click the Parallels Tools disc and choose Open.
Double-click the PTAgent file to start the installation.

When the installation is complete, click Restart to restart the virtual machine or wait for about 2
minutes and it will be restarted automatically.

To edit the settings of Parallels Tools installed in your virtual machine, use the Options tab in the
Virtual Machine Configuration dialog.

Reinstall or Update Parallels Tools

To reinstall Parallels Tools:

1 Start Windows (p. 31).

Once Windows starts, if Parallels Desktop is in Coherence mode, click the Parallels icon Ilin
the menu bar and choose Exit Coherence.

2 When Windows boots up, choose Reinstall Parallels Tools from the Virtual Machine menu.

This option is available only if Parallels Tools are up-to-date. If Parallels Tools are outdated, you
will see the Update Parallels Tools option instead.

Check Whether Parallels Tools Have Been Installed

You can easily confirm whether Parallels Tools were installed. Start your virtual machine and look at
the status bar of its window. If the tip "Press Ctrl + Alt to release the mouse and keyboard" appears
in the status bar of the virtual machine's window, this means that Parallels Tools were not installed.
When Parallels Tools are installed, you do not need to press any key to release the mouse and
keyboard - they are released automatically.

Parallels Tools for Linux

Parallels Tools can be installed in Linux guest operating systems that comply with the following
requirements:

e (libc 2.3.4 and later
e libstdc++ 3.4.6 and later (libstdc++.50.6)

e gcc 3.4.6 and later (including C++ support)
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make 3.80

X Window System X11R6.7, X11R6.8, X11R6.8.99, X11R7.0, X11R7.1, X11R7.2 (1.3),
X11R7.3 (1.4)

kernel sources or development package

Note: Some of Parallels Tools, like Shared Folders Tool and Time Synchronization Tool, may also work in
the Linux operating systems that do not comply with the requirements listed above.

Preparing for installation

Before installing Parallels Tools in a Linux virtual machine, perform the following actions:

Close all applications running on the virtual machine.
If you use a 3D accelerated window manager, disable it.

Make sure that you have the gcc package and kernel sources installed. If these packages are
not installed, the Parallels Tools installer will inform you about this. The kernel sources package
name depends on the type of Linux operating system you use: it can be kernel-devel, or
kernel-headers, or something else. For more information about the kernel sources, refer to
Installing the GCC package and Kernel Sources in Linux (p. 209).

Note: To install Parallels Tools in your virtual machine, you must have the root privileges.

Installing Parallels Tools in the most recent versions of Linux systems

If you have one of the most recent versions of Linux OSs (Ubuntu, Fedora) in your virtual machine,
the pri-tools-l1in.iso image file will be mounted automatically after you connect it to the
CD/DVD drive. To install Parallels Tools, do the following:

3

Su

4
cd

Start the virtual machine.

When the operating system boots up, click Actions and choose Install Parallels Tools.

Note: If the Install Parallels Tools option is grayed out, make sure that your operating system
complies with the requirements listed above.

The pri-tools-l1in. iso image file will be mounted to the virtual machine's CD/DVD drive.

You can connect and mount the Parallels Tools ISO image file manually. In the Mac menu bar,
click Devices > CD/DVD > Connect Image. In the Finder window, go to the hard disk folder
(normally named "Macintosh HD"), select the /Library/Parallels/Tools/ folder, select
the pri-tools-lin.1so file, and click Open to connect it to the virtual machine.

Start a terminal in your Linux guest OS. Type the following command to gain the root
privileges:

Change the directory to the CD/DVD drive directory using
/media/cdrom/
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Note: In some of the Linux operating systems, the mount point for the virtual CD/DVD drive may appear
as /media/Parallels\ Tools/.

5 Inthe CD/DVD drive directory, enter the following command to launch Parallels Tools
installation:
-/install

6 Follow the Parallels Tools Installer instructions to complete the installation.

7 When the installation of Parallels Tools is complete, restart your virtual machine.

Installing Parallels Tools in other versions of Linux guest OSs

To install Parallels Tools in the older versions of Linux OSs, you have to mount the pri1-tools-
lin. iso image file manually. Do the following:

1 Start the virtual machine.

2 When the guest OS boots up, choose Install Parallels Tools from the Actions menu.

Note: If the Install Parallels Tools option is grayed out, make sure that your operating system
complies with the requirements for Parallels Tools installation.

The pril-tools-lin. iso image file will be connected to the virtual machine's CD/DVD drive.

3 Start a terminal in your Linux guest OS. Type the following command to gain the root
privileges:
Su

4 Check if the Parallels Tools CD image is mounted by entering
mount | grep 1s09660

If this command does not return anything, proceed to the next step.

If this command returns anything like
/dev/cdrom on /media/cdrom type 1s09660 (ro,exec,nosuid,nodev,uid=0),

skip the next step and proceed to the following one.

If this command returns anything like
/dev/cdrom on /media/cdrom type 1s09660 (ro,noexec,nosuid,nodev,uid=0)

with the noexec option present in parentheses, you need to unmount the disc using the
following command and then proceed to the next step:
umount /dev/cdrom

5 To mount the Parallels Tools installation disc image, enter the following:
mount -o exec /dev/cdrom /media/cdrom

Note: /dev/cdrom is the virtual machine's CD/DVD drive and /media/cdrom is the mount point for
this device. In some of the Linux operating systems the virtual CD/DVD drive may appear as /dev/hdb
and the mount point /mnt/cdrom. Some Linux OSs do not have the CD/DVD drive mount point. In this
case, you should create the mount point directory manually.

6 When the installation disc image is mounted, change the directory to the CD/DVD drive
directory using
cd /media/Zcdrom/
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7 Inthe CD/DVD drive directory, enter the following to launch Parallels Tools installation:
-/install

Note: You must have the root privileges to run this command.

8 Follow the Parallels Tools Installer instructions to complete the installation.
9 When the installation of Parallels Tools is complete, restart your virtual machine.

Note: If X Server fails to start in your virtual machine, you can install Parallels Tools manually in text
mode.

To edit the settings of Parallels Tools installed in your virtual machine, use the Options tab in the
Virtual Machine Configuration dialog.

How to check if Parallels Tools have been installed

You can easily confirm whether Parallels Tools were installed. Start your virtual machine and look at
the status bar of its window. If the tip "Press Ctrl + Alt to release the mouse and
keyboard" appears in the status bar of the virtual machine's window, this means that Parallels
Tools were not installed. When Parallels Tools are installed, you do not need to press any key to
release the mouse and keyboard - they are released automatically.

Troubleshooting

Parallels Tools installer can be blocked by SELinux. To solve this problem:

1 Start a terminal and determine your version of kernel by entering

uname -r
2.6.18-8.el5

2.6.18-8.¢el5 is the version of your kernel.

2 Openthe /boot/grub/grub.conf file or /boot/grub/menu. Ist (depends on the
version of your Linux operating system) and find the entry that corresponds to your version of
kernel.

title Red Hat Enterprise Linux Server (2.6.18-8.el5)
root (hd0,0)
kernel /vmlinuz-2.6.18-8.el5 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd /initrd-2.6.18-8.el5.img

3 Type the following text at the end of the entry:
sel inux=0

and the whole entry will be:
kernel /vmlinuz-2.6.18-8.el5 ro root=/dev/VolGroup00/LogVol00 rhgb quiet selinux=0

4 Save the file and restart the virtual machine.

After the restart, mount the Parallels Tools disc image and try to install Parallels Tools.
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Update Parallels Tools

If a newer version of Parallels Tools for Linux is available, the Parallels Tools Installation Agent
window appears. You're prompted to choose the command to gain root privileges and enter the
password (if su - root password, if sudo - your user's password). After that, Parallels Tools update
automatically.

Reinstall Parallels Tools

To reinstall Parallels Tools in Linux, first remove Parallels Tools and then install them once again.

Installing and Upgrading Parallels Tools in Text Mode in Linux

After upgrading to Parallels Desktop, the X Server may fail to start in Linux virtual machines. To fix
the problem, you need to install Parallels Tools in text mode.

Start the virtual machine.

2 When you see a message that X Server failed to start, switch to another virtual console using
Ctrl+Option+F1 (Ctrl+Alt+F1) and enter your login details.

3 Choose Install Parallels Tools from the Actions menu to connect the Parallels Tools ISO
image to your virtual machine.

Note: If the Install Parallels Tools option is grayed out, make sure that Parallels Tools can be installed
in your guest operating system. To see the list of guest OSs supported by Parallels Tools, refer to the
Parallels Tools Overview section in Parallels Desktop User's Guide.

The pril-tools-lin. iso image file will be connected to the virtual machine's CD/DVD drive.

4 |n the virtual machine console, type the following command to gain the root privileges:
Su

5 Check if the Parallels Tools CD image is mounted by entering
mount | grep 1s09660

If this command does not return anything, proceed to the next step.
If this command returns anything like
/dev/cdrom on /media/cdrom type 1s09660 (ro,exec,nosuid,nodev,uid=0),
skip the next step and proceed to the following one.
If this command returns anything like
/dev/cdrom on /media/cdrom type 1s09660 (ro,noexec,nosuid,nodev,uid=0)

with the noexec option present in parentheses, you need to unmount the disc using the
following command and then proceed to the next step:
umount /dev/cdrom

6 To mount the Parallels Tools installation disc image, enter the following:
mount -o exec /dev/cdrom /media/cdrom
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Note: /dev/cdrom is the virtual machine's CD/DVD drive and /media/cdrom is the mount point for
this device. In some of the Linux operating systems the virtual CD/DVD drive may appear as /dev/hdb
and the mount point /mnt/cdrom. Some Linux OSs do not have the CD/DVD drive mount point. In this
case, you should create the mount point directory manually.

7 When the installation disc image is mounted, change the directory to the CD/DVD drive
directory using
cd /media/Zcdrom/

8 Inthe CD/DVD drive directory, enter the following to launch Parallels Tools installation:
-/Zinstall

Note: You must have the root privileges to run this command.

9 Follow the Parallels Tools Installer instructions to complete the installation.

10 When the installation of Parallels Tools is complete, restart your virtual machine.

For general information on installing Parallels Tools in Linux, refer to Installing Parallels Tools in a
Linux Guest OS.

Parallels Tools for Mac

Install Parallels Tools

To install Parallels Tools in an OS X virtual machine:

1 Start the OS X virtual machine.

2 When OS X boots up, choose Actions > Install Parallels Tools and follow the onscreen
instructions.

Reinstall Parallels Tools

To reinstall Parallels Tools:

1 Start your OS X virtual machine (p. 31).

2 When Windows boots up, choose Reinstall Parallels Tools from the Virtual Machine menu.

Update Parallels Tools

If a newer version of Parallels Tools for Mac is available, Parallels Tools update automatically.
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Check Whether Parallels Tools Have Been Installed

You can easily confirm whether Parallels Tools were installed. Start your virtual machine and look at
the status bar of its window. If the tip "Press Ctrl + Alt to release the mouse and keyboard" appears
in the status bar of the virtual machine's window, this means that Parallels Tools were not installed.
When Parallels Tools are installed, you do not need to press any key to release the mouse and
keyboard. They are released automatically.

Install Sound Driver in OS/2 and eComStation

Sound driver for OS/2 and eComStation can be installed from the pril-tools-other.iso CD
image. Before starting the installation, connect the CD image with Parallels Tools to your virtual
machine's CD/DVD drive. Choose Install Parallels Tools from the Actions menu.

Before installing Sound Driver, make sure you have the multimedia support installed in the guest
operating system.

To install Sound Driver:

Click the System Setup icon on the system panel.
Select Install/Remove line and then select Multimedia Application Install.

In the IBM Multimedia Presentation Manager/2 - Installation window choose the CD/DVD
drive, then the <CD-ROM drive>\Drivers\Sound\0S2 directory. Select the ALC Codec
feature and click the Install button.

4 Restart the guest operating system.

For Software Developers

This section contains the topics with the information for software developers.

Optimize Remote Debugging

The Parallels plugin for Visual Studio allows you to develop software in one virtual machine and test
it in other virtual machines with just one click.

Note: This feature is available in Parallels Desktop for Mac Pro Edition only.

Requirements

To use this plugin, you need the following:
149



Advanced Topics

= A Windows 7 (or later) virtual machine with Visual Studio Professional/Enterprise 2013 (or later).
= (Other running virtual machines (with Windows 7 or later) in which you will test the project.

= The virtual machine with Visual Studio and other virtual machines must belong to the same pool
of IP addresses, or just configured to use the shared network (p. 162).

= All virtual machines must have Parallels Tools (p. 140) installed.

« The virtual machine with Visual Studio must have the Access Windows folders from Mac
option (p. 52) selected.

= Other virtual machines must have the Share Folders: All disks option (p. 52) selected.

= The user accounts logged in to the virtual machines in which you're going to test your project
must have both username and password and you must know them.

Install the Parallels Plugin for Visual Studio

To install the Parallels plugin, do the following:

1 In the virtual machine with Visual Studio, navigate to the directory where Parallels Tools are
installed. In most cases, itis C:\Program Files (x86)\Parallels\Parallels
Tools\DevTools.

2 Double-click the VMDebugHelper.vsix file. The plugin for Visual Studio will be installed
automatically.

How It's Working

To start remote debugging of your project, follow these steps:

1 In the virtual machine where Visual Studio is installed, open Visual Studio and open your
project.
Build the project and test it locally.

Click PARALLELS > Start Debugging in VM and select the virtual machine you need (this
virtual machine must be running).

PARALLELS | TEST  ANALYZE  WINDOW  HELP

Start Debugging in VM » Windows 8.1 1

You project will open in the selected virtual machine.

Run Windows Phone Emulator

Parallels Desktop allows you to develop and test software for Windows Phone on your Mac. You
need the following:

< A Mac computer with at least 4 GB of memory (more is better)
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To find out how much memory your Mac has, click the Apple menu and choose About This
Mac.

The latest version of Parallels Desktop 12 for Mac installed.

To check whether an update is available, open Parallels Desktop and click Parallels Desktop >
Check for Updates. If an update is available, install it.

A Windows 8 Professional (64-bit) or Windows Server 2012 (64-bit) virtual machine with 1 CPU
and 2 GB of memory (4 GB recommended if your Mac has 8 GB).

Note: Windows with 2 CPUs or more may perform unstably. Parallels is currently working to fix this
issue.

To learn how to install Windows on your Mac, see Install Windows from an Installation Disc

(p. 18). To learn how to set Windows to use 1 CPU and 2 GB of memory, see Set How Much

Memory is Allocated to Windows (p. 100) and Set How Many Processors are Allocated to
a Virtual Machine (p. 127).

Configure Windows to Run Windows Phone Emulator

Once your system meets the above requirements, do the following to configure Windows to run
Windows Phone emulator:

Select Enable next to Nested Virtualization in the Optimization pane (p. 100) to enable
Hyper-V support in Windows.

Note: Enabling Hyper-V support may slightly slow down your Windows performance. If you don't use
Hyper-V anymore, it is recommended to disable this option.

2 Start Windows and make sure you have Windows Phone SDK installed. If necessary, you can

download the SDK here.
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3 Open Visual Studio for Windows Phone, create a new project, and start Windows Phone
emulator. In this step, you may get the following error:
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Show output from:  Build - ==

rrrrrr Deploy started: Project: Phonedppl, Configuration: Debug Any CPU =====-= -
Deploying c:\wsers\alevidocuments\visual studio 2012\Projects\Phonesppl\Phonedppl\Bin\DebugiFho
Connecting to Emulator WVGA 512MEB...

4 If so, close Visual Studio and start Hyper-V Manager.
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5 Select the virtual machine you're going to use to develop or test software for Windows Phone
(the default virtual machine is Emulator WVGA 512MB), open the virtual machine configuration
settings, and change the number of processors from 2 to 1.

Hyper-¥ Manager e

Emulator WhA ST12ME.alev >
|* Hardwara | B Evocamor -
= Add Hardware
* pios ou can modfy the: number of virtual processors based on the number of processors
Bt fro on the physical compuber. You can also modify cther nescurce control seftings.
-y
Marmiber of virtssl processons:
Resource control
= [N Controler O | Youcan use rescurce controls to balance rescurces among viriual machines.
* Hard Drive WVistual machine reserve (percentage): o
™ bnE Conirolier 1 Peroent of total system resouross: o
. I.'\'r.r.k:.w: PhnneEml.dn‘nr Jnu:mu 1:1. | ik | i 100
« | Wirdows Phone Emulator Exterral Bet.., Percent of total system resounces: 00

Note: If you didn't set Windows to use 1 CPU as recommended above, do not change the number of
processors in the Hyper-V virtual machine.

6 After these steps, you can open Visual Studio and start creating or testing Windows Phone
applications.
ML} ‘Wirdows & with phan - Faraliels Ceskaop .
B Phanedng Munnng)  Wizeosaft Visusl Saadio Expres 3 e Windorwes Phor P om &
B e s e fecen o e . .

ki Wi

B EEN oG o)

Generate a Core Dump

Note: This functionality is available in Parallels Desktop for Mac Pro Edition only.
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If you need to generate the virtual machine memory dump, you can do this from Parallels Desktop.
When the virtual machine is running, click the Develop menu (p. 160) in the OS X menu bar and
choose Generate Core Dump. For more details on where the dump is stored and how to convert
it to the Linux, Windows or OS X format, please refer to the pricore2dmp topic of the Parallels
Desktop Pro Edition Command-Line Reference Guide available online.

Start a Debugging Session
Note: This functionality is available in Parallels Desktop for Mac Pro Edition only.

You can start a debugging session directly from Parallels Desktop. When the virtual machine is
running, click the Develop menu (p. 160) in the OS X menu bar and choose Start Debugging
Session.

Integration With Chef/Ohai

Note: This functionality is available in Parallels Desktop for Mac Pro Edition only.

If you're using Chef to provision your Parallels virtual machines or host systems running Parallels
Desktop, you can check in the recipe that the type of system virtualization being used is
virtualization from Parallels. To do this, use the node]'virtualization'] attribute. This attribute is set
by Ohai during the chef-client run.

Note: The Ohai version must be 8.6.0 or later.

You will see the following in the host system:

“virtualization: {
"systems': {

"parallels": "host"
1
"system': "parallels",
"role™: "host™

And the following in the guest system:

“virtualization: {
"systems': {

"parallels": "guest"
1,
"system': "parallels",
"role™: "guest”

}

Integration With Docker

Note: This functionality is available in Parallels Desktop for Mac Pro Edition only.
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Parallels Desktop allows you to run and manage Docker containers as if they were running directly
on your Mac. You just need a Linux-based virtual machine (Boot2Docker) that will host your
containers.

For more details, please refer to the Docker Machine official documentation:
https://docs.docker.com/machine/

Note: \When this topic was being written, Docker Machine didn't fully support Parallels Desktop. While
we're still working and improving this feature, you can use our custom-built executable file available here.

Use Virtual Machine Names as DNS Names
Note: This functionality is available in Parallels Desktop for Mac Pro Edition only.

When you start a virtual machine operating in the shared (p. 162) or host-only (p. 166) networking
mode and it gets an IP address via DHCP, the virtual machine gets registered in the OS X etc/hosts
file and you can use its name to connect from the host operating system or other virtual machine
operating in the shared (p. 162) or host-only (p. 166) networking mode.

For example, after starting such a virtual machine, your etc/hosts file may look as follows:
10.211.55.3 windows-8.1.shared windows-8.1 #prl_hostonly shared

You can use the virtual machine name (windows-8. 7.shared) to connect to this virtual machine. For
example, if you execute the following command in the OS X Terminal:

ping windows-8.1.shared

you will start pinging 10.211.55.3.

When such a virtual machine is shut down, its registration entry is removed from the etc/hosts file.

Resolve Guest OS DNS Requests Using etc/hosts
Note: This functionality is available in Parallels Desktop for Mac Pro Edition only.

When a virtual machine operating in the shared networking mode (p. 162) sends a DNS request,
the request is now resolved also using the OS X etc/hosts file.

For example, if your OS X etc/hosts file contains the following entry:
1.2.3.5 testh

and you start pinging testh in a virtual machine, the guest OS will check the OS X etc/hosts file first
and start pinging 1.2.3.5.
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Other Actions

Using Parallels Desktop, you can also:

= Optimize your virtual machine for software development (p. 104);
= Simulate various Internet connectivity speeds (p. 189);

= Download pre-configured virtual appliances (p. 125);

e Enable nested virtualization support (p. 176); and

= Enable PMU virtualization support (p. 176).

Set File Type Associations

When working with Parallels Desktop, you may need to open an OS X file in some Windows
application or a Windows file in some OS X app. If you often need to do so, SmartSelect allows you
to make your OS X files always open in Windows applications as well as make your Windows files
always open in OS X apps.

Note: This functionality is available only for Windows XP and later versions with Parallels Tools installed
(p. 140).

Associate OS X files with a Windows application

To make some type of OS X files always open in a Windows application, do the following:

Right-click an OS X file, point to Open with and click Other.

2 Navigate to Macintosh HD > Users > <user name> > Applications (Parallels) and open the
required virtual machine folder.

3 Select a Windows application you want and click Open.

4 Parallels Desktop shows an OS X notification asking whether you want to make the application
default for this type of files. Click Make. Now all files of this type will open in the selected
Windows application.

You can also make some type of OS X files always open in a Windows application the following
way:

1 Right-click an OS X file and choose Get Info.
In the Open with section, click the Open with menu and choose Other.

Navigate to Macintosh HD > Users > <user name> > Applications (Parallels) and open the
required virtual machine folder.

4 Select a Windows application you want, choose Always Open With and click Add.
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5 Click Change All and close the file info menu. Now all files of this type will open in the selected
Windows application.

Associate Windows files with an OS X application
For Windows 10:

To make some type of Windows files always open in an OS X application, do the following:

Right-click a Windows file and choose Open with > Choose another app.

2 Select the OS X application you want to use with that type of file and make sure Always use
this app to open <file_extension> files is selected. Now all files of this type will open in the
selected OS X application.

For Windows 8 and Windows 7:

To make some type of Windows files always open in an OS X application, do the following:

Right-click a Windows file and choose Open with > Choose default program.

2 Select the OS X application you want to use with that type of file and make sure Use this app
for all <file_extension> files is selected. Now all files of this type will open in the selected OS X
application.

Modality Mode

When you switch to Modality, you can resize the virtual machine windows and place them side by
side with your Mac's applications.

In the Modality mode, you can:

= Resize the Windows window while keeping its shape by dragging its lower-right corner.

= Resize the Windows window by pressing and holding the Option (Alt) key and dragging the
lower-right corner of the window.

= Resize the Windows window and dynamically adjust the screen resolution by pressing and
holding the Shift and dragging the lower-right corner of the window.

Using the Modality settings, you can configure the virtual machine appearance and behavior when
it is running in the Modality mode. In the Modality mode, you can resize the virtual machine
windows and place them side by side with your Mac applications. A Modality window can be
scaled to any size, and its content will still be active. This allows you to monitor the tasks running
inside the virtual machine while you are working on the Mac side.

To edit these settings, do the following:

1 Click the Parallels icon Il in the menu bar and choose Configure. Or if the Parallels Desktop
menu bar is visible at the top of the screen, choose Actions > Configure.
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2 Inthe Virtual Machine Configuration window, click Options and select the settings name in
the sidebar.

You can configure the settings in this pane even when the virtual machine is running.

@& Windows 8.1 - Options
o= a
General Options Hardware Security Backup
@ Startup and Shutdown Opacity:
Transparent Opaque
@ Optimization
Sharing Keep on top of other windows
Capture keyboard and mouse on click
'-’g Applications

@ Full Screen

.

W Web & Email
—
Ll'.'..l.l Travel Mode

@D More Options
L Restore Defaults

L!J Click the lock to prevent further changes. ?

In the Modality mode, the virtual machine window becomes transparent by default. You can specify
the level of visibility in the Opacity field by dragging the slider between Transparent and Opaque.
You can change the level of transparency for your virtual machine that is running when it is in the
Modality mode.

To manage the behavior of the virtual machine window in the Modality mode, use the following
options selected by default:

< Keep on top of other windows. Clear this option if you do not want the virtual machine
window to appear on top of all other open windows when the virtual machine is in Modality.

= Capture keyboard and mouse on click. Clear this option if you do not want the virtual
machine to capture the keyboard and mouse input when in Modality.

Hide and Show Parallels Desktop

When Parallels Desktop is running, you can hide and show it and all its windows by holding down
the Function (Fn) key and pressing the F6 key.

If Parallels Desktop is visible but running in the background, pressing Fn-F6 brings Parallels
Desktop and all its windows to focus.
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Note: Most function keys (F1, F2, and so on) on Mac keyboards serve as specific control keys, such as
volume and brightness controls, and you must hold down the Fn key as you press the function key to
trigger an alternate, application-specific function. If you want to set function keys to be used for alternate
functions without having to press the Fn key, choose Apple menu > System Preferences and click
Keyboard. Then click the Keyboard tab and choose Use all F1, F2, etc. keys as standard function
keys.

Disable Automatically Suspending Windows

By default, when you quit Parallels Desktop, Windows is suspended, and the next time you open
Parallels Desktop Windows resumes exactly from where you left off.

If more than one person uses Windows on your Mac, then a user can access the account in
Windows suspended by the previous user. To avoid this, you can disable automatically suspending
Parallels Desktop.

To disable automatically suspending Parallels Desktop:

1 Do one of the following:
= Click the Parallels icon !l in the menu bar and choose Preferences. Then click General.

= Right-click the Parallels Desktop icon in the Dock and choose Preferences. Then click
General.

2 Select OS X Resume: Disable for Parallels Desktop.

Once automatically suspending Windows is disabled, each time you quit Parallels Desktop you can
specify how you want Windows to shut down (p. 36). And if you close the Parallels Desktop
window, Windows shuts down according to how it's set in shutdown settings (p. 38). To ensure
that another user can't access your Windows account, set windows to shut down or stop (rather
than suspend).

Remove Parallels Desktop

To remove Parallels Desktop, open your Applications folder and drag the Parallels Desktop
application to the Trash.
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Advanced Preferences

In the Advanced pane of Parallels Desktop Preferences, you can configure some additional
settings.

& Advanced
o = P Q@ =Na
General Shortcuts Devices Security Network Advanced Toolbox Access
Speech: Enable spoken commands

Feedback: Participate in the Customer Experience Program

Troubleshooting: Use detailed log messages
Reset all dialog warnings:  Reset Warnings

Show developer tools

‘El Click the lock to prevent further changes. ?

Speech

Parallels Desktop allows you to operate your virtual machine by using the speech commands. If you
want to do that, select Enable spoken commands and make sure that:

= the virtual machine window is active, and

= the speech settings are properly tuned on the corresponding tab of Mac OS X System
Preferences

If the speech settings are not tuned, you will see the "To enable this option, you
should turn on speakable i1tems in System Preferences® warning message. To
tune the speech settings, click System Preferences.

To view the list of all spoken commands available to manage your virtual machines, please refer to
Enable Spoken Commands (p. 127).
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Feedback

To participate in the Customer Experience Program, select the corresponding option. If you join this
program, Parallels will collect information about your Mac and virtual machines configuration. The
collected information will help us to make the product better fit your needs.

If you join, only the following types of data will be collected:

= hardware configuration of your Mac

= software configuration of your Mac and virtual machines (the names and versions of the
operating systems and software installed in them)

= configuration files of virtual machines

Any types of private information like your name, e-mail, address, phone number, and keyboard
input will not be collected.

For more details, visit the Customer Experience Program page at the Parallels website (follow the
link in the pane).

Troubleshooting

While functioning, Parallels Desktop automatically creates a log file that can be used by the Parallels
support team for solving problems and improving the product. If you select the Use detailed log
messages option, Parallels Desktop will start creating a more detailed log file. It can be helpful for
the Parallels support team, but uses more hard disk space and may slightly lower the system
performance.

Resetting Hidden Messages

Some Parallels Desktop dialogs and windows are provided with the Do not show this message
again option. If you select this option, the corresponding dialog will not appear next time you
perform the same operation. Using the Reset Warnings button, you can reset all dialogs and
windows with this option selected so that they would be displayed again each time you initiate the
corresponding operation.

Developer Tools

Note: This feature is available in Parallels Desktop for Mac Pro Edition only.

Parallels Desktop has several useful features for software developers. If you select the Show
developer tools option, the Develop menu will be available in the OS X menu bar. From this
menu, you can:

= Start an SSH session;

= Open the virtual machine IP address in the OS X default web browser;
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= Start a debugging session, or

= (Generate the virtual machine memory dump.

Locking Parallels Desktop Preferences

If you want to prevent Parallels Desktop Preferences from further unauthorized changes, click the

I J—n
Lock icon = at the bottom of the window. The next time anybody wants to change the settings
in any pane of Parallels Desktop Preferences, an administrator's password will be required.

Shared Networking Settings

Note: Shared network settings are available in Parallels Desktop for Mac Pro Edition only.
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To change the shared networking settings, select the Network tab of Parallels Desktop
Preferences and click Shared. You will see the following window:

@ Network
1= L P = S
General Shortcuts Devices Security Network Advanced Toolbox Access

” Connect Mac to this network
Shared )
.. Show in System Preferences

.4 Enable IPv4 DHCP
!.!'? Host-Only € Enable | =

Start Address: 10.211.55.1
End Address: 10.211.55.254

Subnet Mask: 255.255.255.0
Subnet: 10.211.55.0

Enable IPv6 DHCP
Subnet: fdb2:2c26:fded::

Prefix Length: 64

Port forwarding rules:

Source Port  Protocol Forward to Destination Port

+ e i T]_ . /"'.

E_ﬁ Click the lock to prevent further changes. Restore Defaults

In this window, you can make the necessary changes to the settings of the Parallels DHCP servers
for IPv4 and IPv6. These servers, enabled by default, automatically assign IP addresses to your
virtual machines operating in the shared networking mode. To disable any of these servers, clear
the corresponding option.
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For more information about configuring shared networking, refer to Share Network Settings
Between Mac OS X and Windows (p. 95).

Port Forwarding

Note: This feature is available in Parallels Desktop for Mac Pro Edition only.

Normally, virtual machines set to operate in the shared networking mode cannot be accessed from
external computers. The port forwarding functionality allows computers on your local network and
on the Internet to transfer data to any of your virtual machines that use the shared networking
mode. The data sent to a specific port on your Mac will be redirected to a specific port of your
virtual machine according to the port-forwarding rule.

To add a port forwarding rule:

1 Click the Add button -] below the Port forwarding rules list.
2 In the displayed window, do the following:

= In the Protocol field, specify the port type you want to use for establishing network
connections. You can choose between the TCP or UDP port types.

= In the Source Port field, type the number of the incoming port on your Mac.

< |n the Forward to section, indicate the name or IP address of the virtual machine you want
to connect.
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= In the Destination Port field, type the port on the virtual machine to which the data will be
transferred.

Protocol: ~ TCP

Source Port: \ \

Forwardto: () Windows 8.1 2

© P Address

Destination Port: | ’

3 Click OK to add the rule.

When the rule is added, use the following IP address combination for external connections to your
virtual machine: <you Mac®s IP address>:<Incoming port>.

(

Network

b ".:' :: T;‘,JP Metwork Adapter

Metwork Adapter

Network Adapter

Your Mac

165



Advanced Topics

To edit a rule, select it in the Port forwarding rules list, click the Edit button 4 , modify the
necessary settings, and click OK to apply them.

To remove a port forwarding rule, select it in the Port forwarding rules list and click the Remove
button =.

To restore the default settings, click Restore Defaults.

Host-Only Networking Settings

Note: Host-Only network settings are available in Parallels Desktop for Mac Pro Edition only.
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To change the host-only networking settings, select the Network tab of Parallels Desktop
Preferences and click Host-Only. You will see the following window:

@ Network
—— = _-": . —
= L O B [
General Shortcuts Devices Security Network Advanced Toolbox Access

Connect Mac to this network
@ shared _
e Show in System Preferences

- Y
Start Address: 10.37.129.1

End Address: 10.37.129.254

Subnet Mask: 255.255.255.0
Subnet: 10.37.129.0

Enable IPv6 DHCP
Subnet: fdb2:2c26:f4ed:1::

Prefix Length: 64

diofrvy

‘:ﬁ Click the lock to prevent further changes. Restore Defaults

In this window, you can make the necessary changes to the settings of the Parallels DHCP servers
for IPv4 and IPv6. These servers, enabled by default, automatically assign IP addresses to the
virtual machines operating in the host-only networking mode. To disable any of these servers, clear
the corresponding option.

167



Advanced Topics

To restore the default settings, click Restore Defaults.

For more information on configuring the host-only networking settings, refer to Use Host-Only
Network Settings (p. 98).

Create a Custom Host-Only Network

When working with Parallels Desktop, you can use an already configured shared or host-only
networks. If you need to manage network traffic between virtual machines, you can add a new
host-only network.

Note: You can add new host-only networks in Parallels Desktop for Mac Pro Edition only.

To add a new host-only network:

1 Do one of the following:
= Click the Parallels icon Il in the menu bar and choose Preferences. Then click Network.

= Right-click the Parallels Desktop icon in the Dock and choose Preferences. Then click
Network.

2 Click the Add button | * . Once a new host-only network is added, configure its settings the
way you need.

To remove a custom host-only network, select it and click the Remove button

More Options

In the More Options pane, you can configure the Parallels Desktop additional settings.
To edit these settings, do the following:

1 Open the Actions menu or click the Parallels icon I1'in the Mac menu bar and click Configure.
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2 Inthe Virtual Machine Configuration window, click Options and select the settings name in
the sidebar.

® Windows 8.1 - Options
= i a
General Options Hardware Security Backup
@ Startup and Shutdown Time: Sync from OS X |~ ]
@ o Copy & Paste: Share Mac clipboard
Optimization
- Preserve text formatting
Sharing
Enable swipe from edges
'-—g Applications Enable Apple Remote
Allow Windows to access your Mac's current location
@ Full Screen
E Modality
W« Web & Email
P
Lt“_'.l Travel Mode
@8 More Options
. \ Restore Defaults
fi
d' Click the lock to prevent further changes. 2

Time Synchronization

Select Sync from OS X to synchronize Windows time settings with those of your Mac.

If you want Windows and Mac OS X time settings to always be the same, select Sync from either
0S. With this option selected, if you manually change the time settings in Windows, they are

changed accordingly in Mac OS X and vice versa.

If the time zone set in your virtual machine differs from that of your Mac, you can maintain this time
difference by selecting Do not sync.

Copy & Paste

If you want to copy and paste data between the host and guest operating systems, select Share
Mac clipboard. If the data you copy and paste between Mac OS X and your virtual machine is text
and you want to preserve text formatting, select Preserve text formatting.

Note: This functionality is available only for virtual machines with Parallels Tools installed (p. 199).

Windows Touchpad Gestures

Select Enable swipe from edges to enable edge swipe gestures, for example, swiping from the
right edge of the touchpad to show the Charm Bar, when working with Windows.

Note: This option is available for Windows 8 and later.
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If you often accidentally swipe from the edges of the touchpad and activate features, you may want
to disable edge swipe gestures by deselecting this option.

Apple Remote
Select Enable Apple Remote to use the Apple Remote to control some Windows applications.

For detailed information on using Apple Remote, see Control Programs with Trackpad Gestures
or the Apple Remote.

Current Location

Some of Windows applications may ask your permission to use your current location. To allow this,
select Allow Windows to access your Mac's current location.

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock

f
icon -55 at the bottom of the window. The next time someone wants to change the settings in
any pane of Virtual Machine Configuration, an administrator's password will be required.

Adding and Removing Devices

Adding new devices to a virtual machine is easier than connecting new devices to a real computer.
Removing or disconnecting devices is also easy. The following virtual devices can be added to the
configuration or removed from it:

= virtual hard disk drive
< (CD/DVD drive

= floppy disk drive

= network adapter

= serial port

e printer port

= sound device

= USB controller

Any of the aforementioned devices can be added to the corresponding virtual machine only when it
is stopped.

Note: To be able to connect any virtual device to a real one, you should have system privileges to access
the real device. Otherwise, the real device will not appear in the list of available devices even though it is
installed on your computer.
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Adding a New Device to a Virtual Machine

1 Choose Configure from the Actions menu to open Virtual Machine Configuration.

2 C(Click the Hardware button at the top of the Virtual Machine Configuration dialog to open the
pane for editing hardware devices.

3 Click the Add button ] in the bottom part of the Virtual Machine Configuration dialog and
select the device to be added to your virtual machine.

Note: The Add button is disabled when the virtual machine is running. You need to stop the virtual
machine before you can use this button.

B - |
< CD/DVD
L4 Hard Disk
== Serial Port

& Network '

i= Printer

4 If you selected any device except for a hard disk, the corresponding device with a typical
configuration is added at once and ready for use.

If you selected a hard disk, you should specify some parameters:

= The hard disk type: a new image file or an existing one. Select Boot Camp if you want to
add an existing Boot Camp partition as a hard disk to your virtual machine.

= The hard disk location. Provide the path on your Mac to the existing image file or the path
and name for the new image file. By default, Parallels Desktop offers to save the new image
file in the virtual machine PVM bundle.

= The hard disk size for the new hard disk image file.
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= For the new hard disk image file, you can choose one of the following formats: Expanding or
Plain. By default, the hard disk will have the Expanding format. To create a Plain hard disk,
clear the Expanding disk option. If you want the virtual hard disk to be split, select the Split
the disk image to 2 GB files option. For more information on hard disk formats, refer to
Support for Virtual and Real Disks (p. 172).

Type: New image file <]
Location: Windows 8.1-1.hdd (v |
Size: | 128.0GB <
100 MB 8 GB 32 GB 128 GB 512 GB 2TB

Split the disk image into 2 GB files
4 Expanding disk

Cancel OK

Click OK, to add the hard disk. After you added a new virtual hard disk to the virtual machine
configuration, it will be invisible to the operating system installed inside the virtual machine until
the moment you initialize it. For detailed information on how to initialize the newly added hard
disk, see Initializing the Newly Added Disk (p. 174).

After the new device is added, you can manage its properties as usual and start using it.

Removing Devices From the Virtual Machine Configuration

Choose Configure from the Actions menu to open Virtual Machine Configuration.

2 Click the Hardware button at the top of the Virtual Machine Configuration dialog to open the
pane for editing hardware devices.

3 Select the device you want to remove and click the Remove button =lin the bottom part of
the Virtual Machine Configuration dialog.

Support for Virtual and Real Disks

This section lists the types of disks that can be used by Parallels virtual machines and provides the
information about basic operations you can perform on these disks.
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Supported Types of Hard Disks

Parallels virtual machines can use either virtual hard disks or Boot Camp partitions as their hard
disks.

Virtual Hard Disks
The capacity of a virtual hard disk can be set from 100 MB to 2 TB.
Virtual hard disks can be of either plain or expanding format.

A plain virtual hard disk image file has a fixed size. The size is determined when the

plain disk is created.

An expanding virtual hard disk image file is small initially. Its size grows as you add

expanding applications and data to the virtual hard disk in the guest OS.

When you create a virtual machine, the disk is created in the expanding format. You can change
the disk format in the Hard Disk pane of the Virtual Machine Configuration dialog. To add a plain
hard disk to your virtual machine, clear the Expanding disk option when adding a hard disk to the
virtual machine.

Split disks

A virtual disk of either format can be a single-piece disk or a split disk. A split disk is cut into 2 GB
pieces and is stored as a single -hdd file.

Boot Camp Partitions

With Parallels Desktop, you can choose how to use your Boot Camp Windows XP, Windows Vista,
or Windows 7 operating system: to boot in it natively (via Boot Camp) or in a virtual machine (via
Parallels Desktop). A Boot Camp Windows partition can be used as a bootable disk or as a data

disk in Parallels virtual machines. For detailed information, see Using the Boot Camp Partition in
a Virtual Machine.

Note: You cannot create snapshots or use the Undo Disks option for a virtual machine that uses the
Boot Camp partition.

CD/DVD Discs and Their Images
Parallels Desktop can access real CD/DVD discs and images of CD/DVD discs.

Parallels Desktop has no limitations on using multi-session CD/DVD discs. A virtual machine can
play back audio CDs without any limitations on copy-protected discs.
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If your host computer has a recordable optical drive, you can use it to burn CD or DVD discs in a
virtual machine.

Parallels Desktop supports CD/DVD disc images in the ISO, CUE, and CCD formats.

Note: DMG disk images made with Mac OS X Disk Ultility are also supported by Parallels Desktop. When
creating such an image, make sure you create a read-only and uncompressed image without any
encryption.

Floppy Disks and Floppy Disk Images

Parallels Desktop can use two types of floppy disks:
= Real diskettes inserted into a real floppy disk drive that is connected to the virtual machine.

= Floppy disk image files having the . fdd extension and connected to the virtual machine.

Parallels Desktop treats floppy disk images like real diskettes. Parallels Desktop supports floppy
disk image files that have the . fdd extension and 1.44 MB size.

Initialize a Newly Added Disk

After you added a new blank virtual hard disk to the virtual machine configuration, it will be invisible
to the operating system installed inside the virtual machine until the moment you initialize it.

Initializing the New Virtual Hard Disk in Windows

To initialize a new virtual hard disk in a Windows guest OS, you will need the Disk Management
utility available. For example, in Windows 7 and Windows XP you can access this utility by doing
the following:

= In Windows 7, click Start > Control Panel > System and Security > Administrative Tools >
Computer Management Storage > Disk Management.

« In Windows XP, click Start > Control Panel > Administrative Tools > Computer
Management > Storage > Disk Management.

When you open the Disk Management utility, it automatically detects that a new hard disk was
added to the configuration and launches the Initialize and Convert Disk wizard:

1 In the introduction window, click Next.
2 In the Select Disks to Initialize window, select the newly added disk and click Next.

3 In the Select Disks to Convert window, select the newly added disk and click Finish.
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The added disk will appear as a new disk in the Disk Management utility window, but its memory
space will be unallocated. To allocate the disk memory, right-click this disk name in the Disk
Management utility window and select New Simple Volume in Windows Vista or New Volume in
Windows XP. The New Simple Volume Wizard/New Volume Wizard window will appear. Follow
the steps of the wizard and create a new volume in the newly added disk.

After that your disk will become visible in Computer/My Computer and you will be able to use it as
a data disk inside your virtual machine.

Initializing the New Virtual Hard Disk in Linux

Initializing a new virtual hard disk in a Linux guest OS comprises two steps: (1) allocating the virtual
hard disk space and (2) mounting this disk in the guest OS.

To allocate the space, you need to create a new partition on this virtual hard disk using the fdisk
utility:

Note: To use the Fdisk utility, you need the root privileges.

1 Launch a terminal window.

2 To list the IDE disk devices present in your virtual machine configuration, enter:
fdisk /dev/hd*

Note: If you added a SCSI disk to the virtual machine configuration, use the fdisk /dev/sd*
command instead.

3 By default, the second virtual hard disk appears as /dev/hdc in your Linux virtual machine. To
work with this device, enter:
fdisk /dev/hdc

Note: If this is a SCSI disk, use the fdisk /dev/sdc command instead.

To get detailed information about the disk, enter:
To create a new partition, enter:
To create the primary partition, enter:

Specify the partition number. By default, it is 1.

00 ~NT O S0 T H

Specify the first cylinder. If you want to create a single partition on this hard disk, use the default
value.

9 Specify the last cylinder. If you want to create a single partition on this hard disk, use the default
value.

10 To create a partition with the specified settings, enter:
w
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When you allocated the space on the newly added virtual hard disk, you should format it by
entering the following command in the terminal:

mkfs -t <FileSystem> /dev/hdcl

Note: <Fi leSystem> stands for the file system you want to use on this disk. It is recommended to
use ext3 or ext2.

When the added virtual hard disk is formatted, you can mount it in the guest OS.

1 To create a mount point for the new virtual hard disk, enter:
mkdir /mnt/hdcl

Note: You can specify a different mount point.

2 To mount the new virtual hard disk to the specified mount point, enter:
mount /dev/hdcl /mnt/hdcl

When you mounted the virtual hard disk, you can use its space in your virtual machine.

Hardware Settings

Using the Virtual Machine Configuration dialog, you can configure the virtual hardware available
in your virtual machine:

= Configure the devices currently available inside the virtual machine.
= Add or remove devices.

= Configure the boot order of your virtual machine.

CPU and Memory

Using CPU&Memory settings, you can:

e Set how many processors are allocated to Windows (p. 127)
e Set how much memory is allocated to Windows (p. 100)

= Enable virtualization support in Windows (for Windows 8 and Windows Server 2012 only)
Enable nested virtualization support
Note: This feature is available in Parallels Desktop for Mac Pro Edition only.

Parallels Desktop 12 allows you to run Hyper-V virtual machines inside Windows 8 and Windows
Server 2012 virtual machines, and to run Xen and kernel-based virtual machines in versions of
Linux that support Xen and KVM
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Note: Running a virtual machine within a virtual machine may slightly slow down the hosting virtual
machine performance.

To enable nested virtualization support, select Enable nested virtualization.

If you want to create or test applications for Windows Phone, first configure Windows to run
Windows Phone emulator (p. 150).

Warning: Do not use Hyper-V virtual machines in a production environment. Microsoft® doesn't support
nesting Hyper-V, and so such virtual machines may be unstable.

Enable PMU virtualization support

Note: This feature is available in Parallels Desktop for Mac Pro Edition only.

If you're using virtual machines for software development, you can use a performance monitoring
tool, such as Intel VTune Amplifier or OProfile, to optimize the code.

To get started using a performance monitoring tool:

1 Enable PMU (Performance Monitoring Unit) virtualization support by selecting PMU
virtualization.

2 Start your virtual machine.

3 Either start using a built-in profiling utility or download and install any performance monitoring
tool you like.

Notes:

1. PMU virtualization support can be enabled in Windows (starting from Windows XP) and Linux virtual
machines.

2. Enabling PMU virtualization support may slightly slow down your virtual machine performance.

Boot Order

Using the Boot Order settings, you can configure the virtual machine boot sequence, that is, the
order in which the virtual machine will try to load the operating system from different boot devices.

Note: These settings cannot be changed when the virtual machine is running.

To edit the Boot Order settings, do the following:

1 Click the Parallels icon Il in the menu bar and choose Configure. Or if the Parallels Desktop
menu bar is visible at the top of the screen, choose Actions > Configure.
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2 In the Virtual Machine Configuration dialog, click Hardware and select Boot Order in the
sidebar.

. & (<] Windows 10 - Hardware

o i e= S B -

General Options Hardware Security Backup Dev Settings Business

B cpu & Memory Bootorder: ' Hard Disk 1
Y + CD/DVD
4> Boot Order External device .
«  Metwork 1
m Graphics «  Flannw Nick

External boot device: Not selected
~—— Mouse & Keyboard

Select boot device on startup
gl Shared Printers
¥ Advanced Settings

@ heetiori: | Use EFI Boot

EFl Secure Boot
Boot flags:

m USB & Blustooth

+ | = Restore Defaults

LE“ Click the lock to prevent further changes.

The currently supported boot devices are listed below:
« Hard Disk. Select this device if you want the virtual machine to boot up from its virtual hard
disk drive.

< CD/DVD-ROM. Select this device if you want the virtual machine to boot up from the media
connected to its virtual CD/DVD-ROM drive.

Note: The virtual machine will use the CD/DVD-ROM drive specified as CD/DVD-ROM 1 in its
configuration.

= External device. Select this device if you want the virtual machine to boot up from a bootable
external device (USB, FireWire, Thunderbolt, etc.) connected to your Mac. Once selected,
choose the device from the External boot device menu located below.

« Floppy Disk. Select this device if you want the virtual machine to boot up from a floppy disk
image connected to its virtual floppy disk drive.
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= Network. Select this device if you want your virtual machine to boot from a network adapter
using PXE (Pre-Execution Environment).

Note: The virtual machine will use the network adapter specified as Network 1 in its configuration.

Every time you start the virtual machine, it tries to boot from the device specified as the first one in
the Boot Order list. If the virtual machine cannot boot from the first device (for example, no media
is connected to it), the virtual machine proceeds to the second device in the list and tries to boot
from this device, and so on.

In this pane, you can perform the following operations:

= (Change the currently set boot sequence by selecting the name of the corresponding boot
device in the Boot Order list and moving it up or down using the arrows to the right of the list.

= Remove a boot device from the sequence by clearing the check box next to its name.

If you choose the Select boot device on startup option, you will see the following message at the
virtual machine startup: "Press ESC to select boot device". If you press ESC pending 5
seconds, you will be able to select a boot device. If you do not press ESC, the virtual machine will
try to boot from the devices specified in the Boot Order list.

Note: Make sure that the device you wish to use for your virtual machine booting (hard disk drive, CD-
ROM drive, floppy disk drive, or network adapter) is available to the virtual machine and configured
properly. If you do not have any boot devices configured in your virtual machine, you will see the following
error message after you start the virtual machine: “No boot device is available”. In this case,
you should stop the virtual machine and configure at least one boot device for it.

Boot Windows Securely

Pirated versions of Windows may have backdoors through which hackers have full access to the
system and data. If you're working with Windows 8 or later in Parallels Desktop for Mac Pro Edition,
you can configure Windows to check the boot loader on startup. This allows to prevent the
execution of unsigned and potentially dangerous code.

To configure Windows to boot securely, select EFI Secure Boot. If a user tries to start a virtual
machine with an illegal version of Windows, Secure Boot detects unauthorized changes to the
firmware, operating system, or UEFI drivers and prevents such an operating system from starting.

Boot Flags

The Boot flags field is intended for specifying the flags that can change the virtual machine system
behavior. The system flags can be used by the Parallels customer support team in cases when
something goes wrong in your virtual machine. It is not recommended to type anything into this
field without being instructed to do so by the customer support staff.
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If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock

.y
icon -{I at the bottom of the window. The next time someone wants to change the settings in
any pane of Virtual Machine Configuration, an administrator's password will be required.

Graphics

To view and configure the amount of video memory available to the virtual machine video card, use
the Graphics settings.

To edit these settings, do the following:

1 Click the Parallels icon Il in the menu bar and choose Configure. Or if the Parallels Desktop
menu bar is visible at the top of the screen, choose Actions > Configure.

2 In the Virtual Machine Configuration dialog, click Hardware and select Graphics in the
sidebar.
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Note: These settings cannot be changed when the virtual machine is running.

'Windows 1{i - 'I-'I'ardware

@

| General Options Hardware Security Backup Dev Settings Business

B cpu & Memory Memory: 512MB 2

A%
‘ g& Boot Order
| 2 MB 64 MB 256 MB 2GB

B Graphics
- Resolution: Best for Retina display

| High-res, high-DPI graphics. Most apps look sharp and

S Mouse & Keyboard clear.
Scaled
i Shared Printers Graphics scaled to full size. Best for legacy apps.
) Best for external displays
Q MNetwork 1 Windows manages DPI settings on each display.

¥ Advanced Settings
3D acceleration: DirectX 10 ﬁ

, Sound Vertical synchronization

m USB & Bluetooth

L+ = Restore Defaults
LP Click the lock to prevent further changes. ?
In the Memory field, you can set the amount of video memory that will be available to the virtual

machine.

To configure the video memory limit, do one of the following:

= Drag the slider
= Use the spin box arrows

= Type the value directly into the Memory field

Working with Windows on Retina Display

If you're working with Windows 7 or later on a Mac with a Retina display, you can choose how
Windows is displayed on the screen:
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= Best for Retina display. Windows resolution matches that of the Retina display and the DP!I
setting increases. Windows interface elements and text are clear, sharp, and at full size. This
option is supported by Windows 7 and later.

= Scaled. Windows resolution and DPI setting don't change. Instead, Windows is scaled to full
size. As a result, Windows interface elements and text are not sharp. This option is useful for
Windows applications that don't support high-DPI settings and appear small onscreen.

= Best for external displays. Use this option if you're working with Windows on multiple displays
one of which is non-Retina. The option is supported by Windows 8 and Windows 10.

For Windows XP:

If you're working with Windows XP on a Mac with a Retina display, Windows becomes scaled but
its resolution doesn't change. As a result, Windows interface elements and text are not sharp.

However, you can enable full (2880x1800) Retina resolution for Windows by selecting Enable

Retina resolution. At such a high resolution, Windows interface elements and text become sharp
but small.

Enabling 3D Acceleration
If you want to use Windows Aero in your Windows virtual machines or use games and applications

that require video cards that support DirectX or OpenGL, select On or the version of DirectX you
need from the 3D acceleration menu.

Enabling Vertical Synchronization

Sometimes in games and 3D applications, a newly rendered frame may overlap a previously
rendered one and then screen tearing happens. This occurs when the video card or the software
using it begins updating the actively-displayed memory in a manner that is out of sync with the
monitor's refresh rate. To prevent screen tearing, select the Vertical synchronization option.

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock

.y
icon 115-5]i at the bottom of the window. The next time someone wants to change the settings in
any pane of Virtual Machine Configuration, an administrator's password will be required.

Floppy Disk
To view and configure the virtual machine floppy disk drive settings, use the Floppy Disk settings.

To edit the device settings, do the following:

1 Click the Parallels icon Il in the menu bar and choose Configure. Or if the Parallels Desktop
menu bar is visible at the top of the screen, choose Actions > Configure.
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2 In the Virtual Machine Configuration dialog, click Hardware and select this device name in
the sidebar.

Note: If this device is absent, you can add it to Virtual Machine Configuration. For detailed information on
how to add a device, refer to Adding and Removing Devices.

@ Windows 8.1 - Hardware

R S

General Options Hardware Security Backup

‘ @ Network 1 Source: I unattended.fdd 1%}

H Printer 1

‘ . Sound

m USB & Bluetooth

-
[ Hard Disk 1

B8 Floppy Disk

i CD/DVD 1

8 Serial Port 1

* |- | Restore Defaults

Lgi Click the lock to prevent further changes. ?
In the Source field, specify the source device or image file that will emulate the virtual machine
floppy disk drive:

= |f you want to use a real floppy disk drive, click the Source field and select the real device name
from the list.

= If you want to use a floppy disk image, click the Source field, click Choose an image file, and
specify the path to the desired floppy disk image file.

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock

i
icon "—il at the bottom of the window. The next time someone wants to change the settings in
any pane of Virtual Machine Configuration, an administrator's password will be required.

CD/DVD-ROM

To configure the virtual machine CD/DVD drive settings, use the CD/DVD settings. Virtual CD/DVD
drives can be connected either to physical CD/DVD drives or to CD/DVD images.

Note: You can connect up to 4 IDE devices (hard disks or CD/DVD drives), 6 SATA, and 15 SCSI
devices to a virtual machine. Each device is listed separately in the Virtual Machine Configuration dialog
and has its own number.

To edit the device settings, do the following:
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1 Click the Parallels icon Il in the menu bar and choose Configure. Or if the Parallels Desktop
menu bar is visible at the top of the screen, choose Actions > Configure.

2 In the Virtual Machine Configuration dialog, click Hardware and select this device name in
the sidebar.

Note: If this device is absent, you can add it to Virtual Machine Configuration. For detailed information on
how to add a device, refer to Adding and Removing Devices.

® Windows 8.1 - Hardware
c = P i
General Options Hardware Security Backup
@ Network 1 Source: Disconnected <]
H Printer 1
W Advanced Settings
Q Sound Location: SATAO:2 &)

m USB & Bluetooth

et Hard Disk 1
. Hard Disl
| ==
B Floppy Disk

8 Serial Port 1

i bl Restore Defaults

L;l Click the lock to prevent further changes.

To emulate the virtual CD/DVD drive, you can connect one of the real CD/DVD drives on your
physical computer or a CD/DVD image file to the virtual machine.

Note: Parallels virtual machines support ISO and DMG image files and may support CUE and CCD
image files.

In the Source field, the source device or image file that emulates the virtual machine CD/DVD drive
is specified. You can change the source device:

e To use areal CD/DVD drive as the virtual machine CD/DVD drive, click the Source field and
select the real device name from the list.

< To use an image file as the virtual machine CD/DVD drive, click the Source field and choose
the image file from the list, or click Choose an image file and specify the path to the desired
image file on your Mac.

In the Location field, you can specify the type of interface for connecting the device:

< IDE. Using this interface type, you can connect up to 4 virtual devices (hard disks or CD/DVD
drives).

= SATA. Using this interface type, you can connect up to 6 virtual devices (hard disks or CD/DVD
drives).
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If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock

.y
icon d-!{ at the bottom of the window. The next time someone wants to change the settings in
any pane of Virtual Machine Configuration, an administrator's password will be required.

Hard Disk

To view and configure the virtual hard disk settings, use the Hard Disk pane of Virtual Machine
Configuration. Parallels Desktop allows virtual machines to use hard disk images in the - hdd
format and Windows Boot Camp partitions.

Note: You can connect up to 4 IDE devices (hard disks or CD/DVD drives), 6 SATA, and 15 SCSI
devices to a virtual machine. Each device is listed separately in the Virtual Machine Configuration dialog
and has its own number.

To edit the device settings, do the following:

Shut down the virtual machine. (p. 36)
Open the Actions menu and choose Configure.

In the Virtual Machine Configuration dialog, click Hardware and select this device name in
the sidebar.
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Note: If this device is absent, you can add it to Virtual Machine Configuration. For detailed information on
how to add a device, refer to Adding and Removing Devices.

Windows 10 - Hardware

®

General Options Hardware Security Backup Dev Settings Business

Source: [J Windows 10-0.hdd ﬁ
Expanding disk, 128.0 GB

Edit... Compress...
m USB & Blustooth Free Space: Real time virtual disk optimization
= :
Hard Disk 1 ¥ Advanced Settings

Location: SATAO:1 |

&= Serial Port 1

LE“ Click the lock to prevent further changes.

In the Source field, the virtual hard disk file (. hdd) that emulates the virtual machine hard disk is
specified. You can change the hard disk source:

= To use the Boot Camp partition as the virtual machine hard disk, click the Source field and
select the Boot Camp partition name from the list.

= To use a virtual hard disk file as the virtual machine hard disk, click the Source field and choose
the virtual hard disk file from the list, or click Choose an image file and specify the path to the
desired image file (. hdd) on your Mac.

In the Location field, you can specify the type of interface for connecting the device:

= |IDE. Using this interface type, you can connect up to 4 virtual devices (hard disks or CD/DVD
drives).

186



Advanced Topics

= SATA. Using this interface type, you can connect up to 6 virtual devices (hard disks or CD/DVD
drives).

= SCSI. Using this interface type, you can connect up to 15 virtual devices (hard disks or
CD/DVD drives).

Note 1: The Mac OS X guest OS does not support the SCSI controller. In the latest Linux distributions,
the SCSI driver may be not installed. In this case, you should install this driver in your Linux guest OS to
be able to use the SCSI controller.

Note 2: The SCSI 7:0 location is not available for selecting, since it is occupied by the SCSI controller
itself.

Compressing the Disk

If you use an expanding (p. 172) virtual hard disk in your virtual machine, its image file size on the

physical hard disk increases as you add new data to the virtual hard disk. When you delete some
data from this virtual hard disk, free unused space appears on the disk, but the amount of space

your virtual machine occupies on the hard disk of your Mac does not reduce. To free the unused

space back to Mac, click the Compress button. The virtual hard disk will be compressed and the
hard disk image file size will be decreased. As a result, there will be more free space on your Mac
hard disk.

Note: Compressing can be performed for virtual machines without snapshots and with the Rollback
Mode option (p. 93) disabled.

Editing the Disk

If you find that the capacity of your virtual machine hard disk no longer fits your needs, you can
change its size.

Important:
1. Resizing a hard disk can be potentially dangerous to your data. Before you start, it is highly
recommended that you properly shut down the virtual machine (using the shutdown procedure of its

guest operating system) and back up the data. To learn how to make a backup, please see Back Up a
Virtual Machine (p. 117).

2. Resizing may take some time. It is not recommended that you interrupt the process.

3. If your MacBook is running on battery, connect it to a power source or make sure the battery is fully
charged. A power outage while writing changes to the disk may cause data loss.

To change the disk size:
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1 Click Edit.

Size: 64.0 GB s

0 MB 8 GB 32 GB 128 GB 512 GB 2TB

Resize file system
¥ Expanding disk
Split the disk image into 2 GCB files

Reset Apply Close

Note: If your virtual machine is running, has snapshots, or uses a Boot Camp partition as a hard disk,
its virtual hard disks cannot be resized.

Drag the slider or enter a new size in the Size field.
Select Resize file system if you want to change the file system size:

= |f you select Resize file system when increasing the disk size, the additional disk space will be
added to the last volume. If you deselect Resize file system, the added space will appear as
unallocated space and will be invisible to the guest operating system. To allocate this space,
you will have to either create a new partition or expand an existing partition. For instructions on
allocating the added space, please refer to the guest OS documentation.

= |f you select Resize file system when decreasing the disk size, the disk will be decreased by
removing the unallocated space and decreasing the size of the disk partitions. If you deselect
Resize file system when decreasing the disk size, you will be able to remove the unallocated
space of the disk only and the disk partitions will remain untouched.

If the format of the virtual hard disk is expanding, you can convert it to plain by deselecting
Expanding disk.

If you want the virtual hard disk to be split, select Split the disk image into 2 GB files option.

Note: For more information about virtual hard disk types, please refer to Support for Virtual and Real
Disks (p. 172).

188



Advanced Topics

Automatically Conserve Disk Space

In most cases, the space that Windows takes up on your hard disk expands as you add files and
other data, but isn't reduced when you delete data. To set Parallels Desktop to automatically
reduce disk space:

= Select Real time virtual disk optimization.

You can also quickly remove unnecessary files that have built up in the system (p. 129) to free up
disk space.

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock

f
icon ’ii-g']i at the bottom of the window. The next time someone wants to change the settings in
any pane of Virtual Machine Configuration, an administrator's password will be required.

Network

Using the Network settings, you can change the network type used in your virtual machine.

To edit the device settings, do the following:

1 Click the Parallels icon Il in the menu bar and choose Configure. Or if the Parallels Desktop
menu bar is visible at the top of the screen, choose Actions > Configure.

2 In the Virtual Machine Configuration dialog, click Hardware and select this device name in
the sidebar.
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Note: If this device is absent, you can add it to Virtual Machine Configuration. For detailed information on
how to add a device, refer to Adding and Removing Devices.
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You can choose one of the following network types for the virtual machine network adapter:

= Shared Network. Select this option to enable the Network Address Translation (NAT) feature
for the virtual machine. In this case, your virtual machine will share whatever network
connection is currently used by the host computer.

See Shared Network to learn how to configure this network type.

= Bridged Network. Select this option to allow the virtual machine to access the local network
and Internet through one of the network adapters installed on the host computer. In this case,
the virtual machine is treated as a stand-alone computer on the network and should be
configured in the same way as a real one. You can choose the physical adapter where the
virtual machine adapter will be bridged in the list below the Bridged Network option.

See Bridged Ethernet Network to learn how to configure this network type.
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= Host-Only Network. Select this option to allow the virtual machine to connect to the host
computer and the virtual machines residing on it and to make it invisible outside the host
computer.

See Host-Only Network (p. 98) to learn how to configure this network type.

Network Conditioner

Note: This feature is available in Parallels Desktop for Mac Pro Edition only.

If you're a software developer, you can simulate various Internet connectivity speeds to test your
applications. To do this, select Network Conditioner and choose a pre-configured profile that is
specific to the network conditions you want to test. Or click Configure and specify the Inbound
and Outbound settings according to your needs.

MAC Address

In the MAC address field, you can change the MAC address currently assigned to the virtual
machine. MAC addresses are automatically generated during the virtual machine creation.
However, you can modify the default MAC address by typing another value in the MAC address
field or clicking the Generate button. When entering a new MAC address, make sure that it is
unigue within your network.

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock

i
icon #—!’I at the bottom of the window. The next time someone wants to change the settings in
any pane of Virtual Machine Configuration, an administrator's password will be required.

Printer

Using the Printer settings, you can configure the virtual machine printer port settings. A virtual
machine can have up to three printer ports.

To edit the device settings, do the following:

1 Click the Parallels icon Il in the menu bar and choose Configure. Or if the Parallels Desktop
menu bar is visible at the top of the screen, choose Actions > Configure.

2 In the Virtual Machine Configuration dialog, click Hardware and select this device name in
the sidebar.
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Note: If this device is absent, you can add it to Virtual Machine Configuration. For detailed information on
how to add a device, refer to Adding and Removing Devices.
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In the Port field, choose the port type. If available, you're recommended to use the USB port type.
Connecting a printer to a virtual machine via USB ensures faster data transfer rate than connecting
it via LPT.

Notes:
1. You can connect up to 6 USB and up to 3 LPT printers to a single virtual machine.

2. You can connect a USB printer only if your virtual machine has a USB controller (p. 196). If not, you
can easily add it (p. 170).

In the Source field, the source device that emulates this printer port is specified. A printer port can
be emulated by one of the following devices:

= Printers. You can use any of the printers connected to your Mac in your virtual machine. Click
the Source field and select the appropriate printer from the list.

For the detailed information on how to set up a printer in your virtual machine, please refer to
Print from Windows (p. 82).

< Real printer port. If your Mac has a physical printer port, you can connect it to your virtual
machine. Click the Source field and select the physical port hame from the list.

e Output File. You can emulate the virtual machine printer port by using an output file. Click the
Source field and choose an output file from the list, or click Choose an output file and specify
the path to the desired output file on your Mac.
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If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock

.y
icon J-!{ at the bottom of the window. The next time someone wants to change the settings in
any pane of Virtual Machine Configuration, an administrator's password will be required.

Serial Port

In the Serial Port pane, you can configure the virtual machine serial port settings.

To edit the device settings, do the following:

1 Click the Parallels icon Il in the menu bar and choose Configure. Or if the Parallels Desktop
menu bar is visible at the top of the screen, choose Actions > Configure.

2 In the Virtual Machine Configuration dialog, click Hardware and select this device name in
the sidebar.

Note: If this device is absent, you can add it to Virtual Machine Configuration. For detailed information on
how to add a device, refer to Adding and Removing Devices.

Using serial ports, you can establish a connection between:

= The virtual machine and the host computer devices (using a real port); or

= Between two virtual machines located on the same host computer (using a socket).

If you want to connect your virtual machine to the host computer device, you should create a serial
port emulated by a real port. The Source list comprises the devices on the host computer that are
available for connection. The connected device, being used in any virtual machine, cannot be used
by the host computer. To be able to use it in the host computer, you should first disconnect it from
the virtual machine. To do that, use the Devices menu in the Mac menu bar.

If you want to connect two virtual machines with each other, you need to create a serial port
emulated by a socket in each virtual machine. The names of the serial ports should be identical.
The connection between the virtual machines via serial ports is bidirectional. It means that the
working modes of the sockets set during the port creation can be changed later in the Serial Port
pane.

If you need to log the performance activity of your virtual machine or to record the data from it and
use this information later on, you can connect your virtual machine serial port to an output file on
the physical computer. You will be able to view and analyze the activity history of the virtual
machine any time you need by exploring this file.

You can add a new serial port to your virtual machine using Add Hardware Assistant. For the
instruction on how to add serial ports, refer to Adding and Removing Devices.
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Note: You can connect up to four serial ports to a virtual machine.

® Windows 8.1 - Hardware

L H L 7} .

General Options Hardware Security Backup

@ Network 1 Source: (=i /dev/cu.Blustooth-Incoming-Port (&)

H Printer 1
I . Sound

m USB & Bluetooth
-
b Hard Disk 1

B Floppy Disk

CD/DVD 1
Serial Port 1

| Restore Defaults

L_gl Click the lock to prevent further changes.

In the Source field, the source device that emulates this serial port is specified.Serial ports can be
emulated by the following devices:

= Physical Serial Port. To connect the virtual machine serial port to one of the existing serial
ports on the host computer, choose the appropriate port on the host computer in the Source
list.

= Socket. To connect two virtual machines through the sockets, click the Source list and choose
the appropriate socket. If there are no sockets available, click New socket and specify its name
in the Enter a socket name field.
You should also configure the role the virtual machine will play in the connection by selecting
the necessary role in the Mode list. Selecting Server enables you to use this virtual machine to
direct the other one. Selecting Client enables you to direct this virtual machine from the other

one.

Note: If you change the socket mode of the first virtual machine, make sure the socket mode of the
second virtual machine is also modified.

« Output File. To connect the virtual machine serial port to an output file, click the Source list
and choose the appropriate output file. You can also click Choose an output file to locate the

necessary file.

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock

f
icon Lﬁ] at the bottom of the window. The next time someone wants to change the settings in
any pane of Virtual Machine Configuration, an administrator's password will be required.
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Sound

The Sound pane of Virtual Machine Configuration allows you to configure the virtual machine sound
device parameters.

To edit the device settings, do the following:

1 Click the Parallels icon Il in the menu bar and choose Configure. Or if the Parallels Desktop
menu bar is visible at the top of the screen, choose Actions > Configure.

2 In the Virtual Machine Configuration dialog, click Hardware and select this device name in
the sidebar.

Note: If this device is absent, you can add it to Virtual Machine Configuration. For detailed information on
how to add a device, refer to Adding and Removing Devices.

[ ] Windows 8.1 - Hardware

i == S

General Options Hardware Security Backup

‘@ Network 1 Output: Default Z]
g Priner Input; Default B

Sound Sync volume with Mac

m USB & Bluetooth

-
B Hard Disk 1

ﬂ Floppy Disk

‘ CD/DVD 1

B8 Serial Port 1

i il Restore Defaults

L;l Click the lock to prevent further changes. ?

Use the Output list to choose the necessary device. You can choose one of the following devices:

« Default. Select this option if you want to use the output device set as default in Mac OS.
= Built-in Output. Select this option if you want to use one of the output devices from your Mac.

= Mute. Select this option if you want to mute the output device.

Note: If you have a 5.1 or 7.1 surround-capable sound card connected to your Mac, you can use it in
Windows (p. 204).

Use the Input list to choose the necessary device. You can choose one of the following devices:

« Default. Select this option if you want to use the input device set as default in Mac OS.

= Built-in Microphone. Select this option if you want to use the built-in microphone.
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= Mute. Select this option if you want to mute the input device.

Sync volume level

For Windows XP and later with Parallels Tools (p. 140) installed, you can set Windows and OS X
volume levels to always be the same. With the Sync volume with Mac option selected, if you
manually change the volume level in Windows, it is changed accordingly in OS X and vice versa.

If your virtual machine doesn't have Parallels Tools installed, the guest operating system syncs the
volume level from OS X. If you want to set another volume level in the virtual machine, disable Use
Mac volume.

If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock

.y |
icon -!']i at the bottom of the window. The next time someone wants to change the settings in
any pane of Virtual Machine Configuration, an administrator's password will be required.

USB & Bluetooth

A virtual machine can emulate only one USB controller, which provides you with the possibility to
connect up to 12 USB 3.0, 15 USB 2.0, and 32 USB 1.1 devices to the virtual machine.

To edit the device settings, do the following:

1 Open the Actions menu or click the Parallels icon I1'in the Mac menu bar and choose
Configure.

2 In the Virtual Machine Configuration dialog, click Hardware and select this device name in
the sidebar.
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Note: If this device is absent, you can add it to Virtual Machine Configuration. For detailed information on
how to add a device, refer to Adding and Removing Devices.

. & Windows 10 - Hardware

D = S 3 &

General Options Hardware Security Backup Dev Settings
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.-? Boot Order Share Mac camera with Windows
. Share Bluetooth devices with Windows
m Graphics

USE Connection Preferences...

~—— Mouse & Keyboard
¥ Advanced Settings

H Shared Printers Enable USB 3.0

Q Network 1
g Printer 1
. Sound

h USB & Bluetooth

[ Restore Defaults

—
+

Lp Click the lock to prevent further changes.

In the USB & Bluetooth pane, you can:

= Disable camera sharing.
= Enable Bluetooth devices sharing.

e Enable USB 3.0 support.

Once USB 3.0 support is enabled, you can immediately start using USB 3.0 devices with
Windows 8 and Windows Server 2012. To be able to use USB 3.0 devices with Windows
7/Nista/XP, you must also install the USB 3.0 driver in Windows. The driver can be found here.

Note: You can also use USB 3.0 devices in the guest versions of OS X 10.7.4 with the latest updates
installed, OS X 10.8, and Linux guest operating systems that support USB 3.0.
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If you want to prevent Virtual Machine Configuration from unauthorized changes, click the Lock

.y
icon -5 at the bottom of the window. The next time someone wants to change the settings in
any pane of Virtual Machine Configuration, an administrator's password will be required.
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CHAPTER 6

Tips and Troubleshooting

If you're having trouble using Parallels Desktop, check this section for possible solutions.

In This Chapter
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Install Parallels Tools for Seamless Operation
Between Windows and Mac OS X

Many issues with using Parallels Desktop can be solved by installing Parallels Tools.

Parallels Tools help you work with Windows in the most comfortable and efficient way. With
Parallels Tools, you can:

= Move the mouse seamlessly between Windows and Mac OS X

= Synchronize the Windows time and date settings with those of Mac OS X
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= Share your Mac OS X disks and folders with Windows

= (Copy text and drag and drop objects from Mac OS X to Windows and vice versa

Important: Once you install Parallels Tools and restart Windows, you don't have to do anything else.
Parallels Tools automatically just work, without any action or configuration on your part.

To install Parallels Tools:

1 Start Windows (p. 31).

2 Choose Actions > Install Parallels Tools and follow the onscreen instructions.

For more information on installing and updating Parallels Tools, see Parallels Tools for Windows (p.
142).

Find Settings

If you want to change a setting in Parallels Desktop but you aren't sure where to find the setting,
you can search for it by doing the following:

1 Do one of the following:
= Click the Parallels icon Il in the menu bar and choose Configure.

= |f the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.

2 Type a word or phrase in the search field. Any settings related to your search are highlighted.

For example, if you want to find out whether you can change settings related to the Dock, type
"dock" in the search field and options that make Dock icons bounce to alert and allow you to
access Windows apps from the Dock are highlighted.

Restore Virtual Machine Default Settings

ReadWhen working with a virtual machine, you can change different virtual machine settings, such
as an amount of memory, video memory, number of CPUs, sharing settings, etc. To restore default
settings:

1 Do one of the following (the virtual machine must be shut down):
= In Control Center, right-click the virtual machine you want to configure and click Configure.
= |If the virtual machine window is open, click Actions > Configure.

2 In the virtual machine configuration dialog, find the pane with the settings that you want to
restore and click Restore Defaults.
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| Can't Activate Parallels Desktop

You must activate Parallels Desktop to be able to use all of its features.

If you are having trouble activating Parallels Desktop, try the following:

= Make sure the activation key you're using is for the version of the software being installed.
= Make sure you're entering the key correctly.

If you purchased and downloaded Parallels Desktop from the Internet, you received an
activation key via email. For best results, copy and paste the key from the email.

If you have a boxed copy of Parallels Desktop, the key is printed on the DVD sleeve. Make sure
you enter the entire key (30 characters). Dashes are added automatically.

= [fstill can't activate Parallels Desktop, check this Knowledge Base Article for an extended list of
solutions.

Memory Usage Problems

The amount of Mac's physical memory required for each virtual machine operation can be
represented as follows:

Virtual Machine Memory = Guest OS Memory + Video Memory + Virtual Machine Monitor Memory

= Guest OS Memory is the amount of RAM available to your guest operating system. You can
configure the guest OS memory amount in the CPU & Memory pane of the virtual machine
configuration dialog.

= Video Memory is the amount of physical memory available to the virtual machine's video card.
You can adjust the video memory amount in the Graphics pane of the virtual machine
configuration dialog.

= Virtual Machine Monitor is the module responsible for the guest operating system virtualization.
It consumes memory to perform operations of guest virtual devices and performs virtual paging
emulation. The amount of memory required for the Virtual Machine Monitor operation depends
on the guest OS and varies from 50 MB to 200 MB.

Memory Overcommitment

If you have several virtual machines running simultaneously and you are trying to start one more
virtual machine, you may come across the memory over commit. If so, Parallels Desktop informs
you with the corresponding message. If you start one more virtual machine, this may significantly
slow down all your virtual machines. To solve this problem, you can:

= Stop one or several of your running virtual machines; or

= Edit your virtual machines' configurations so they consume less memory.
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Windows Seems Slow

If Windows performance seems slow, try the following:

Quit applications and programs you aren't using: If you run a number of memory-
consuming applications and programs simultaneously, Windows performance may become
slow. Quit any applications that you aren't using. You can also use Activity Monitor (located in
the Mac OS X Finder in Applications > Utilities) to see how much of your Mac's memory each
application is using. That way, you'll have a better idea of which applications cause
performance to degrade the most.

Change how much memory is allocated to Windows: Parallels Desktop is set to allocate a
certain amount of your Mac's available RAM memory to Windows and the rest to Mac OS X. If
too much memory is allocated to Windows, Mac OS X may slow down, which in turn can cause
Windows programs to slow down because they're running on top of Mac OS X. If, on the other
hand, too much memory is allocated to Mac OS X, then Mac OS X applications may run well
but Windows programs might slow down.

To optimize the performance of both Windows and Mac OS X, set the memory allocated to
Windows (p. 100) to be somewhere within the recommended range, indicated by the graphic
under the memory slider in the CPU & Memory configuration panel.

Antivirus software may slow down your virtual machine: Windows may become slower after
you install antivirus software. To be protected, you have to sacrifice performance.

Note: Do not install more than one Windows antivirus program.

Run fewer virtual machines at once: If you are running multiple operating systems at once
using Parallels Desktop, stop one or more of them to improve performance of the others.

Run Windows locally: If you start Windows stored on an external storage device connected to
your Mac (for example, an external USB disk drive), its performance will be lower than if it were
stored on your Mac.

Tune Windows for speed: To speed up Windows, select Tune Windows for speed in the
Optimization pane (p. 100).

Disable log messages: If you select Use detailed log messages in the Advanced pane of
Parallels Desktop Preferences, Parallels Desktop will start creating a more detailed log file. It
can be helpful for the Parallels support team, but uses more hard disk space and may slightly
lower the system performance.

Pressing Ctrl+Alt+Del

As a Windows user, you might know that you can press the Ctrl+Alt+Del key combination to make
available troubleshooting options, such as starting the Task Manager or changing a password.

To mimic pressing Ctrl+Alt+Del in Parallels Desktop:
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= Press fn+Ctrl+Option+Del.

My Password Isn't Working

If Parallels Desktop doesn't accept your password, try the following:

e Be sure that Caps Lock is not on. If Caps Lock is on, an indicator appears in the password
field. To turn Caps Lock off, press the Caps Lock key.

Password: | |

= Be sure that the keyboard is set to the correct language. If the keyboard is set to a language
that doesn't belong to the group of Romance languages, an icon in the password field indicates
the keyboard language setting.

Password: | =|

My Virtual Machine Doesn't Boot

If your virtual machine doesn't boot correctly, most probably it's because there isn't any operating
system installed. To install an operating system, do the following:

1 Prepare the OS installation media:
= If you have an OS installation disk, insert it into the DVD drive of your Mac.
= |f you have a USB drive with the OS installation files, connect it to your Mac.
= |f you have a disk image, copy it to your Mac.

2 Restart the virtual machine by doing one of the following:
= (lick Actions > Restart.
= Click the Parallels icon Il in the menu bar and choose Actions > Restart.

3 And follow the onscreen instructions.

I'm Having Problems Connecting to the Internet

When you install Windows, it is automatically configured to share your Mac's Internet connection.
For details on configuring Windows' network and Internet connection, see the section on
connecting to the Internet or a network (p. 95).
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Configure 5.1 or 7.1 Surround Sound in a Virtual
Machine

If you have a 5.1 or 7.1 surround-capable sound card connected to your Mac (via USB or FireWire),
you can use it in your virtual machine. Follow these steps:

Step 1. Configure the sound card in Mac OS X.
Step 2. Select the sound card as the sound output device in the virtual machine configuration.

Step 3. Configure the sound card in the guest operating system.

Configure the sound card in Mac OS X

To configure a sound card in Mac OS X:

Start the Audio MIDI Setup application (you can find it in ZApplications/Utilities).

2 Select your 5.1 or 7.1 surround-capable sound card and choose the necessary sample rate
and bit depth from the Format pop-up menus.

Note: Make sure these settings match the appropriate settings for the sound card.

3 Click Configure Speakers, select Multichannel and choose the necessary type of output from
the pop-up menu.

4 Set this sound card as the default output device in Mac OS X: select it in System Preferences
> Sound > Output.

Select the sound card as the sound output device in the virtual machine
configuration

After you have configured the sound card in Mac OS X, select it as the sound output device in the
virtual machine configuration:

1 Do one of the following:
= Click the Parallels icon I in the menu bar and choose Configure.

= |[f the Parallels Desktop menu bar is visible at the top of the screen, choose Actions >
Configure.

Click Hardware and select Sound.
Make sure the Connected option is selected.

Choose Default from the Output menu.
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Configure the sound card in the guest operating system

Configure the sound card in the guest operating system.

In Windows 7/Vista:
Click Start > Control Panel > Hardware and Sound >Sound.

On the Playback tab, select Parallels Audio Controller and click Configure.

Select 5.1 Surround or 7.1 Surround (depends on your sound card), click Next several times,
and then click Finish.

On the Playback tab, select Parallels Audio Controller again and click Properties.
Click the Advanced tab and choose the sample rate and bit depth.

Note: The specified settings shouldn't be higher than the same settings specified in the Audio MIDI
Setup application in Mac OS X (described above).

6 When ready, click OK twice.

In Windows XP:

1 Click Start > Control Panel and double-click Sound and Audio Devices.
2 On the Volume tab, click Advanced in the Speaker settings section.

3 On the Speakers tab, select the necessary speaker setup.

In Linux:

You can try to follow these general guidelines to use the 5.1 or 7.1 surround-capable sound card in
Linux:

1 Click System > Preferences > Sound.

2 On the Hardware tab, choose the necessary speaker setup from the Profile menu.

I'm Having Problems with Antivirus Software

Because of the close integration between Parallels Desktop and Mac OS X, some Parallels Desktop
processes may be detected as malicious by antivirus software installed on your Mac.
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To prevent the antivirus software from blocking Parallels Desktop processes, perform a full system
scan using the antivirus software, and then if no viruses are detected, add the Parallels Desktop
processes to the list of trusted processes. For information on how to do this, refer to your antivirus
software Help.

Important: The names of Parallels Desktop processes usually start with prl or parallels.

The F8 Key Isn't Working Correctly

In Mac OS X, the F8 key and Ctrl+arrow key combination are reserved for triggering Spaces (a
feature that lets you organize your windows on multiple desktops). Because of this, the F8 key and
Ctrl+arrow key may not function correctly with Windows programs.

If you are experiencing this problem, change the Spaces hotkeys settings. See Mac Help for more

information. From the Finder, choose Help > Mac Help or Help > Help Center and search for
"Spaces."

A Password is Required to Open the Virtual
Machine Configuration

In Parallels Desktop 12 activated with the volume license product key, virtual machine configuration
can be password protected from being viewed and edited.

So if you're requested to enter the password to open the virtual machine configuration and you
don't know it, contact the person who gave you this virtual machine (in most cases, it's your
system administrator).

Windows or Windows Programs Ask for
Reactivation

When you first install Windows on a PC, Boot Camp partition, or virtual machine, you must activate
Windows to use it. You can activate Windows over the Internet or by phone.

Once activated, every time you start Windows it checks whether it is running on the same hardware
on which it was originally installed. When you import Windows to Parallels Desktop from a PC or
create a Boot Camp virtual machine, Windows detects that the virtual hardware is different and
may require reactivation, depending on the version of Windows you’re using and Microsoft’s
licensing policy.

206



Tips and Troubleshooting

Windows or Microsoft Office asks for reactivation

If you imported Windows from a PC or created a Boot Camp virtual machine and Windows or
Microsoft Office asks for reactivation, try to reactivate it over the Internet or by phone with Microsoft
Support.

Note: For the detailed information on how you can reactivate Windows or Microsoft Office, please refer
to the Windows/Microsoft Office help resources.

If Windows or Microsoft Office has reached the activation limit, you won't be able to use it in a
virtual machine. In this case, you can do one of the following:

- [f Windows cannot be reactivated in a Boot Camp virtual machine, work with Windows by
booting your Mac directly into Windows.

= Buy a new activation key to activate Windows in a virtual machine.

Third-party application asks for reactivation

If you imported Windows from a PC or created a Boot Camp virtual machine, some third-party
applications that are tied to the hardware on which they were originally installed may ask for
reactivation. In this case, you can do one of the following:

= If you choose to work with an application in a virtual machine, contact the application vendor for
help. The vendor may give you another activation key or offer to deactivate the application on
the PC or Boot Camp and activate it in the virtual machine.

Important: If the vendor gives you or you decide to purchase a new activation key, please note that
reactivating an application with a new key in a virtual machine may break its activation on the Boot Camp.
[t means that if you later decide to work with the application by booting your Mac directly into Windows, it
will require reactivation.

= |f an application asks for reactivation in a Boot Camp virtual machine, work with the application
by booting your Mac directly into Windows.

Manage Virtual Machines via Command Line
Interface

In Parallels Desktop for Mac Pro Edition, you can create and manage your virtual machines via the
command line interface. To learn more about the commands and options, please refer to the
Parallels Desktop Pro Edition Command-Line Reference guide available online.
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Change Password in Windows via Command
Line Interface

To change your Windows account password via CLI, do the following:

Note: You can do this in Parallels Desktop for Mac Pro Edition only.

1 Start Windows (p. 31).

2 Launch Terminal in OS X (Applications > Utilities > Terminal) and find out Windows UUID
(Universally Unique Identifier) by executing the following command:
prictl list --all

The output may be as follows:

uuiD STATUS 1P_ADDR NAME
{6F05fe58-2ef6-4049-847a-c393F1077658} running = Windows 7

6f05fe58-2ef6-4049-847a-c393f1077658 is the Windows UUID.
3 Change your Windows account password by executing the following command:
prictl set <Windows UUID> --userpasswd <account_name>:<new_password>

This command may look as follows:
prictl set 6f05fe58-2ef6-4049-847a-c393F1077658 --userpasswd Appleseed:qwerty

If you see the following output, the password has been changed successfully:
authentication tokens updated successfully.

Configuring a Network in Linux

When setting up network in Linux, you may need to configure the DHCP client to send the virtual
machine's ID in DHCP requests. For information on how to configure your DHCP client, refer to the
DHCP client documentation.

For example, in Red Hat Linux guest OSs, you need to edit the DHCP client configuration file.

1 Open the dhclient. conf file and make sure that the following lines are present.

interface "eth0" {
send dhcp-client-identifier 1:<MAC address>;
¥

2 If there are no such lines, add them manually to the file and save it.

When the dhclient.conf file contains these lines, DHCP client sends the virtual machine's ID to
the DHCP server. The DHCP server sends an IP address in response.

Tip

To locate the dhcl ient.conf file, in a terminal, enter:
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strings /sbin/dhclient | grep etc | grep dhclient.conf

or:
rpm -gql dhclient

Installing the GCC Package and Kernel Sources
INn Linux

When installing or upgrading Parallels Tools in a Linux virtual machine, you may need to install the
gcc package and kernel sources in your Linux guest OS. Kernel sources can be either downloaded
from the Internet or installed from Linux distribution disks.

To install the gcc package and kernel sources in the RHEL/Fedora/CentOS Linux distribution, enter
the following command in a terminal:

yum install gcc kernel-devel
make

To install the gcc package and kernel sources in the Debian/Ubuntu Linux distribution, enter the
following command in a terminal:

apt-get install gcc make linux-headers-$(uname -r)

For information on how to install the gcc package and kernel sources in other Linux distributions,
refer to the documentation for these distributions.

If you still experience any problems, try to find a solution in Parallels Knowledge Base or refer to the
Parallels support team http://www.parallels.com/en/support/desktop/.

Checking the Build Number

To check the version and build number of the Parallels Desktop software you are using, do one of
the following:

= Click the Parallels icon Il in the menu bar and choose About Parallels Desktop.

= |f the Parallels Desktop menu bar is visible at the top of the screen, choose Parallels Desktop
> About Parallels Desktop.

A window appears showing the build number.

Note: The window that appears also provides you with other useful information about your copy of
Parallels Desktop, including the licensing information and a link to the Parallels support web page.
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Send Technical Data to Parallels

To help improve the quality of Parallels Desktop, you can send technical data to Parallels.

If Windows is forced to shut down because of an error, Parallels Desktop automatically opens a
Send Technical Data form. If you notice unusual behavior in Parallels Desktop, you can also send
technical data manually.

To send technical data:

1 Do one of the following:
= Click the Parallels icon Il in the menu bar and choose Help > Send Technical Data.

= |[f the Parallels Desktop menu bar is visible at the top of the screen, choose Help > Send
Technical Data.

2 Describe what you were doing when the problem occurred, and fill out the form.

Note: You can review the problem report components that will be sent to the Parallels support team
and deselect some of them in the Parallels Problem Report Details window, if desired. To open this
window, click See Details.

If Parallels Desktop auto-generates a problem report, the report window contains the Send a
solution to me when available option. After the report is sent, Parallels engineers start
investigating the problem. When they find any workaround or get any news about the reported
issue, you will be notified by email.

3 Click Send Report.

Parallels team uses error reports to improve the product quality but doesn't respond to them.

Request Support

To contact the Parallels support team for assistance:

1 Do one of the following:
= Click the Parallels icon Il in the menu bar and choose Help > Request Support.

= |[f the Parallels Desktop menu bar is visible at the top of the screen, choose Help > Request
Support.

2 Follow the onscreen instructions.
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More Resources

For more information and help using Parallels Desktop, see the following resources:

= Parallels support website: The Parallels support website includes product help files and a
FAQ section.

= Parallels Knowledge Base: This online resource has valuable articles about using Parallels
Desktop and other Parallels products.

= Online documentation: You can find PDF user guides for Parallels Desktop and Parallels
Transporter online by choosing Help > Online Documentation.

e Parallels Command Line Reference Guide: This document, available on the Parallels Online
documentation page, has information on using the prictl command line utility to manage
Parallels Desktop and its virtual machines from a terminal.

= Parallels API references and the SDK programmer's guide: These guides for [T-
professionals can be found on the Parallels Online documentation page.

Feedback

= Parallels welcomes your feedback on how to make our documentation more helpful. You can
submit feedback using the Documentation Feedback form on our website
(http://www.parallels.com/products/desktop/support/).

In This Chapter

Visit the Parallels Desktop Twitter and Facebook Pages..........ccvvvvvviiiiiieeiiviviiiiinnn, 211

Visit the Parallels Desktop Twitter and Facelbook
Pages

To keep up with the latest news and updates, you can visit the Parallels Desktop Twitter and
Facebook pages. Choose Parallels Desktop > About Parallels Desktop and click Our Twitter or
Facebook page.
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CHAPTER 8

Glossary

This glossary defines terms and spells out abbreviations used in Parallels Desktop documentation.
References to terms defined elsewhere in the glossary appear in jtalics.

Administrator. A user with administrative privileges.

Activation key. A unique set of symbols that activates the Parallels Desktop application on your
Mac and lets you use the Parallels Desktop functionality to its full extent.

Active operating system. The operating system where Parallels Transporter Agent is launched.

Active volume: The volume of the physical source computer that is used as a boot volume for the
active operating system.

Bootable hard disk. A disk used by the operating system to boot from, usually a disk that has an
operating system installed.

Boot Volume. A hard disk partition from which the operating system boots.

Boot Camp partition. A partition on the hard disk of your Mac that can be used for installing a
Windows operating system on it (for Mac host computers only).

Bridged networking. Virtual machine network connection mode that enables the virtual machine to
appear as any other computer on the network, with its own IP address and network name.

Coherence. One of the view modes you can use to work with Windows. When Windows is in
Coherence, its desktop is hidden and Windows applications appear on the Mac desktop next to
your Mac applications, as if they were all part of a single operating system.

Configuration file. A file specifies the virtual machine's hardware configuration, the devices it uses,
and other settings. It is created automatically when you create a new virtual machine. See also PVS
file.

CPU. Stands for central processing unit. It is an internal part of the computer. See also Processor.

Disks in the old format. Disks of virtual machines that were created in Parallels Desktop 2.5 and
earlier or Parallels Workstation 2.2.

Disks in the new format. Disks of virtual machines that were created or used in Parallels hardware
virtualization products starting from version 3.0.
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Expanding format. A virtual hard disk format. An expanding virtual hard disk image file resides on
your host computer and is small initially. Its size grows as you add applications and data to the
virtual machine.

FireWire connection. A wired connection that enables a high-speed data transmission between
computers.

Guest operating system (guest OS). An operating system installed inside your virtual machine.

Host computer: The computer that is used to run virtual machines. In case of Parallels Desktop for
Mag, it is your Mac. In case of Parallels Desktop for Windows or Parallels Desktop for Linux, it is the
Windows- or Linux-based physical computer where Parallels Desktop is installed. In the Parallels
Transporter documentation, this term may define the computer that hosts the result of migration.

Hot key. A user-defined key or combination of keys that provides quick access to applications and
commands. See also Shortcut.

HDD file. During the creation, the virtual machine acquires a virtual hard disk file with the .hdd
extension. See also virtual hard disk file.

Host-only networking. Virtual machine network connection mode that creates a private network
between the host computer and its virtual machines, which makes the virtual machines available
from the host computer only.

ISO image. A special file that contains the entire contents of a CD or DVD disc commonly used to
install an operating system.

Image file. A single file containing the complete contents and structure of a data storage medium
or device, such as a hard disk drive, CD, or DVD.

IP address. A unique address that is assigned to a physical computer or a virtual machine that
participates in computer networking.

Linux computer. A physical computer that has a Linux operating system installed.
Merged disk. A split disk whose parts were merged into a single disk.

Migration. The process of transferring data from a physical computer or a third-party virtual
machine into a Parallels virtual machine or virtual disk.

Modality. One of the view modes you can use to work with Windows. In Modality mode, the
Windows desktop appears in a window and scales in size as you resize the window. Also, you can
set this window to always stay on top of other windows, and you can adjust its transparency level
S0 you can see through it when you're working with other applications.

OS. Operating system.

Parallels Desktop for Mac. An application that enables you to create, manage, and use virtual
machines on your Mac.
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Parallels Tools. A set of Parallels utilities that ensures a high level of integration between the
primary and the guest operating systems.

Parallels Transporter. An application that uses data of a physical or virtual computer for creating a
Parallels virtual clone of this physical or virtual computer. The resulting virtual machines can be used
with Parallels Desktop.

Parallels Transporter Agent. An application that collects data on a physical computer and
transfers it to Parallels Transporter installed on your Mac.

Plain format. A virtual hard disk format. A plain virtual hard disk image file resides on the host
computer and has a fixed size that cannot be changed.

Preboot Execution Environment (PXE). An environment to boot computers using a network
interface independently of available data storage devices (like hard disks) or installed operating
systems.

Primary operating system (primary OS). Operating system that controls the I/O devices of the
computer and that is loaded when the physical computer is turned on. It is the operating system of
the physical computer where the Parallels Desktop application is installed.

Processor. The central processing unit, or CPU. It is an internal part of the computer.

PVS file. A virtual machine configuration file that contains information about the virtual machine
resources, devices and other settings.

Shared networking. Virtual machine network connection mode that allows the virtual machine to
use the host computer network connections. In this mode, the virtual machine is invisible to other
computers on the network the host computer belongs to.

Shortcut. A user-defined key or combination of keys that provides quick access to applications
and commands. See also Hot key.

Snapshot. A copy of the virtual machine state at a particular point of time. The files related to
snapshots are stored in a special subfolder in the virtual machine's folder.

Source computer. The computer from which you are going to migrate data using Parallels
Transporter.

Split disk. A split disk is cut into 2 GB pieces, but is stored as a single HDD file. Split disks allow
you to transfer the data stored on a split disk piece by piece using a USB drive or other media that
have limited space and cannot store a large virtual hard disk image file.

Terminal. In Mac OS and GNU/Linux operating systems, a utility that enables you to access the
command line.

Third-party virtual machine. A virtual machine created in a third-party virtualization product, that
can be converted to a Parallels virtual machine with the help of Parallels Transporter.

214



Glossary

Virtual hard disk (virtual disk). A file that emulates the virtual machine's hard disk.

Virtual Machine. The computer emulated using Parallels Desktop. A virtual machine has its own
virtual hardware and requires an operating system to control its hardware. The installed operating
system and its applications are isolated inside the virtual machine and share physical hardware
resources of the host computer.

Virtual Machine Configuration. Like any physical computer, a virtual machine has its own
configuration which is set during the creation and can be later modified. The virtual machine
configuration settings are stored in a PVS file.

Virtual machine files. Files stored in a virtual machine folder. A virtual machine has at least two
files: configuration file and virtual hard disk file.

Virtual hard disk file. During the creation, the virtual machine acquires a virtual hard disk file with
the .hdd extension. This file performs the functions of a real hard disk. See also HDD file.

Virtual machine template. A virtual machine that can be cloned to multiple virtual machines that
will have the same configuration and data that the virtual machine template had.

VM. See Virtual Machine.

Windows computer. A physical computer that has a Windows operating system installed.
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